Amazon Echo and Virtual Switches stopped working


#1

This used to be working just fine. Now, after the Monday Night/Tuesday Amazon Echo update, whenever I ask the echo to trigger a device that is controlled by a virtual switch, I just get a failed tone.

I removed all my devices in the Alexa app, unlinked and relinked SmartThings, and rediscovered devices. I get the exact same failed tone.

Does anyone know what happened? All the physical light switches still work fine, it’s just the virtual that are broken. And they are only broken on the Echo, they still work fine in the ST app. Amazon is no help as I can’t get past the canned response help desk.


(Jason "The Enabler" as deemed so by @Smart) #2

Yeah, I’ve noticed a problem as well, but it isn’t just the virtual switches. It sends to be just random things for me. Not sure what’s up.


(Preston Todd Bradford) #3

Not 100% sure on this but it seems to be two word groups. My Alexa group “Todd Leaving” running virtual switch “Leaving” quite so I renamed the Alexa group to “Garage” still running virtual switch “Leaving” and it now works. It was failing on “goodbye” too. One word, but sounds like two? I read on Reddit that Amazon is aware of the issue.


(Eric) #4

different words fail from day to day, then succeed on the next day. My echo/Smart Home/ group-name setting virtual switch “TV Mode” and “Watch TV” both failed 3 days ago, then “TV Mode” worked 2 days ago, then both worked last night. Other virtuals with different naming, did accept commands.

I have been assuming it’s Amazon tweaking the engine and/or reserved words, and getting some user-hate-feedback before they un-reserved the words.


#5

My HA device bridge items work with the EXACT same words. Something else is up here. I’m just going to use the HA bridge for a while.


(Jeff W) #6

I have a weird issue where Alexa would turn on a smart bulb for me, but when I asked it to turn it off, I would hear nothing or the error tone and nothing would happen. Looking at the Alexa app, it sees the voice command properly, but just isn’t doing anything.

To work around it, I created a group in the Alexa app and added this one thing (bulb) to it and oddly enough, it turns off without any issues.

For those who are curious, my “Thing” name is Driftwood (it’s a driftwood lamp).


#7

Can’t turn off my harmony activities but can turn on, have not had time to mess with it yet. All these failures is making me reach for the remote :smiley:


(Jason "The Enabler" as deemed so by @Smart) #8

I’m wondering if this could be a problem.

I just received the weekly email from Amazon about echo. Lutron switches are now fully supported.

I’m willing to bet that is why our virtual switches are not working right.

I do know that when they integrated the thermostats I lost control of a lot of my things. I had to rename them because the words were apparently reserved for other items.


(Bobby) #9

Or it might be ST…


#10

The HA bridge is working for me with the EXACT same names as the ST virtual switches that were failing.

I can confirm it was switches with two words in ST, when I changed the names to a single simple word, like “car” instead of “my car” it started working.


(mytaytay) #11

Logitech activities began to fail for me 3-4 days ago, as well.
Using remote in the interim…can you imagine?

Love the instability for now regardless of whether it’s SH, Echo, etc.


#12

Some new naming quirks on the Echo side this week made some previously acceptable switch names unusable, including Netflx and Hulu. .(hmmmm…)

There are some possible workarounds.

One) use an echo group (created through the Amazon app, not the SmartThings app) that echo will accept. You don’t have to change anything else, and you can just use trial and error to find one that you like that echo will accept. For example, it appears that “Flicks” will work, although “Flix” and “Netflix” don’t.

More discussion in the naming quirks thread:

If the problem is on the smartthings side, this won’t help. But if you just run into one of the new reserved words, it will.

  1. use IFTTT with Alexa as the If and harmony as the That. This still works, you can say “Alexa, trigger Netflix” and echo will take it. But you do have to include the “trigger” phrase, and some people don’t like that.

  2. use the free app Yonomi to connect echo and harmony. This has the same name and quirks issues as 1), but it takes,smartthings out of the picture. So if you run into problems with both a new echo reserved word and some issue on the SmartThings side, you can resolve it this way. Some people find that yonomi runs faster then IFTTT, others find it about the same.


(Tommy Tucker) #13

Having the same issue which started pretty abruptly around a month or so ago. Everything was working more or less fine the months prior. Echo suddenly responding with “That command doesn’t work on that device”, or just simply making the error tone and doing nothing. Strangely enough it will turn on certain devices no problem and then give that response when trying to turn it off (or vice versa). It doesn’t seem to discriminate against either virtual switches or physical devices. Was having constant trouble with “Turn on the TV” through Harmony which worked previously and has since randomly began working again. My window AC unit is now having issues and it is plugged into a ST outlet. The device is saved as A.C. I’ve tried using the group a. c. (how echo was recognizing it in the history), AC, ac all with no success. The AC will turn off with any of those voice commands but not on. Saved it under the group name “Air conditioning” and now I get “That command doesn’t work on that device” and then it powers on… Tried voice training, repair z wave network, and everything else op tried. Appears JDRoberts advice is the best solution until someone else can shed more light on what the problem may be.


(Glen King) #14

Hmmm. Will power users soon be griping as much about Echo as about Smartthings? lol

Seriously, we have to keep firmly in mind the fact that the automation/integration wave is just beginning. So we can expect to see ‘major’ problems in all these systems, at least for the near future.


#15

I had this same issue creating virtual switches to run the default routines in SmartThings. I called the switches the name of the routine… “Good Morning” and “Good Night” worked. “Goodbye” and “I’m Back” did not work. I also tried “I’m Home” and “Im Back” and those did not work, either. I tried “Hello” and it started playing “Hello” by Adele instead. I checked the history, and every time it heard me correctly, but did nothing or the wrong thing.

In order to get “I’m Back” and “Goodbye” to work, I ended up renaming them “Apartment” and “Good Bye.” So it’s interesting to note that splitting “Goodbye” into two words fixed that one.


#16

This is a bug that was introduced into echo (nothing to do with smart things) with their April 4 update. They are aware of it and are working on a fix. Basically, echo does hear you correctly but then the echo cloud gets confused about what is a Music request and what is a Home automation request. This has caused some switches which previously worked to stop working. See the following:


(Richard G) #17

until recently i had a virtual switch which fired the Good Night Routine…

I named the virtual switch “night mode”… if i click the switch within smartthings it works but if I say Alexa turn Night mode on it doesn’t seem to work…

Any thoughts?


(Jason "The Enabler" as deemed so by @Smart) #18

Try these two things

  1. Take the word mode out of the name.
  2. when taking to Alexa, say, “Alexa turn on night mode switch”

When I was using switches to do this I started having the same problem.

We started having trouble with certain words when Amazon stepped up the game on the thermostat integrations, and especially after both ecobee and nest were done.

Not sure if you’ve seen it yet, but there is a new game in town for echo.

Check this out… I’ve noticed that going through this skill a lot of those reserved words aren’t causing nearly as much trouble.

Plus, you can just say, Alexa, tell home to set the mode to night.