SmartThings Alexa App Error

I get an error after trying to save the Alexa app settings as shown below. I asked a friend with a similar setup as mine to try and save his Alexa app settings and he receives the same error. Everything seems to be working in spite of the error. I have tried toggling the switch and selecting devices individually but get the same results. I do have a lot of devices but I hope that wouldn’t be the cause. Any ideas?

I’m getting the same error.

Hey Stillme, if you’re getting an error of not saving a page under Device setting then please reinstall the Alexa app and prepare setup device but again face this problem then Contact Amazon Alexa support. They’ll give you a specific solution.
I’m also facing the problem of Unable to load the page while clicking on the Setting tab but sometimes it works and sometimes it’s not working. I tried to reinstall Alexa App many times but its maybe not responding due to Wi-Fi fetching error, but Alexa’s support gave me the best solution. Thanks to them.

I am fairly certain that the problem I have is due to the large number of devices on my system. There are numerous apps that time out trying to load all of the devices on my system. A member of the support team on this forum told me that there is not much hope of it ever being fixed on the classic app even though just changing the time allocated for a time out would probably solve the issue.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.