SmartPower Outlet turning on and off but not actually passing power through


I hope someone can help. One of my SmartThings SmartPower Outlets (UK version) has started acting strangely. You can turn it on and off using the App or Alexa (you can see little blue light on the side of the outlet turning on and off) but it does not actually seem to be letting power through to whatever is plugged in to it.

It was working fine but since I changed what was plugged into it the above has started happening, even if I swap back to what was originally plugged in.

It sounds like a device failure but was just wondering if anyone else has seen this and knows of a fix before I attempt to return it.

Many thanks,

Have you tried plugging something else into it? A simple device with no intermediate electronic interface like an old fashioned lamp or something. Does the device that isn’t working work in an outlet if plugged in directly? It’s not a microwave or refrigerator or something with a large draw is it?

1 Like

OK, just 2 quick questions. Have you tried power cycle the outlet? Meaning turn the circuit breaker off then on or unplug the outlet and plug it back in.
Is this plug a dimmer or just an on/off? Brand and model would also be easier to get help.

1 Like

Wow, thanks for quick response.

Yes I’ve tried turning it on and at at the socket, using the app, using the button on the side of the plug and completely removing it from the socket and tried the same again in other sockets with various things plugged in to it.

It is a SmartThings SmartPower Outlet (UK version). It’s just an on/off switch.

To confirm: The device that were plugged in work fine if plugged in directly. And they are not anything that has a large draw, just lamps.

So plugging this same device back in still working and nothing else? I suggest you return this device since there are a couple of reports about the plug contacts not making good contact and overheat.


No, now the original lamp that was plugged in doesn’t work either. I suspect you are correct about the contacts. I’ll send it back.

Thank you.

1 Like

Those run off of relays and my guess is that the relay is not getting triggered and current is not passing through it.

I have a couple of these now that have done a similar thing.
One has fixed itself on rather than off.

They don’t take a lot of load before burning out the relays.

I only use these sockets for zigbee repeaters now… wouldn’t trust them with ANY load.
There have also been more serious problems on other threads.

If its still under warrenty then you should be able to get it replaced but I personally wouldn’t trust the replacement.

1 Like