SmartLighting (Delay when turning on)


(Jake) #1

Hey everybody,

I bought a GE Z-Wave Smart Fan Control switch(12730). I hooked it up and have it working in my bedroom to turn on/off my ceiling fan. I set up a smartapp to turn on/off my two nightstand lamps when I hit the switch. There’s a huge delay.

Tap the switch: Fan comes on at 2 seconds, 1 nightstand lamp comes on at 7 seconds and the other lamp comes on at 8 seconds.

Is there any way to speed up the delay? I walk into my room and stand in the dark for a few seconds at night. :slight_smile:

Thanks!

-Jake


(Paul) #2

Have you tried a zwave repair since you added this equipment? That could help a little.

There will always be some delay, but my living room has a similar setup, and the delay is more on the order of 3-4 seconds.


(Jason "The Enabler" as deemed so by @Smart) #3

What you are seeing is the delay in the switch updating its status with the hub. The system didn’t know to turn on the lights until it knows the switch is on.

To confirm this, do the following:

  • With the ceiling fan and all lights off.
  • Open the app and go to the ceiling fan switch device screen (where you turn it on/off).
  • physically press the switch on the wall and count how long it takes for the status in the app to update.
  • also take note of how long after that the bulbs turn on.

Questions:

  • what kind of bulbs are you using?
  • what device handlers are you using fur the switch and bulbs?
  • what smart app are you using for this automation?

I’m trying to determine if you are running local or in the cloud.


(Jake) #4

Thanks for the responses guys. I’m not home now to test the timing in the app but here’s the answers to your questions:

Questions:

  • what kind of bulbs are you using? (EcoSmart dimmable CFL bulbs)
  • what device handlers are you using fur the switch and bulbs? (wemo insight switch and GE Z-Wave Lighting Dimmer - 12718)
  • what smart app are you using for this automation? (SmartLighting)

(Jason "The Enabler" as deemed so by @Smart) #5

My bad, the bulbs don’t matter. I thought you had smart bulbs turning in with the press of the switch.

The wemo switch is Wi-Fi so you are definitely ruining in the cloud.

I’m pretty sure what you are seeing is the delay in the switch updating the status and in the delay of the cloud.

I do not see a way you can really improve on this…

Do you have any motion sensors?


(Eric) #6

“Alexa turn on the bedroom”


(Ben Lebson) #7

Your issue is that the GE switch is not an instant status switch, it takes a few seconds before ST is aware of it’s state change. I have a setup in my home which runs completely locally (z-wave switch triggers z-wave outdoor plug-in socket) and still takes anywhere between 1-8 seconds to react.


(Jason "The Enabler" as deemed so by @Smart) #8

I have to counter you on this… My GE switches are extremely fast to update… But that is not always consistent.

The reason I asked if he has any motion sensors is this.

Using CoRE I created a piston that whenever a moron sensor good arrive it fires and runs the refresh command on several switches that I always want up to date.

I have a lot of moron sensors do it works really well.


#9

My house needs a moron sensor. Now. :japanese_goblin:{looks meaningfully at third housemate}


(Jason "The Enabler" as deemed so by @Smart) #10

Wow! I even had to read that one several times to figure out what I was talking about!