Big delay when using Z-wave in-wall switch to turn on Zigbee bulb


#1

Okay, so I have two scenarios where I have a room+closet, and I want the GE in-wall Z-wave switch to turn on both the overhead bulb and a non-wired Zigbee bulb in the closet. There is a massive delay in both instances, and I’m trying to identify the problem. The delay is sometimes as much as 5-10 seconds. Other times it’s quick. No telling.

I don’t think it’s necessarily Z-wave <-> Zigbee communication delay, because I have lots of Z-wave door sensors that are instantly turning on Zigbee bulbs. This seems to be isolated to the in-wall switches controlling bulbs on another circuit.

Is there any way around this? Would I have better luck with a Z-Wave bulb? Or changing to a Zigbee switch?


#2

I’m sure that’s very frustrating. We need to do a little detective work first. Let’s leave the zigbee bulb out of it for a minute.

A) If You’re saying that you have a GE zwave loadbearing switch installed on the circuit that controls the light fixture and flipping the switch manually has a delay In the light coming on, then that’s a problem with either the switch or the wiring, because the switches work manually at the wall even if your hub is missing all together.

B) If instead you’re saying that when you flip the switch at the wall the ceiling light comes on immediately, but if you tap the switch tile in the smartthings mobile app there is sometimes a noticeable delay before the ceiling fixture comes on, then the problem is again either a defective radio in the switch or the mesh is weak and the messages are not reaching the switch. ( or maybe there sometimes local interference.)

C) If you’re saying that when you flip the switch at the wall the ceiling light comes on immediately, but it takes a few seconds for the status update in the SmartThings mobile app, then that’s a different issue.

I’m very tired today, so I’m going to have to leave it to other people to continue with this, but based on the answers to the above three questions if it looks like a mesh problem your next step would be to do a Z wave repair.

Again, leave the issue of the zigbee bulb of out of it until you have the speed you want for just tapping the switch icon in the SmartThings mobile app and turning on the ceiling fixture.

Then you can look at the speed of just tapping the bulb icon in the smartthings mobile app and start from there on the bulb. But first get the switch itself up to speed. Then get the bulb up to speed. Then start working on the combination.


(Ray) #3

I know you said z-wave switch but to be clear. This is not a dimmer is it because it usually takes a little longer for smartthings to have status of the switch because of the ramp rate. 5 to 10 secs is definitely excessive. Are you using the Genetic DTH?
How far away is the switch from the hub and any repeater in between? Try doing a Z-wave repair or exclude/pairing again. Also get support involve. They should be able to tell if it’s a mesh or other odd issue.


#4

Thanks for the help guys, here’s what I’ve done so far:

For the record, I use the Osram Lightify Zigbee bulbs.
It’s a dimmer switch, a toggle GE dimmer.
I deleted it from the hub via the IDE, and then re-added it via the app. Generic Device Handler.
Testing reveals normal functioning of overhead light with both the switch and the app - no noticable latency, just as before.
Then I did a network repair, which came up with no issues.
Finally I created a New Lighting Automation with Smart Lighting: Set the switch as the trigger, turn on the Zigbee light when the switch is turned on; turn off as well.

Same delay. It’s inconsistent: Sometimes it will be 1 second, other times 5-10 seconds… I don’t have this problem with Zwave Door Sensors and Zigbee bulbs. They’re near-instant. Only getting the delay with the switches.


#5

Since it’s a dimmer, you’ve probably run into the patent issue. GE does not license the Lutron patents on “instant status” for dimmers. Consequently, the dimmer switches do not immediately report activity to the hub. Non-dimmer switches and sensors do. ( although one of the Lutron patents did expire this year, there is another one that is still active, and so there aren’t any devices that I know of where they didn’t used to have instant status and now they do.)

if it’s really important to you may need to change the switch for one that does do instant reporting (that includes the in wall micros).


#6

Unfortunately I have the exact same issue with a non-dimmer GE switch in another room…


#7

Scratch that, the non-dimmer switch is pretty good. It does get hung up every now and then, but not more than 3 seconds.


#8

The other option would be to use a zwave switch that supports association and use a smart zwave bulb instead of a smart zigbee bulb and directly associate them. That would allow the switch to send a wireless command straight to the bulb without going through the hub. That’s usually the quickest you’re going to get. The only issue with that is you may not get status updated in the SmartThings mobile app right away, it gets a little complicated.

As I said, I’m tired today, and I can’t go through the specs on the GE switch for you, but if you can post the exact model number, someone can let you know if that switch will work with the bulb.


#9

You’ve been super helpful in this and many other threads, so thanks.

I just went ahead and changed it to a non-dimming switch, and it’s better.


#10

Also interesting about the instant status reporting. Not even the 14 series have it. Just another reason for me to wait to upgrade.


(Ray) #11

Just a side note. My GE Zigbee dimmer doesn’t have ramp rate so the status is super quick. Just in case you still want dimming then it’s something to consider. It also helps your zigbee mesh as well.


#12

I did consider trying a ZigBee switch too. I should probably unload a few things first :wink: