SmarthLight app problem with timezone and scheduler


(Nicolas Donoso) #1

I’m using SmartLight App to schedule some lights at specific time.

The problem is that the light is turned one hour before the established program
When I look for the source of problem and I find that the scheduler save the wrong time …

Any idea of how to solve it?

Thanks


(Bobby) #2

Did you have it saved at that time before, and the app failed to update? I am dealing with rhe same problem this morning too. Light should have turned off at 8, but it turned off at 6:30.


(Nicolas Donoso) #3

No, I set the app yesterday to have a nice wake up at 6:10 am but it turned on at 5:10 am


(Bobby) #4

Have you tried hitting “update” in ide?


(Bobby) #5

Can you look at your detail log, mine fires both at set time and earlier?! I guess I need to delete and recreate.


(Mike Thomas) #6

I am not sure if this is related to a problem I am having or not. A few days ago I set up about 10 Automations (using the Smart Lighting SmartApp on my mobile device, not the IDE).

One of those automations (I call it “Upstairs cameras” keeps turning two switches on at 10pm instead of 12am (midnight). Thinking this might be an edge case bug or something, I tried:

  • Set the trigger to 11:59pm instead of 12:00am - no change (still turns on at 10:00pm)
  • This was the only automation that was dependent on Mode - I removed that dependency - no change (still turns on at 10:00pm)
  • Deleted & re-created the “Upstairs cameras” automation (including the dependency on Mode) - no result yet (there is a 24-hour turnaround between each attempt :smiley:

I have confirmed in the device logs (via the App) that it is this automation that is turning on the devices, not some other event.

If I were to try to hit “update” in the IDE, where would I do that? I am logged in to https://graph.api.smartthings.com/ide/apps, but it tells me I have no apps.


(Nicolas Donoso) #7

You have to go to Locations - > installed apps (at the end of the page)

I think that SmartLights App have some bug with timezone and specific time schedule.


(Mike Thomas) #8

Thanks.

BTW deleting and re-creating that one flaky Automation did the trick. Apparently there was an inconsistency between what the app was displaying (midnight) and what the underlying data said (10pm).

Looking back at the history for one of the two devices that this Automation controls, I can see it had (somehow) stored two “on” times - 10pm (wrong) and midnight (correct). But the app was only displaying one “on” time.

I must have fat-fingered something when setting up the automation, but I’m disappointed that the app let me corrupt its internal data.

Mike