Smarthings hub cloud not conecting

which model hub do you have?
switch it from wifi to ethernet cable to see if it connects.

I have the 2nd generation.

Try unplugging it for several minutes. Remove the batteries if you are using them. You had mentioned disconnecting/reconnecting but if you only did it for a few seconds and left the batteries in… that would not work so you need to clarify.

Questions - how many Edge drivers are installed on your hub? What is the color of the led light in the front of the hub? Do you see any activity in the Ethernet port in the back of the hub?

Here are pics.

  • assign your hub to a room (important)
  • unplug it for several minutes and remove the batteries
  • post how many Edge drivers are installed on the hub (in the app, tap on the hub tile, tap the 3 dots and select Driver)

You can also use a community developed to check the number of Edge drivers installed on your hub: API Browser+

Look here to see if your hub and devices also show as offline:

Driver is grayed out

Why is it grayed out?

Works now miraculously. I cleared the cache and plugged it in and nothing up until now. I’ll take it.
Thank you for your time.

I spoke too soon. It is now disconnected again.
I got a new modem yesterday but the router stayed the same. I cannot say its that because I don’t know when this actually began.

Does anyone know exactly why my hub cloud is offline? The threads can be too long and hard to makeout what it actually is?

have you tried rebooting your router?

hopefully, you have opened a ticket with ST support as well

Reboting like a reset? If so I haven’t done that. I am afraid that will delete all the devices.

Yes, I just opened a ticket with them.

No, not a reset. If there is a UI for the router, there is most likely an option to reboot/restart it.

I never tell users to reset… I am anti reset.


What is strange I did the soft reset by pressing the reset with a pin and wait for lights to go red and reboot and the lights didnt change from blue. I also did a hard reset where you disconect the power cable and router, wait 3 min and turned red, blinked blue and solid blue and nothing. I dont think it reset to begin with.
Thoughts? The customer support hasn’t figured it out.

I notice sometimes the cloud is online and other times offline. Could it be the hub going bad?
Also how do you exactly reset v2? Ive looked around and doesn’t do anything when I try.

be aware that resetting the hub may not resolve the issue. Speak to ST support first. A hard reset wipes out everything and forces you to start from scratch… adding all devices back and recreating any and all Automations. But as I mentioned, it is possible you may still experience the same issue before the reset.

Next time your hub shows as Online… look to see how many Edge Drivers are installed on your hub? Have you been installing any on your own or not?

you can attempt a soft reset on your hub which only resets the network settings of the ST hub. Remove the power cord, press and hold the reset button and insert the power cord and keep pressing until the led changes to yellow and release. Then wait about 10 minutes as it will attempt to connect and check for firmware to update.

hard reset instructions are on the following page for Aeotec hubs… reset also applies to the v2 hub.

I did the soft just now. Waiting 10 mins now.
As far as the drivers last I looked was Wemo or something similarly named and zwave smart thermostat that I don’t us anymore with smartthings.

Over 20 mins now blinking purple/white mix. I did diagnostics with the app and ST app, wifi works except no cloud connection.

wifi? v2 hub does not have wifi. model # of hub?

Model STH ETH 200
THE light is blinking magenta after the soft reboot and this is the message I get about wifi. It has ethernet cable.