Smartcam HD Pro will not connect via wifi


(Jonathan Latter) #1

Hi guys I need some help. I’ve got the HD Pro SNH-P-6410 cam and it will not connect to my wifi. I’m using the official app first and following its instructions to the letter… When light flashes red, press button on back for 5 seconds. When light goes green go into wifi settings on phone and find the cam. It’s there and connects to it. I go back to the app and I enter my wifi password. It then says it will take up to three minutes to connect… It doesn’t. After three minutes there is an error.

The camera works fine over cable but I need it wireless. I’m also trying to connect near my router to rule out weak signal (very unlikely anyway). I’m using a Virgin superhub and have no issues connecting the many other wifi devices I have.

I’ve run out of ideas, can anyone help?

Jon


(Micheal ) #2

Had the same problem…try doing the entire setup via the wired cable, including the wireless setup. Then disconnect the cable when the setup is done.

If that doesn’t work, you may want to look at your router to see if there is a “MAC restriction” set up there…you would have to ‘white list’ the device in the list, then it should show up. That is a rare problem, but something I set up for additional security. No one can connect to my wifi without me adding the MAC (yes, for those security people out there, I know there is MAC Spoofing…I am talking casual folks getting on my wifi…not hackers).


(Jonathan Latter) #3

Thanks for the tip. I’ll give that a go. I checked my router settings and I have no restrictions from what I can see (I’ve not set up anything like that anyway - But not a bad idea).


#4

@Johnny5alv. I ended up using the Samsung Techwin SmartCam app to connect it to my wifi, and then SmartThings.

Their website will do the same:

https://www.samsungsmartcam.com/web/

I use the Samsung app and site to validate the camera works whenever ST can’t see it.


(Jonathan Latter) #5

Yes that’s what I’ve been ‘trying’ to use. I tried Smartthings but that didn’t work. I’m just concentrating on getting it to work with its own app


(Jonathan Latter) #6

Got it sorted! That worked a charm thank you.

Just wondering now… The camera is obviously designed to be ‘always on’ but it gets quite warm. So I have to wonder, how much power is it using? Would it be ok to put a smart plug on it and have it only come on when I’m out?.. Or will it loss it’s settings if left off for so many hours…

Thanks again for the help

Jon


(adis) #7

It looks the post was last updated 9 months ago. The issue might not be current anymore.
However, I considered my comments might help someone.
I bought the Samsung SmartCam Pro (SNH-P6410BN) yesterday from BestBuy. It came with a firmware from November 2015. Same like the problem described in this post, it was never detected by the web page at https://www.samsungsmartcam.com/web/ after removing the network cable. As soon as I plugged the cable back, the camera was detected on an internal static IP address. As a last resort I upgraded to the last firmware from June 2016, knowing that this firmware was going to remove the possibility to access the camera’s IP address in favor of the new Samsung’s crappy mandatory software access.
Well, nothing changed and the camera continued to be undetected while wireless. However, I was able to connect to it (wireless) using the IP Cam Viewer Pro Android application from inside and outside of my LAN, emulating a SNH-E6440BN camera.
I have very good incoming audio, but no other settings. The image is very good quality and, I want to believe that after I make any setting (in wired connection) for triggering recordings on the local SD card using Samsung website, they’ll work also in wireless mode.

Conclusion: the wireless connection works fine, but is just not accepted by their own (Samsung’s) web application. Since this three way camera connection is very disturbing/invasive to the majority of users who have external static IP addresses like myself, and to the ones who want to use the cameras only from inside their LAN, I will be returning this camera to the store soon, for a refund. Same for all other 6 I have (SmartCam and SmartCam Plus). My advise to Samsung is: give up any software development and continue producing only cell phones and TV sets. You’ll have only satisfied customers this way.

I hope it helped,
Adis


#8

Mine runs warm too. Just hooked up my Kill A Watt meter, and it ways it’s only pulling 3 Watts. My Iris smart plug (via SmartThings) shows 3.8W. Surprising how warm it feels though!
The specs say 11W, thank goodness it’s not that bad!

I had a heck of time getting mine hooked up to Wifi. Repeated setup several times, did a full reset, talked to support, re-entered the password at least eight times. Not actually clear how I got it running in the end, it just started working after letting it sit around for fifteen minutes after one of the various reset attempts.


Samsung SmartCam: SNH-P6410BN, SNH-E6440BN and SNH-1011ND (+WWW Digest auth) (tested and working)
(JAL) #9

Regarding the RTSP streaming and digest authentication locking out third-party access, I have contacted the Federal Trade Commission (FTC) and filed an official complaint against Samsung Corporation and Hanwha Techwin (the developer of the camera/firmware) regarding this matter. The reason I did this is that the behavior of the manufacturer and/or it’s contracted developer(s) is reprehensible–the company only initiated a firmware update to remove third-party access/development/support after they realized there was revenue to be made through their own service; what’s worse, in the firmware update and the TOS/TOU, the consumer was never informed that A) this was possible, and B) this behavior had been included in the new firmware. The nail in the coffin was the fact that the company also did not A) provide an informed opt-in/out function with the firmware, nor did they B) provide an option to downgrade the firmware (to date). I encourage others to do so as well because after hours of deliberations with multiple representatives across three (3) companies/subsidiaries regarding this firmware issue and the anti-competitive nature of it, the only recourse is first FTC initiated action, and then a class-action lawsuit if the company does not comply. If the FTC cannot take action, I will be submitting this for CAL at earliest, because if it has happened to me (us) it has happened to millions of others undoubtedly across the IP camera marketplace. The FTC website can be used to file the complaint–took me five minutes.


(Alberto Rodriguez) #10

Please let me know how you submitted you complaint as I have 3 cameras that just got the update after being used for almost 2 years with no problems and are just bricks since I can’t use them along with all my other non Samsung cameras. I’m also interested in filing a class action lawsuit if the don’t resolve the matter. I called their tech support and was told that they are no longer allowed to even talk to us about configuring in 3rd party apps. I was involved in the class action lawsuit against Sony on the removal of the ability to install Linux. They never returned the ability but the payout certainly made up for it. If they won’t let us to continue to use the cameras I expect them to compensate us for the trouble they have caused.


(Jon) #11

Make sure you guys are using the correct app. It’s actually the smartcam+ app. The orange one… I couldn’t sync my camera with my wifi until I used that app…


#12

A screenshot would be more helpful than “the orange one”. The visual would give those people a better understanding of exactly which one. :slightly_smiling_face:


(Jon) #13

There you go… My bad…


#14

Reviving this thread to ask a quick question, I finally got my cam to connect by hooking it up directly with ethernet, setting up the WiFi, then disconnecting the network cable. After unplugging it from the wall to move it into position in the room, it seemed to “forget” the WiFi settings and won’t connect; the LED light keeps blinking blue.

The only solution here would be to run a long ethernet cable to the camera to set it up, but that would only work until the power went out, and I’d have to do it all over again. Any suggestions?