Need help joining Samsung SmartCam HD PRO

Purchased the Samsung Smartcam HD Pro - SNH-6410BN and I am not able to join it to the the Hub 2.0. First the HUB could not find it. I followed the directions to plug it into ethernet, power it on and attempt to add. Of course it shows 0 devices found.

All outlined here:

Not mentioned in the documentation you can hold the wifi button on the back of the camera for 5 seconds to put the camera in discovery mode. This allows Smartthings to see the camera however it gets stuck at “Please Wait While We Check for Password”. It stays at this screen for over 10 minutes where I just cancel the add. I tried again with the same results. I setup the camera via the Samsung App and it works fine with that app. I tried adding the camera into smartthings this time not as a new camera but a camera already setup. It couldn’t find any cameras this time. I put the camera in discovery mode by holding the wifi button and sure enough it found it. I got the “Please Wait While We Check for Password” alert again and couldn’t add it.

Any Ideas? Support is too slow.

Samsung Support was able to help me out.

Here are my steps:

  1. Hold the reset button in until the light turned red
  2. open the Smartthings App,
  3. attempted to add Samsung Smartthings Camera, it doesn’t show up
  4. Hold the WiFi button on back of camera for 5 seconds, status light will turn yellow, and camera will show up in SmartThings App
  5. Assign Camera Name - Next
  6. It was again stuck at checking for password so I tapped the WiFi button on back of camera and it went to the next page on adding a password.
  7. This page was a bit tricky because it doesn’t accept a long or complex password. I was able to insert the password and success it works in the smartthings app.

I noticed almost a 10 second delay which I am not happy about but I was able add the camera to the Samsung app and it works fine in there. Not sure Smartthings is fully developed for this camera yet but I got it working.

I had the same problem connecting my HD camera to smart things I finally got it to work except the sensors does not work on it when it detects motion it will send me a motion detective from within the SmartCam app it will never alert smart things that it has heard something or something moved therefore it will not activate my siren it just works as a camera

after the recent update - I cannot re-add the camera at all - seems like it doesnt authenticate/query for a password

I see:
debug checkCameraForPassword
info Verified Camera: SNH-P6410BN (9663)
debug getChildDevices(false), children=0
info Verified Camera: SNH-P6410BN (9663)

but thats it - no step to enter the password …

have done multiple reboots, full resets etc - simply doesnt work …

this is all I get: “Please Wait While We Check for Password”

any idea @posborne @nastevens
even tried all 3 dth
Samsung SmartCam 6414
Samsung SmartCam 6417
Samsung SmartCam HD Pro (UK)

I just tried a 6417…no luck. Pretty crazy that it won’t work.

Had the same issue, factory reset and start from scratch. Something about an existing password it doesn’t understand. Reset will clear the password and allow for setup again.

Plug in, hold reset until the device turns off.

Mine were refurbished, so I assume someone already set a pass.

Mark - SmartCity enthusiast.