SmartApps light automation not obeying mode


#1

I’ve setup lighting automation based on time of day using the Smart Lighting SmartApp.

I’ve set the “Only when mode is” condition to “Away” but it is ignoring my mode setting - the lighting rules are always active regardless of my Security setting - ARM (AWAY), ARM (STAY), or DISARM.

I’ve tried with “Only on certain days of the week” both unset and with all days selected - same result for both settings.

Also - I regularly receive a red error dialog stating “Error fetching device” when trying to access the SmartApps section of a Thing. When I can access this section, tapping the automation setting described above to view details often ends up showing a perpetual spinner… I have to force quit the app and restart until I can get the SmartApp settings view to load correctly.

I’m using v2.1.0 of the SmartThings app for iOS.

thanks.


(Greg) #2

Mode is actually talking about global mode. Not Smart Home monitor Mode. try switching to away mode by using a routine. You can include making SHM arm away in that routine, but of course don’t do that if you are there testing.


#3

Regrettably, early marketing materials for Smart Home Monitor used the term “mode” for armed status, even though Mode already had a completely different meaning within SmartThings. You can still find this in some of the support knowledgebase articles, which is why it’s easy to get confused.

But anytime you see “mode” in a routine or smart app, it refers to the original use of the term, which was for the global status of the location: Home, Away, Night, etc. As in the kitchen motion sensor should trigger the lights to come on if the house is in Night mode.

If it’s referring to the SHM armed status (home, armed stay, armed away) The choices should be limited to those three options, and the field label will probably include “SHM.”


Upcoming Visual Updates
#4

thanks, that cleared it up!