Light schedule not working when SHM set to away


(Gerald Marchese) #1

I set up a light schedule for a light to turn on at 7:02pm and turn off at 11pm and used the ARM/Away mode in HSM. I want it to come on automatically only when I am in ARM/AWAY mode. If I am home I don’t want the light to come on. It does not work when I set it to ARM/AWAY. If I set it to come on at 7:02 and off at 11 it does work when not in ARM/AWAY. It only fails when in ARM/AWAY. Any ideas on how to correct this?


#2

This almost sounds like something to do with modes. Does your light schedule have something set for “Only when mode is”? I’m assuming you’re using Smart Lighting to do that schedule.

Also, how are you arming? Manually, or through a Routine? If through a Routine, are you changing the mode to a mode that the lighting schedule won’t trigger under?


(Gerald Marchese) #3

Yes I use Smart Lighting. I have the schedule set for “Only when Mode is AWAY” then when I want to run it I manually set the ARM/Away through SHM.


#4

Hi @GerryM Ok, got it. When you manually set SHM to Arm/Away that doesn’t really change the mode. Arm/Away or Arm/Stay settings just use, or not use, a combination of open/close and motions sensors. They don’t actually set a mode.

What you want to do is use a Routine to manually set your Arm/Away security setting AND to set the mode to AWAY.

If you’ve not done that before, here’s how:

  • Tap on Routines
  • Tap on the “+” in the upper right corner
  • At the prompt, give your Routine a name - “Arm system and set to Away mode” for example, and tap on Next
  • Now, find “Set Smart Home Monitor to” and select Arm/Away
  • Now, find “Change the mode to” and select Away
  • Tap on Done

If for some reason you get the red bar of death while doing that, just back out of everything and start over.

When you leave for the day, just go to Routines and tap on what you just created. Later on you can experiment with automating that with presence devices, or other activities.


#5

SMH has never worked correctly for me. Routines are easy to set up and do what I need them to as for as lights on or off and home/away modes.


(Gerald Marchese) #6

I did a quick test, I set things up with a routine as instructed in your directions. It turned on my test light but didn’t shut it off. I will do more testing tomorrow. In the routines. where it says “Turn on these lights or switches” I listed my test light. Do I also have to enter the “turn off these lights or switches” even though in smart lights I listed to turn on at 9am and shut at 10am for an example. Or just use this routine for Arm and away, and just keep my light schedule IE on at 9am off at 10 am when set to away.

Thanks for your help.


#7

I have a routine to turn lights on in the morning as I wake up and set the mode to disarm so that I wont get any notifications of movement, another routine to set the mode to away (I’ll receive push notifications of movements) and turn off all lights, another routine for when I return that sets it to disarm, and a routine for sleep that sets it to home stay that will notify me of movement and it turns off all lights. I have another routine that I select manually whenever I want to turn off all lights and put it into disarm mode, ie on my days off during the day.


(Gerald Marchese) #8

Good information. I just created another routine to disarm the system. I am a new user and never knew that this was a better way of arming and disarming the system.
I just did some testing this morning with lights that are scheduled in away mode and everything works like it is suppose to. Thanks to all who helped.