Smart Things is UNRELIABLE

Yes. It was accepting incoming commands however not giving any out. No power bump but to your point, I reset everything including switches via breakers and that did nothing for the system either as the hub was not sending commands from events, triggers, or routines. Every device was reset including the hub twice. When the app started to come back the system started to work very very slowly and inconsistently for about 30min. Now everything is up and so far working just as it has been.

Unfortunately I will likely get something like this again next week sometime as it never seems to fail.

Sorry for your bad experience. It does seem like the only thing in ST universe that never fails, is the failure :slight_smile:

Yeah, thanks. It is a bummer. Didn’t have to wait a week for more issues, routines aren’t firing again which I have had an open ticket with ST over now for over 2 months. This is something they can’t figure out which is the majority of my issues that come and go. Not all but most. Very frustrating to not be able to have lights go on and off at specific times. That’s a very basic function that doesn’t even work right.

Same exactly situation here. Have you tried Rule Machine? Since routines and modes have been iffy, I switched most of my basic functions to @bravenel s app and it certainly reduced the time I spend troubleshooting routines and Smart Lighting failures.

No, actually I haven’t. I will have to check that out. With all I have invested I’d rather not walk away but am very frustrated. Thanks for the tip, I’ll definitely check it out. Did you just eliminate all routines and smart lighting rules to use this instead?

No, I didn’t eliminate all routines or smart lighting. But I really trimmed down the number of modes/routines/Smart Light instances I use. I used to have about 10 modes, 15 routines and over 30 Smart Light instances. I am now down to 3 modes/4 routines and a handful of Smart Light instances. The rule of thumb for me, is that IF the automation can run locally, then it goes into Smart Light, if not, then it goes to Rule Machine or a custom app. I haven’t had any major issues in 2 months (aside from the occasional platform hiccups).

Here is the link to Rule Machine. It may seems overwhelming at first, but once you get it installed, you will find it pretty easy to work with:

If you find Rule Machine useful, then don’t forget to drop a line on this thread! Maybe one day @bravenel’s app will run locally.

When you say Smart Lighting runs locally… I’m not sure it does (at least in my house)… when they are having issues in the cloud, nothing works at my house… so I’m not sure if anything is actually running locally despite me having a V2 hub… I’ll have to look at what I have doing what.

I ONLY have routines programmed to turn a light on at a certain level, at certain times. Other than that, I will have to look at what I have going on. It’s very, very basic… I don’t have any modes changing.

If you only perform basic functions with your routi es, then I definitely recommend using Rule. Local processing is based on 3 conditions. Use Smart Light app, only use z-wave/zigbee devices and stock device types. If these 3 are met, then unplugging the ethernet and power cable should not affect functionality. If that’s not the case, then is something wrong.

depending where you are
https://graph.api.smartthings.com/localDevice/list
or
https://graph-eu01-euwest1.api.smartthings.com/localDevice/list

and

https://graph.api.smartthings.com/localInstalledSmartApp/list
or
https://graph-eu01-euwest1.api.smartthings.com/localInstalledSmartApp/list

shows you which devices & smartapps can be run locally, however if you use a device not in the list say in smart lighting then then the whole App / rule will be run in the cloud.

and since the list of devices i have in the list are only 10 out of my now 98 devices, then it pretty much makes the local processing useless, at least for me.

Very interesting. I see why I’m not being run locally. I only have 2 of my 10 devices in the local list so it’s all shot just like you.

Interesting enough though also based on what Bobby says, all devices should be local and they aren’t. I’m using all z-wave/zigbee devices, only stock device types, and smart lighting. I meet those conditions yet my cree connected bulbs are not in the local list.

I have to say that I’ve been very critical of ST, but since removing EVERYTHING and adding devices slowly over the last month, things have been mostly good. and i probably just jinxed myself and SHM will set off the siren in the middle of the night :unamused:

That is surprising. Cree are officially supported bulbs, so I don’t see why they wouldn’t qualify to run locally. Are you sure you’re using the stock zigbee bulbs device type? Even my GE bulbs, who are not officially supported were running locally using the generic device type.

even that page is not working. i don’t know if it is only for me.

Honestly I wouldn’t even know how to make a non-stock device type. I’ve removed and re added things so many times with the assistance of support and blown away routines and started from scratch, complete resets, etc. I don’t know why the device types aren’t showing local, support always gets back to me every once in a blue moon with current open or new tickets saying how busy they have been but I ho early haven’t gotten any attention on these issues in a long time.

All I have btw, 4-cree connected bulbs, 2 go control z-wave switches, and the aeon remote. That’s it. Other than that I have my nest stuff and harmony hub connected too but I don’t use ST to do a single thing with any of it (no programming or routines of any kind except on the switches and bulbs). I have simple timed events that are supposed to turn lights on and off at certain times to certain levels. That’s it. Very, very basic. I’m not even using the flexible sunrise and sundown. I have specific times programmed.

In one of your previous posts, you mention that if I am using stock device types and they are not local installed devices then something is wrong. Can you elaborate on this? I am looking into this again and only have 2 of my devices in local device types… only my 2 switches, not my Cree bulbs. How do I correct this? I don’t even know where to begin.

Is there a way to completely blow it all away and start over (like a hard reset)?

So not sure if anyone can help becuase ST seems to not be able to.

Lately Both of the smartphones(Galaxy S5’s) on the network leave and come back within a minute when we are just sitting at home. I have tried everything to fix it.

Also my front door will not autolock anymore. It just randomly stopped.

You might want to use Life 360. It’s a lot more reliable than phone presence.

Is your lock z-wave or zigbee? May have dropped out of network. Have you done anything to troubleshoot? There are several things you can try, starting with just taking the batteries out to factory reset. It depends greatly on your luck, which one would work for you…