Smart Lighting Automation Stopped Controlling Individual Devices

Since yesterday’s automation outage, all my automations that connect to LiFX bulbs via the Smart Lighting SmartApp have stopped working. Automations setup as regular Automations, not via SmartLighting, work fine. They are a bit limited, as such for certain things I require the SmartLighting Smart App.

Automations via the SmartLighting Smart App only work if I select a scene to automatically activate. If I select individual devices - the individual devices don’t get activated. Live Logging via the IDE shows that the automations do run, and no error message is shown, however the bulbs never get turned on/off. IDE shows that event ran. If I place those same bulbs into a scene, then they successfully work with the automation, HOWEVER they do not turn off when motion stops - a feature built into SmartLighting. As such I end up needing to make a second automation inside Automations, to turn lights off when there is a period of no motion - which works fine.

Prior to yesterday I had ALL my automations setup via SmartLighting with no issues at all. Internally nothing changed. I left to work with a working system, and came home to a broken one. The only thing that occured in the middle - was an automation outage yesterday.

I removed the LiFX connection and re-did it. Tried creating new automation inside Smart Lighting, no luck. I did notice that the old scenes I used to have, before deleting the LiFX connection, automatically deleted from my Smart Things app. However they are still available to select inside the Smart Lighting app. This makes me think the devices inside Smart Lighting somehow need a refresh - but am unsure where to go from here.

Manual control for everything from my app works fine.

I am using the new app. Always have been. Never used Classic. Running the ADT hub.

Ideas?

Also - automations aren’t paused. And updating them via IDE did nothing.

Interesting thing - i cannot access Scenes via IDE. Gives me an error.

I hadn’t realised you could list scenes in the IDE. Has that been there forever, and I just forgot about it, or is it a new thing?

Honestly not sure. I never accessed Scenes in IDE - just saw the link today and clicked it and saw an error. I included it here in-case it helps anything.

I am actually having the same issue. I have been beating my head against the wall between revoking privileges , deleting all Lifx bulbs from ST, and re-adding all 17 of my Lifx bulbs to ST. All of my Smart Lighting worked flawlessly yesterday, and stopped working around 7pm CST. As part of my testing, I setup a new Smart Lighting with a TPLink bulb (cloud to cloud integration), and it works perfectly fine. This issue appears to be only around Smart Lighting with Lifx (cloud to cloud integrations).

As a side note, when I look in the ST IDE, under devices, I’m seeing all 17 of my Lifx bulbs with a standard device network ID of “LIFX|:lifx_mini_day_and_dusk|:undefined”. All of my other cloud to cloud integrations, appear to have fully unique device network IDs. Lastly, when I look in the IDE under logging, I’m seeing all the appropriate log messages, such as “Master Bathroom: Day: 70% sent setLevel command to Bathroom3”, but the lights don’t actually turn on. I’m by no means a developer, but I have a networking background, and I’m curious if that “undefined” network address is where the commands are being sent and ultimately not making it to Lifx’s cloud.

Thoughts?

1 Like

My LiFX devices show up the same exact way in IDE.

I also noticed that my Harmony Hub, which used to control my LiFX bulbs via ST - was no longer able to dim my bulbs. It took a few disconnects/reconnects just to get it to be able to turn them on/off again. Eventually i realized LiFX was now supported natively and integrated that way.

Your onto something with it being a cloud-cloud integration that’s not properly functioning.

I tried deleting the Smart Lighting app today and reinstalling it. Recreated my automations in smart lighting from scratch - same thing still. Bulbs work as scenes - don’t work as individually selected devices.

For the last two days my lights didn’t turn on in the morning, but my other automations (thermostat) worked. The lights are grouped into a “scene” and history showing them not being connected at a time. Weird. :man_shrugging:t3:

Same issues. Fixtures say no network connection when trying to use them

Is your failed automation setup via SmartLighting Smart App? This thread is specifically for an issue related to Cloud lights via SmartLighting automations.

Otherwise - this sounds mainly like ST just lost connection to your cloud bulbs. It seems that as of 2 days ago ST’s cloud-cloud integration broke somewhere.

Do you mean when manually controlling a light fixture via the app? We’re all having issues specifically with SmartLighting Smart App automations targeting individual devices.

This sounds more like your having issues with your internal network. Try to delete the non-working bulbs, and then reintegrate them again. Also make sure the fixture you are trying to control is successfully connected to the cloud. If these are LiFX bulbs - check the bulbs inside the LiFX app to make sure they’re connected to the cloud. Some of the earlier versions of the LiFX bulbs used to loose cloud connectivity - however would continue to function via the LiFX app.

Update: Around 2:45PM today, a second LiFX connected app appeared - and now there’s a duplicate of all my bulbs inside the app. No clue how this happened.

@Brad_ST any ideas here? I’m happy to provide any additional diagnostic assistance to try to get this resolved.

Please use the search function first, there are two topics regarding the new LifX integration.

I did check the forum and didn’t find any thread related to this specific issue. I’ve already attempted to reconnect LiFX twice. The bulbs are connected. Manual control for all bulbs works. Scenes that control bulbs work. Smart Lighting automations that control scenes with the LiFX bulbs work. Smart Lighting automations that select individual devices and not scenes - don’t work. As it sits - there are currently 2 LiFX apps showing up in my connected services. One that randomly appeared yesterday, and the original one.

I’ve even deleted all bulbs and started from scratch. I deleted the Smart Lighting app. Nothing has worked to let my Smart Lighting automations work as they used to prior to 2/4/2020.

EDIT: Figured I would try to make a new automation today - since I saw at around 2:50am my HUB randomly went offline for 30 minutes. Plus yesterday I did finally see a notification of an outage regarding automations. Plus the fact that a 2nd LiFX app appeared in my connected services. And hey - IT WORKED! Going to see if I can setup my automations back via Smart Lighting with, hopefully, no further issues.

EDIT: Nevermind - works with some bulbs, not with others. I don’t get it.

My issue was with smartthings generally. 2 days ago I unplugged and rebooted. Automations connecting it and alexa quit working so my outside light which works off a kasa plug had to be turned off manually. Finally found that for some unknown reason alexa showed everything from smartthings being on switches and said I had no network connection. I since deleted all those unknown switches from alexa and now everything seems to be working again.

Report it to support.

I have a few days ago. Haven’t seen any resolution yet, and was hoping someone within the Community had some better ideas.

You are facing two problems and mixing them. Not easy to find anybody with the same setup.
I do use LifX and I do use Smart Lighting too, but not for the LifX bulbs. I rather use them with Advanced Button Controller and remotes and not as single devices, but I might have them with scenes in SmartLighting, if I have a rule. Not sure.

I thought I had just one problem?

And i actually found someone with the exact same issue, he replied in this thread towards the beginning.

You should be able to see Scenes in the IDE again. You had a couple that were malformed that had to be removed. In terms of LIFX, given that you have duplicate, I would remove all of the LIFX devices and start fresh with them. If you’re still having control issues, let me know which ones and when and I’ll try to take a look.

@Brad_ST, the duplication is due to the LIFX Connect in the Classic app. If you have both the connect and the new C2C in the new app, then they will show up as duplicates. One with the old fully Classic compatible DH and tiles, the other with the new non fully Classic compatible tile and “place holders” in the IDE.
The first one is from the LIFX Connect SmartApp, the second is from the new C2C integration.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.