Smartthings and LIFX automations stopped working (June 2020)

I’ve recently purchased a Smartthings hub, motion sensors, and LIFX mini color lights. I was able to set up everything and had automations running in Smarthings classic through the Smart Lights Smartapp. Yesterday I had to turn off our internet, router, and hubs as we’ve just recently moved in and had to rearrange a few things. Since then the automations are no longer being triggered by the motion sensors. I can see and control the lights manually through both the LIFX app and the Smartthings app, however the automations will just not trigger. I can see that motion is being detected through the Smartthings app, but the lights do not come on.

I’ve also tried using Smart apps through the newer Smartthings app, and the automations still do not work. Since then I’ve disconnected and reconnected my LIFX lights to Smartthings with no change in results.

I’ve read through some of the forums and see other people had similar issues, but didn’t see any solutions to the problems. I’m new to setting up automations using the Smartthings hub so I may be missing something obvious, but they were working with the initial set up then stopped after having everything disconnected yesterday.

Have you tried deleting the automations and setting up new ones? I’ve had some occasional trouble with automations (I use the newApp), and deleting/remaking tends to fix it for me.

Unfortunately, multiple people have reported problems with the LIFX integration recently. Your best bet is to report the issue to both SmartThings support and LIFX support. The more people who report it, the more resources they will assign to looking into it.

Some people have had success by removing the cloud connection (not the automations or the individual devices) and reauthorizing it. But I haven’t tried it and I don’t know how much trouble it is to do that if you already have the automations set up.


  1. Try disabling the automation, wait 1 minute and re-enable it.
  2. good practice to assign IP# to all IP devices from your router to prevent devices from getting assigned new IP# when you reboot everything.
  3. follow @JDRoberts idea to remove lifx integration and connect it back. Menu > settings > connected services
1 Like

Unfortunately the LIFX bulbs are tend to play up. They do loose the cloud connection and the brilliant C2C connection is useless. Here to note, the bulbs are working from the LIFX app, with local control, but cannot initialize SSL Cloud connection to LIFX until restarted. Due to this the C2C connection fails on ST side.

I don’t know why the working local control had to be changed to C2C. It was working without issues for years. Now every week I had to power cycle once or twice a bulb.

1 Like

Yeah I’ve deleted and made new automations multiple times but with no luck.

I’ve removed lifx and reconnected it, but I’ve not tried assigning IP addresses yet. I’ll try that and see if it helps.