Smart Life integration stopped working (Jan 2023)

Has anyone else had a problem with Smart Life (Tuya) devices ceasing to work in SmartThings ?
I had an IR blaster set up to control heaters in my barn and it went offline. When I reconnected my devices had disappeared out of SmartThings. When I relinked the service with Smartthngs my devices came back but no longer function. Could this be because there is no edge driver? If so, does anyone know of an edge driver for Smart Life devices?
I found a Switch Bot IR blaster that still works with SmartThings but I am afraid that it will be next to fail. Seriously considering changing over to Hubitat

Smart Life with Smartthings is a cluster f*&k. Pick a different technology if you want to stick with Smartthings. If you want to stick with wifi devices, I have had great success with Meross.

The smartlife/smartthings integration is cloud to cloud, not edge drivers. So that shouldn’t be the issue. :thinking:

@Paul_Oliver has used the integration in the past, he might have more to add.

I looked at the meross web site and i didn’t see an IR blaster in their list of products. I need something to control some older bladeless heaters in my barn. I have 4 that I want to hit with one remote. I did get the switch bot mini to work for now so we will see how it goes.

1 Like

Yes, it was working fine until a few days ago. For some reason the link to Smart Life disconnected and when i reconnected it the devices no longer function. The Switch Bot mini hub works great but i had to connect it to SmartThings via third party. It would not accept my SwitchBot login. I am still not quite sure how I got it connected but I don’t want to argue with success for now.


I don’t to think the Tuya/SmartLife integration plays nice with any platform. So switching platforms probably won’t help. I recently bought a used ST v2 hub for my 2nd location and I am currently using the Tuya app a lot less.

As JD said there are no Edge Drivers for Tuya WiFi devices and they are not needed because it is a c2c (cloud to cloud) integration.

As you probably know most Tuya WiFi devices don’t work with the Tuya-SmartThings integration. Tuya does not provided the firmware to make this happen unless the brand pays for it.

The work around for plugs, lights, switches, and other on/off devices is to create tap-and-run (scenes) in the Tuya app that turn the device on and off. You need 1 for On and 1 for Off. And for multi speed devices you need one for each speed. This might also work for IR blasters depending on how you are using them, but I have never tried it.

Once the work arounds are set up they are very reliable, but they problem is they are 1 way. ST can tell Tuya to do something, but Tuya will never update ST that a change in state occured.

In the past I found that the Tuya integration works better the SmartLife integration, so I use the Tuya integration even if I use the SmartLife app. This may have changed.

So even though your IR blasters have the ST integration, you could try the work around to see if it is more reliable.

The following provides more details on the work around. One change is that you can create the virtual switches using one of several Edge drivers.

1 Like

This ↑↑

Another option is to flash your Tuya products with Tasmota and if they are newer then OpenBeken.
And use the Tasmota Edge driver.

Thanks for all the info. Yes, in order to make this work in the first place I had to program a separate remote for each button in Smart Life. I think this is the work around that you described. It worked great with the exception that I had no feedback that it was actually working. Fortunately I had a camera in the room that I could tell if the heaters were on or off. The problem happened when everything went ofline and then Smartthings no longer allowed the previous buttons to function in SmartThings. I played around with it this morning and found a different remote template in the Tuya App that Smartthings recognized so I got everything working again. The other problem that I have noticed is that half the time that I tried to link Smartthings to the Tuya app and also the Smart Life app It would not even get through to their web site to link up. I even tried to go directly to their web site and it would not come up even not going through Smartthings. So I think Tuya has some issues as well . Anyway, all is well that ends well , at least for now. I have some other questions about SmartThings automations but I will start another thread about that later. SmartThings support has been pretty much useless as usual.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.