Smart Home Monitor alert with lights bug

I have my SHM set up with “Alert with Lights” - and it’s set up to use my two FortrezZ sirens. What I expect in this scenario is just the strobes would flash and not sound the sirens. However, this is not the case - both go off. I have nothing selected under “Alert with sirens”

I would love to run with just the strobes flashing until I’m convinced I have everything set up correctly and switch to the strobes and siren when I have confidence in the SHM.

I think I recall somewhere something about this that at the moment the device type for similar devices cannot separately turn on/off the strobe and siren.

But don’t quote me on that as I might be talking utter rubbish! :smiley:

Ha! Well on the device type for the Siren, I can separately operate the strobe and the siren, so I think it’s that the SHM isn’t set up correctly to only trigger the strobe when a siren is selected under the “Alert with lights” category.

1 Like

@stevesell, what device type are you using? Most device types for sirens have “switch” capabilities, which in the device type turn on BOTH the light and siren when an ON commend is sent.

@Benji,spot on.

1 Like

Thank you for chiming in guys! Hopefully you can help out!


I just looked at all the device types for sirens. You must be using the SmartAlert Siren. It’s the one capable of independently using the strobe and siren.

What I said above still stands. Since you were able to select the siren as a light switch (because it has switch capabilities), and it receives the ON command to turn on, both the siren and strobe will turn on. That’s what the device type is designed to do.

SHM is actually set up correctly because it thinks you selected a light switch, and it doesn’t know that you were actually wanting the strobe light. In the device type, that is handled by something SHM would have to address separately, as in sending value: 0x21 to strobe the device instead of 0xFF for on. SHM would have to be modified to address the scenario described above.

1 Like

@johnconstantelo - I’m using the one SmartThings matched when I paired the sirens. It shows up as “SmartAlert Siren” - and you’re right, it must be using the “switch” capability on() command to toggle the lights.

What I expect to happen is if you pick a device with “alarm” capability under “Alert with lights” that it would use the strobe() command.

See my post above on how that device type is written. I suppose you could create your own device type (modeled 99% from ST’s) so that ON would just trigger the strobe. It would actually pretty easy to do: :wink:

Give that device type a try. It will not affect the normal operation of the device when using individual tiles to test, strobe, siren, or off. What should happen is that an ON command should now only strobe the light as you want it to.

Let me know!

1 Like

John’s reply seems to address the issue very well. My solution, open the cover, add a Off/On switch to the siren…accessible from the top cover. :slight_smile: