SmartThings Community

Simulated Switches no longer working with Echo (June 11, 2018)


#1

Not sure if anyone else has come across this or not.

My virtual switches in smartthings have stopped working with all my Echo devices. I have virtual Momentary Switches that are working fine, only devices with the type “Simulated Switch” are not functional. I have deleted and readded them several times. Echo detects them and adds them to the app, but the app shows them as not responding.

Everything else (even other virtual device types) connected through Smartthings appears to be working.


Amazon Echo -> SmartThings -> Harmony; Worked for a year, now doesn't work (July 2018)
Alexa stopped controlling one of my Fibaro switches
Alexa not being able to connect to virtual switches
(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

Hmmm…

I only have a couple Virtual Switches (and V1 Hub) that are linked to secondary-functions of my Projector & Screen and I notice they haven’t been consistent for a little while now.

Not conclusive, though.

Technically, unless there has been a major change in the Alexa SmartApp, there’s no way for Alexa (or even SmartThings) to know this is not a “real” Switch!


#3

I can change the device type to other settings (like Switch Capability for instance) and the Aelxa app will show it as available and toggle it. When I change the device type back to Simulated Switch the Alexa App shows the item as Not Responding again.

It’s very strange.


#4

Heh, Even more interesting. Decided to create a dummy Simulated Switch device handler and was going to copy from the existing one.

Simulated Switch is no longer available


(MS) #5

YES! This happened to me as of two days ago. My ‘goodnight’ routine turns on a VS on demand (echo command), then shuts the VS back off after a minute. The VS going on triggers a whole host of stuff around the house. I noticed that the stuff didn’t happen as it should for 2 nights in a row. Today I checked the logs and I see that the VS hasn’t gone on in 2 days- but I definitely gave the echo command multiple times and she said “OK” when I asked her to turn it on.


#6

Two days ago was right when I started having issues too


#8

I haven’t tried that. Since I have so many Virtual devices, I’d like to avoid re-creating them all and then adjusting all the rules that go along with them.


(Stephen Hill) #9

Another one here with the same problem. Echo gives the expected response but doesn’t turn on the switch.

Turning it on directly from the Smartthings app works fine though.


#10

More messing about.

If I change them to the device type “On/Off Button Tile” they work as expected.


(Michael) #11

Looks like the simulated devices were removed from the SmartThings Public Github repo too. But there is the virtual switch code:
https://raw.githubusercontent.com/SmartThingsCommunity/SmartThingsPublic/master/devicetypes/smartthings/virtual-switch.src/virtual-switch.groovy

Have you tried the virtual switch instead? It runs local too.


#12

Cool, thanks.

I tried the handler above but it appears I don’t get to run things locally.

Error:
Org.springframework.security.access.AccessDeniedException: Run Locally Permission not allowed for DeviceType: d8c157e0-4936-46c4-b07a-fe9bc205d7e0


#13

I would definitely suggest that everyone who has this problem report it to support, as that was a SmartThings – supplied DTH.

( I would really like to see them start publishing change logs for the stock DTHs, we just run into this kind of thing too often. :scream: Maybe someday. )


(Michael) #14

You actually don’t need to use the code. Virtual device should appear in the drop down.


#15

Aha, so this is why my ‘sleepy time’ switch didn’t work last night. Thanks alot ST! Had to pull out the phone and turn it on by hand, sheesh.


#16

Heh, lol. Funny, I never noticed. Thanks for pointing that out.

Yea, that DH works fine. Same as the On/Off Tile. I’ll begin making my changes.

Thanks for the tip.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #17

That is (was?) the great benefit of having nearly all of the DTHs and SmartApps in a public open source GitHub repository. It is (was?) trivial to see the exact change history, sometimes with useful comments.

And some SmartThings devs or build engineers would even accept and appreciate Community made “Pull Requests” to fix or tweak minot issues… Add a Capability claim, or a manufacturer fingerprint, etc…

Alas, I fear that was “then”… And now that mutually beneficial system is deprecated. :cry:


But the Repo still exists and has recent commits… :confused:?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #18

Well… The Repo actually does indicate current (“2 days ago”) changes to Simulated Devices…

Details of Switch:


#19

I’m coming up blank for a use case where a simulated device would need a health check.

Full disclosure, I lack imagination.


#20

So is there a fix to this issue?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #21

If the breakage is actually caused by the changes / commit I linked above, then affected folks ought to contact Support@SmartThings.com

But it may be easier to just experiment with replacing “Simulated Switches” with “Virtual Switches” (or vice versa?). Hopefully somebody will come up with the best path.

Or somebody could do more diagnostics on this, including Live Logging and such, and figure out what the exact code issue is … presuming the available open-source code is the one which is affected. Then we could submit a Pull Request to fix it. I’m curious as to what broke how … but don’t have the time to investigate, personally, at the moment.