Alexa shows virtual switches as offline

At some point in the last few days Alexa has deemed my virtual (simulated) switches as ‘Offline’ even though they work fine from the ST app. She replies ‘sorry, the device is not responding. Please check its network connection and power supply.’

I tried removing one of the switches from the Alexa app and re-adding it bit there was no change in behavior. A friend of mine is experiencing the same behavior. Is anyone else seeing this?


Are they also marked “offline” in the Alexa App?

I have one that is not offline in the App, but Alex voice still says “isn’t responding”… Haven’t tried removing (“Forget”) / adding (“Discover”) again.

Yes, they are marked as offline in the Alexa app. It shows 24 devices there but when I run discovery she tells me she found 18 devices. In the Alexa app there are 6 devices, all virtual switches, which show as offline. These worked fine until recently.

I think its a known problem that just popped up a few days ago.i believe @JDRoberts mentioned that amazon is aware of the problem.

1 Like

I had the same issue. Added them back and they seem to be holding.


This happened to me too. I had to create new vs’s. Alexa recognized them. I deleted the ones Alexa said were offline.

If anyone sees problem with virtual switches, can you try to just open the Echo SmartApp and clicking “Next” and “Done”? I would like to solve this issue if it is widespread but have not seen it myself.
Also, try actuating the virtual switch once outside of Alexa.

Didn’t make any difference.

I have 3 devices authorized to Echo: a zigbee smart bulb, a Z wave pocket socket dimmer, and a virtual switch.

The two nonvirtual devices show up fine.

The virtual device shows up as “off-line” in the Alexa app, and Echo will no longer control it. The same switch has been working for months.

I tried forgetting the device from the echo app and re-discovering, but that didn’t help.

I’m seeing the same behavior as JD

1 Like

Same issue here.

+1 same issue.

I had this issue also. Activating the switch within the Smartthings app (turning on and turning off) cleared the offline notification on Alexa. Everything appears to work now. Hopefully it holds.

We found the issue, expect a fix for this next week.

Meanwhile, actuating device outside of Alexa should resolve it for a while.


is this still scheduled for this week?

I believe it is released now!


Fixed at my house! :heart_eyes:

1 Like

Great, thanks for confirming!

1 Like

Yup, all, good here too…


This week Alexa started showing my SmartThings receptacles intermittently on or offline. I can run discovery on Alexa and a receptacle might show up fine one pass, then offline the next time I run it. I can turn them on and off in the Smartthing app with no problem and when they are on from the Smarthing app Alexa will find them no problem. An hour later try to issue a on or off command with Alexa and she reports one or more of the devices in a group as offline. She was rock solid the preceding weeks, this just started in the last few days. Any ideas?


Lars, what was the fix? Is it an update to an app, firmware, or an auto update? I am showing devices as offline at this time.