SmartThings Community

Set thermostat hold temperature for a set length of time?

hello everyone!

i’m hoping to to add some automation to my “away” scene so that when i leave the house, i can automatically lower the thermostat to a set temperature for a default length of time like 1 or 2 hours. i know i can set it permanently, but then i get home and the house is too cold! thanks for any help!

Hi tedgotsoul, welcome to the forum.

Scenes are a one shot deal - they set things to a certain state and then stop, so it’s not possible to do what you want using just a scene.

Here’s one way you could achieve it (assuming your away temp is 15 and home temp is 21, just for example sake)

Scene:
Have a scene that sets ‘Away’. It has the following actions:

  • Set thermostat temp to 15
  • Set location mode to Away

Next, create a custom automation:

  • Condition: If home mode is set to away
  • Action: Set thermostat temp to 21 with a delay of X hours

This way, by running the scene you’ll trigger an automation immediately, but it won’t actually perform the action until X amount of time has passed.

This has a limitation that you won’t be able to cancel the automation action. But it should work as you describe.

On a side note, this is the sort of thing that annoys me a bit about SmartThings. Scenes are effectively just automations that get triggered manually, but there are also certain things you can’t do with scenes (such as the delay described above.) I think SmartThings should drop ‘Scenes’ entirely as a separate entity, and allow you to set a ‘trigger’ called ‘manual’ - which causes an automation to appear in the UI as a scene does. It simplifies things a lot, but also gives you more flexibility and control.

1 Like

That’s a great idea @stooshie45 !! However I can’t set a delay more than 10-minutes in the app. Sheesh!

Hit ‘Customise’ and you can select as long as you want. Just tried it, created one with a delay of 24 hours. Seemed happy with it. What version of the app are you using?

I am using the new app … are you using the old app? Maybe that is why I don’t have that option.

Nope, I’m using the new app too… that’s weird! What platform are you on (iOS/Android?)

I’ve got an iPhone 8 and am using the latest software and the latest app. So maybe it’s an iPhone thing?

Could be, that’s really weird - what thermostat are you using? Only other thing I can think of is that maybe it’s device specific?

Tried it on a couple of different devices (TV, Soundbar, Lightbulb, Outlet) - works on all of them. So probably not something that’s device specific.

yes, it must be device specific. it doesn’t work with my thermostat. oh well… not a big deal. i came from a great system with Iris Lowes in which everything worked with one app (garage door, lights, watering the garden, thermostat, alarm system)… and then they gave up and killed their system. so now i’m back to like 6 apps to control my smart junk. i miss the days before al gore invented the internet. life was simpler