Scene doesn't work properly to set ecobee thermostat settings

I have an “Away” scene that gets run when I leave my 2nd home, it turns things off and adjusts the heat/cool set points for the thermostat etc. Has been working fine for over a year. A little over a week ago I left there and ran the “Away” scene as usual. Today I happened to look at the thermostat settings and noticed that the heating setpoint was never set by the scene. Opened up the scene, and it mysteriously has lost that setting (heating setpoint), so the empty house has continued to be be heated for the past week (not happy). I have tried to edit that scene but I notice that now I can only save either a heating or cooling setpoint - smartthhings won’t save both, even with mode set to auto. It’ll look like it’s going to save it, but when I tap “Done”, then go back to edit the scene again, it didn’t save both heat and cool settings. This is a capability that worked in the scene up until recently, so what’s happened?

I am having the same problem/issue with my Ecobee thermostats. Could it be a recent update of the Smartthings app that causes this issue? It is frustrating. I had a couple of Honeywell Round thermostats that recently failed, so I replaced them with the Ecobees. The Honeywell thermostats never worked 100%, it was glitchy at best, would sometimes change temperature setpoints in “away”, “home”, and “night” scenes according to what I would set it at, but would only work about 50% of the time. And it would also disconnect from Smartthings randomly, so I would have to re-enter credentials to reconnect.

When the Honeywells failed, I took the chance to replace them with Ecobees, thinking Smartthings might control it better. But now this issue. If someone has a solution to the above issue, it is appreciated.

I contacted ST support and sent screen shots of the app, showing that the thermostats settings were not being saved in the scene. I can duplicate the error easily. I received a bizarre response from an ST support agent stating that “ looks like you’re attempting to access scenes in the IDE”, when there had been no mention of the IDE (I am not using it) in my ticket and the screen shots clearly show the ST iOS app. Apparently ST support can’t tell the difference between a web browser running the IDE and the ST app running on an iOS device. So zero assistance from support. It looks like another case of break it then ignore it.

That is indeed an unfortunate and disappointing response from the support team.

The work around I figured out, is to just manually set the thermostat to either “cool” or " heat," and set just one temperature set point for either “heat” or “cool.” Don’t even bother with other settings (mode and fan) as the app won’t save it.

This way, scenes can control the temp settings on the thermostat as it changes from one scene to another. Then set the thermostat Hold Duration setting to “Until you change it” so it ignores the schedules and just follows changes by the scenes and automations in the ST app. This can be found the the Ecobee app under Device Settings.

For some reason, the Ecobee app comes loaded with default schedules, and I found that I cannot delete all of them, nor deactivate them.

Life is full of workarounds, and compromises. :frowning: