Second v2 hub goes offline whenever my phone arrives!

I have two v2 hubs on my account. For some strange reason, the second hub keeps going offline, and it seems to happen when I arrive at that location!

The first hub works fine, no issues. Events gets triggered and we get notifications on both of our phone no problem.

Few weeks ago I got another v2 hub to monitor a second location. I am using the same account but registered the hub under a different location. It worked fine for a while, but now I realize whenever I go to the second location, my phone somehow knocks the hub offline! (or perhaps it crashed when it detected my phone’s present?)

The first time it happened, I was there to pick up the mail, and left quickly. Then I got a notification on my phone that the hub went off line (it has been fine for a week). I couldn’t go back to check things, but I checked online as well and both the web UI and the phone said the hub was offline.

Went back the next day, power cycled the hub, and the status went back to normal.

A few days later, I went back again, and sure enough, the hub went off line again when I was there. The hub has solid green light in the front, and the web UI does NOT say the hub is offline, only the app on my iphone says its offline!

Are there any issues with having more than one hub on an account? I couldn’t really tell whether the hub is truely offline, or if the phone app is messed up (I tried restarting the app, same). I tested my flood sensor while the hub is showing as offline, and strangely I got a TXT notification, so the hub is online, just as the web UI reported. But somehow the App thinks it’s offline (and I didn’t get the app notification, only TXT notification).

I am using SmartThings App 2.0.4 on iPhone.

Is there a way for me to log in or check the status of the hub locally? Is there an ssh interface? I am a software developer so I am curious to see if I can get the status from the hub directly.



Nope, feel free to do a port scan to verify, but the last i port scared my hub it had no open ports.

There is only to check on your hubs.
FAQ: Logs and SmartThings - An intro into figuring out what went wrong

You may also want to contact support,

Thank you. I have reached out to support. is showing the hub as online, and logs indicate it is pinging normally (I guess every 30 seconds?).

So perhaps this is just a bug on the iphone app? I tried toggling between the two locations. Location 1 is fine, location 2 will show offline after a few seconds.

How do you have that hub connected? Straight Ethernet to your router or through some sort of WiFi ‘bridge’?

Do you statically assign IPs in your network or just all DHCP? How big is your DHCP pool if used?

Straight Ethernet cable directly to the router. DHCP and pool is definitely big enough as I have very few devices, and the router is locked down so no one else is using it.

How does the hub detect my phone’s presence? Through wifi or location/gps based?

I wonder if the system is getting confused by me and my wife’s phone. Both shows up with the same name (this is a different issue, even if I give the 2 phone unique names, presence only uses one name/device for some reason).

How about dedicate an ip to your hub 2. Maybe ip conflict?

If DHCP is configured correctly (which it seems it probably is) and so long as the router isn’t completely horrible, it’s unlikely to be a IP address conflict.

@wildgoose , I thought it might be through WiFi/LAN but I walked in the house with my WiFi disabled on my phone and it still detected me so I’m assuming it does it through location/GPS.

@benji Ah, so the app must be sending the location back periodically.

I did some additional testing with the help from support. This looks like a bug in the iphone app. I deleted the app and downloaded/logged in again. It initially said the second hub is online, but after I switched the location a few times and looked at the activity, it then report the second hub as being offline. says the hub has been online, so the app must not be getting the correct state somehow.

Is anyone using 2 hubs in two different locations? I can’t be the only one with this bug. :smile:

That would mean the app is periodically polling the hub which would be insane if it was. I would have thought the SmartThings cloud is the one checking in with the hub and if they can’t reach it, they send your app a push notification that the hub is offline, it would save the battery life of your phone.

I am using 2 hubs with 3 different locations with no problem.

@benji It might be pulling the status only when the app is open. I didn’t notice significant battery drain with the SmartThings app.

Also a bit strange is, when I switch from hub2 to hub1, the offline message disappears immediately. But when I switch from hub1 to hub2, it takes like 15 seconds for the offline status to be shown.

@navat604 Great. So it is working for some people. Are you using the iPhone app or Android?

I wonder if it’s the hub itself that might have some problem. Is there a way to factory reset the hub? I mean completely reset the hub? (Google says remove the hub from the account and add it back to reset it, but I am not sure if it’s a full reset…). When I got it initially I had some trouble pairing it with my sensor, so I pressed the reset a few times and removed it from my account and added it back. I wonder if this messed up some state somewhere…

I am still within the Amazon return period so if all else fails I could return the hub and get a new one to see if it’s any different.

Yeah I’m all out of ideas I’m afraid :fearful:

I think I know what’s going on. This is only a problem on my phone. On my wife’s phone, it’s not an issue!! (On my phone I deleted the app and reinstalled the app, so it’s in a cleaner state than my wife’s app, still, it shows off line).

Smartthings have some issues with 2 phones on the same account. Both phone gets assigned the same name, and presence doesn’t work on both phones (ie, only mine or hers work, never both). Last I heard they are working on this.

This is probably another bug related to two phones. One of the phone have trouble pinging the second hub, or the hub/system gets confused somehow.

With the new update. You can now add new user to the account. Hopefully that will help.

1 Like

Oh I not realize I can add user now. Will give it a try tonight!