Seam: Temporary Solution for Managing Lock Guest Codes (Jan 2023)

CEO of Seam here. I want to offer a temporary solution to manage access codes for anyone who is currently affected by this.

Note, we’re technically a software API used by Airbnb PMSs like Hospitable, Enso, HostAway…etc, so it won’t be the perfect solution for non-technical users, but we want to help out anyone who’s currently affected by this. We obviously won’t charge you money. Use it and hopeful this help. Happy to answer questions or ping us at


Signup for Seam
Go to and create an account.
Once logged in, in the top right, click the drop down, and click create a new workspace. Make sure this new workspace is NOT a sandbox (don’t toggle the switch). You will not be able to connect a real Smartthings account via the sandbox. You must use a production workspace. Once you’ve created the new workspace, switch to it.

Connecting Your Smartthings Account
To link up your SmartThings account(s), go to the Webviews menu in the left tab, click “Add Connect Webview” button in the top right, select SmartThings from the list of providers, and go to the link url provided. You will be walked through connecting your Smartthings account. Complete the steps and then your door lock devices will appear in the Devices tab of the dashboard.

Creating and Managing Access Codes
Once your devices are linked up, you can view them under “Devices.” If you click on a door lock device, you will be able to create access codes. Note that access codes are UTC timestamped! (welcome to software developer land) You must be careful to check that the start/end times match the timezone where your lock is located.


Interesting, thank you for providing this. I’m sure there will be some users that will be looking into your service.


Hey sybohy !
I’m trying to connect my smartthings account, but I get stuck after logging in with my samsung credentials. The page says “Select 2FA Method” with the smartthings logo.

Any help would be appreciated !

interesting. Are you using a Samsung Galaxy phone by change? We’ve had issues with 2FA on those. I also saw another user the other day struggling with regular SMS.

Can you try to switch your SmartThings account to use an authenticator app (e.g. Google authenticator) and try again to link via Seam?

ps: my email is in case you want to ping me directly to troubleshoot.

btw, if any software developer here is interested in creating a proper Smart Lock manager app for Airbnb hosts, feel free to use our API. My hunch is that this would be quite useful for a lot of folks as we get a lot of demand for it but don’t have time to build it. If you build it, they will come :slight_smile:

A couple of development guides to get you started:



Hi, Sy,

Thanks for this very hopeful solution! I’ve got my locks added to Seam, and have been able to add/delete codes. However, when I try to schedule a code, the code is activated immediately at the lock, not at the scheduled time. Good news, it does delete the code at the scheduled time. I’m testing on a Schlage FE599 lock. I don’t see a way to SET the time zone (you mention this in your initial post), but I do see the correct one showing in the scheduling calendars, which is correctly CST. Any ideas? Thanks!

1 Like

David, how far in the future are you trying to schedule those codes? Could you also provide me the device uuid (check seam dashboard url) and the code that had this behavior? I’ll take a look at our admin tools to see exactly what happened. btw let me know if you run into reliability issues with FE599. I’ve been told it’s not the most reliable Z-Wave code programming device out there. If you see problems, I’d like to investigate them so that we can figure work-arounds.

1 Like

Sy, thanks for your response. So, I was testing scheduling in the near future, like 30 mins from now, and then delete 20 mins later. I haven’t tested far into the future, say days or weeks. I tested several different codes, all with the same result. The device id as listed on the Seam dashboard is: cfdf2d6d-544e-4cdb-a56e-d1ef30b3c821 and one of the codes I tried was 8970. I’ve had very good luck with the Schlages at my vacation properties. I have a Kwikset lock I’m going to try this evening. I’ll post my results.

So I was able to test the Kwikset 620 on my front door, and the same result; set the code to go off in twenty minutes, but the code activated immediately. the device id is 4a813522-fce4-48b1-b01e-fbf6d9fc342c and the code I tried was 5746. I’ll wait to see if the code is deleted as expected.

I wonder if there’s a bug in the UI where the starts_at timestamp gets sent to our servers in UTC. That would explain why something 30 mins ahead immediately gets set. UTC is 8 hours ahead, so the code takes effect immediately since the starts_at is 7 hours and 30 minutes in the past. As mentioned, we recently pushed an update to show user local timezone instead of UTC. I’ll dig in tonight and report back tomorrow.

For the record, the code did delete, but only after 41 minutes past the scheduled time.

1 Like

i just tried to connect my smartthings account, but not able to get past two factor authentication. i originally had SMS as the only option, but then added an authenticator app based on this thread (but don’t see how to delete SMS so that the authenticator app is the only option). whenever i try to re-connect smartthings, it only lists SMS as the only 2FA method i can choose. it’s not picking up the newly added authenticator option.

1 Like

revisited the seam URL to connect ST and was prompted to enter a 2FA code. did that and then got the message:

Resuming two factor authentication

but eventually it errored out with:

An unexpected error has occurred. Please contact customer support.
Debug Log

tried twice and got the same result.

We’ll take a look first thing in the morning. It’s possible the session went stale. I’ll follow up via email

So I thought about that and scheduled a code that was more than 31 minutes in the future (42 to be precise), and this time the dashboard showed Status as UNSET (as opposed to SETTING, which it always did, previously) and the code did NOT activate (yeah!) … except it did, 12 minutes later – 30 minutes before scheduled start. The dashboard Status also showed REMOVING at scheduled end, and continued to do so as I tested the code on the keypad over the next 30 minutes before it was finally removed from the lock, and the schedule in the dashboard expired/cleared. This was tested on a Schalge FE599. You are so close. I’ll set a code to activate in more than 24 hours from now, and see what happens. ITMT keep up the good work. It’s not a perfect solution, but for those that rely on door-code management for their business during this ST fiasco, your offer to help out those in this situation is deeply and greatly appreciated.

David, I have an explanation. It doesn’t have to do with timezones, i was incorrect. That stuff is working fine. It turns out that not that long ago, we implemented a 30-minute time-buffer to ensure that access codes would be programmed against a device by the requested time. First some smart locks are flaky and it’s really important for some of our large enterprise customers that the code be programmed on the device at the starting time. To ensure this, we begin our programming routine 30 minutes ahead of the activation time window. If the lock is functioning properly, then the code is active 30 mins before the time window opens. Generally this is totally fine since some of our customers program access codes 6 months in advance and/or a few hours before check-in. However, in the instance you tested, this logic would definitely lead to confusing behavior! As far as removal of the code, this is done right away once the active time window expires. I think we’re going to keep this logic in place for a bit longer until we sort out good devices from flaky ones. We tend to lean toward being more cautious than not and will probably re-evaluate this logic in due time.

i got it working by deleting the pending smartthings webview and re-adding it. that then allowed me to choose OTP as the 2FA authentication method instead of SMS.


Ah, that explains everything!So if you plan to keep the 30 minute buffer, then that
is an easy fix for for me – just set the start time 30 mins later than actual. So great, I’m going to begin using your service for my next checkin, and will report back if I run into any issues. Thanks so much!!

1 Like

Great work, I know a lot of people have been pulling their hair out the last few weeks!

I seem to be having issues making the connection, have switched from SMS 2FA to the Google App. Have got to the final stages but seems to be getting stuck on “Setting up access to account (1/6)” and doesn’t progress beyond 16%. Have deleted and restarted but seem to be getting the same issue, is there anything I can try? Not sure if it’s affected by having multiple homes on one account?

@gwion could you email me at that I can look into this? I will need the email address you used on your smartthings account to look into our server logs.

1 Like