Schlage problems


(Mike) #1

I have a Schlage Camelot that worked 100% up to last week. I use the enhanced lock app to lock the door after it was closed for 10 minutes. Everyone is so use to the app locking the door that they don’t bother to lock it.

Lately the app is not locking the door. I have tried removing the app and reinstalling but that didn’t help. The lock is connected with correct status. I can lock / unlock remotely.

Any ideas? The hub recognizes the lock as a zwave lock instead of the Schlage lock. Does that make a difference?

Thanks


#2

Same lock, same problem.

I eventually got it working again but not sure how. I did like you, uninstall and re-install but that didnt seem to work. I believe that only after editing(no changes made, just pressed enter at the end of a line) the source in the IDE, save and publishing got it working again.Either that or luck.

That said… The Schlage Problem may be a red herring. At the same time my “Sunroom Temperature monitor” app was not working. It would not turn on the heat once the temp fell below a set parameter. Like the door lock problem, this seems to be fixed as well.


#3

I think the “after 10 minutes” is the problem.
I have been having issues this week with stuff that relies on time like that.
I have 2 rooms that activate lights based on motion, then turn them off after 2 minutes of no motion. These have been failing to turn off intermittently.


(Mike) #4

I don’t want to blame everything on the upgrade but it seemed to happen after the upgrade. I had some other issues also.


(Ben W) #5

I had a similar issue were my Schlage was not responding to commands, but was still reporting status. My fix was removing the device from smartthings and re-adding it. If its responding to the ST app its probably fine.

Have you checked the logs to make sure the command is being sent? Maybe its not the lock but the door sensor.

I also been having issues with cloud commands being ‘lost’.