Schlage Connect keypad not working


#1

So I have a Schlage Connect electronic deadbolt with keypad paired to my SmartThings Hub. The keypad went dead (no illumination, can’t enter codes, etc.) but I can still remotely unlock/lock the deadbolt via my SmartThings Hub/App. My app indicates that batteries are at 99%. However, if I replace the batteries, the keypad comes back to life and everything works fine. This has happened several times. How can there be enough battery power to operate the deadbolt but not the keypad? Any thoughts?

I already emailed Schlage. Haven’t heard back yet but I’m expecting some stock response like “replace the batteries” or “reset the device”.


#2

When you select the Device from Things within ST do you see an icon “Code entry on” or “Code entry off” with a little remote control icon? I have this accessible for my Yale locks and if it is set to off, it disables my keypad. Not sure if this is a feature of Schlage within ST and the DTH.


#3

I do have that icon and it is set to “Code Entry On”. Thanks for the input anyway!


#4

Sounds like it’s going to be one of those needle in a haystack resolutions. :slight_smile:

Maybe there are more people with Schlage versus Yale to ST integrations, but it seems like there are a lot more issues reported around Schlage locks and the DTH or other weird or unexpected functionality.


(Jg506) #5

It could be loose connection between the keypad and the unit that happens to address itself when you replace batteries only to later get loose again as the lock engages. Make sure the connection pin of the keypad is inserted all the way (it should click if I recall correctly) and that wiring is outside the movement path of the lock.


#6

Interesting thought, I’ll check it out when I get home. Thanks!


(Dale C) #7

I had my keypad go totally dead on one of my Schlage no matter if I replace batteries or not. Worked fine for about a year but then keypad died but the lock still works in ST


#8

Update…Per jg506’s recommendation, I tried to see if the keypad connection pin was securely inserted. After removing the battery cover, I realized that I did not have access to the connection pin…at least not with out more disassembly, which I was not ready to do. Instead, I disconnected the battery pack then reconnected it (without replacing the assumed dead batteries) and that seems to have fixed it…at least for now. Did the lock just need a “reboot”? Any thoughts? We’ll see how long it takes before I am confronted with the situation again.


(www.rboyapps.com - Make your home your butler!) #9

We have a FE599 Schlage where the backlight has gone dead. Disassembles it down to the circuit board but couldn’t be fixed. Great news is that Schlage is awesome and they promptly send a replacement.

pS - don’t try this on your lock unless you’re really comfortable. The magnetic locking pins are a royal pain to realign and reassemble.


#10

Did you ever get a response from schlage on this issue?


(www.rboyapps.com - Make your home your butler!) #11

What issue, replacing a dead keypad backlight? They’re great they just replaced the whole lock.


#12

I had a Schlage keypad stop working. Rebooting by disconnecting and reconnecting the battery would make it work again for a week or two. I finally called Schlage and they sent a new lock. Now 6 months later the new lock is doing the same thing. The keypad stops responding but it still works by using the app.


#13

I had the same thing. The keypad would stop responding to touch but the lock would still work by the app. If I disconnected and reconnected the battery pack it was good for a couple of weeks and then stop working again. Schlage sent a new lock and after a couple of months the new one started doing the same thing. I have to carry a key just in case I get locked out.


(Ryan) #14

Anyone else coming to the realization that Samsung has actually just released a sub-par service with no intention of improving it or making work right? The same problem is now happening to me and there is no “fix” or “explanation” to what is going on. Honestly, I really wish I would have tried a different more responsive service at this point!


#15

Happened to me yesterday too. I disconnected and reconnected the battery pack and it came back to life.

Looks like a Schlage issue to me rather than SmartThings. @travelingman525 What makes you think it has anything to do with Samsung?


(Ryan) #16

I have been having issues with the Samsung Brand Motion Sensor as well (battery mount design, randomly loosing connection and not reconnecting, are the biggest issues). And then there are all the times the app on the phone doesn’t communicate with the Hub. I have friends that have gone with other ecosystems and they have greater functionality/options of what their devices can do. The common thread between any major issue I have had with my Smart Home, has been the SmartThings, it is just an ongoing frustration that makes me wonder if I should have gone with a different “Hub” system. It is possible that the Google Home, NVidia Shield, Schlage, items are the problems areas, but it certainly doesn’t help Samsung’s image.


#17

But in this case there is no issue with the connection to the lock. That actually works. People are just posting in this forum because it’s convenient.

Samsung has nothing to do with Schlage’s lock. They both use an open form of communication in the form of zwave. It’s like saying your iPhone and Apple is to blame when your Sony bluetooth headphones won’t turn on.

I understand your frustration but you should be posting in the threads related to the issues you are having. I hope you find a solution.


(Matt K) #18

Keeps happening to me as well.

Not sure how to fix it.


#19

Anyone have a solution on this thread? It’s also happening to my Schlage Camlot lock. About once every week the key pad stops working, and I even made sure the connector inside is fully connected with the wire tucked into the appropriate slot. The key pad comes back to life after reconnecting the battery pack. I emailed Schlage but haven’t heard back.


#20

You should call Schlage/Allegion at 888-805-9837. They will ask for the serial number of the lock and send you one. I had the same thing done about 7 months ago and the same thing is happening with the replacement, unfortunately, so your mileage will vary…