I Took The Dive--but need help with Iris Keypad and Schlage lock


(Steve) #1

So, I took the dive into Smartthings yesterday, and so far it’s awesome. I’ve had no real issues getting everything paired up and running. I’ve even loaded the Iris Keypad handler and ULM.

I’ve run into two issues though, and I’m wondering if anyone else has experienced these issues.

  1. My Iris keypad is paired, but when I enter a code and hit on, it just beeps twice and doesn’t arm the system, and the Off, Partial, and On buttons on the bottom flash. This is an important feature because my 11 year old has an old phone that is not smart (as a trainer, hell get a smart phone if he’s responsible with that) and my wife isn’t all that tech savvy. I need them to be able to enter a code on the keypad to disarm the alarm. Anyone have any issues with this in the past? I saw on the original keypad post that someone else had this issue but it fixed itself by the morning, which it has not for me.

  2. My second issue is my Schlage Century locks paired and were fine, but within an hour or two they now read as offline. Has anyone had this issue and worked out a fix?

Thanks all for any assistance. I look forward to becoming an active member of the community as I dive into this awesome open platform!

Steve


(Mark) #2

Sounds like the keypad didn’t finish pairing. Did you follow the procedure in this thread?

How far away are the locks from your hub?


(Steve) #3

I did follow that procedure. I was thinking about unpairing it and doing the install all over again.

For the locks, I was actually about to do an update post. I force removed the locks and followed the procedure for disenrolling on the lock itself, then I re-paired them and they are back online. The hub reads the lock state and updates when locked or unlocked. However, when I click unlock in the app, it says unlocking but doesn’t actually unlock.

The locks are about 10 feet away from the hub. I put the hub exactly where my Iris hub was to hopefully avoid distance/interference issues with the thought that if it worked with one hub in that location it would work with another =)


(Steve) #4

Another update: Got the keypad working =) No idea what I did though. And when I arm the system the locks locked, which is weird considering I couldn’t lock/unlock by clicking on the item in Things. Oh well. I’m happy as is right now, I’ll probably start messing around with it again in a few hours with a fresh head. Thanks for the help Mark! =)


(Mark) #5

Glad to hear the keypad’s working for you now.

I don’t have any z-wave locks, but I do know that they can be prone to pairing issues too. I think it’s often related to the extra security features that z-wave supports/enforces with locks but not other devices like switches or contact sensors.