Schlage BE469 Lock No Longer Works

My z wave deadbolt stopped working a couple days ago. I removed the lock and attempted to re-add it, but I believe an edge driver doesn’t exist and now all the Groovy DTHs are gone. I checked out the smartthings edge driver repo here and it doesn’t look like my lock is there (BE469WK). Does anyone know of another channel or driver to use for this lock?

@philh30 has developed an Edge driver for that lock. Check this post with a link to subscribe to the channel and install the driver:

I added that channel and installed the driver. I’ve tried to add it by doing “Scan” and by adding the Schlage Door lock specifically under “Select from list of devices” in the SmartThings app and get the same result both ways. It gets added as a Generic “Z-Wave Device” and there is no option for me to swap the drivers. When I tap on the device it says “This device hasn’t updated all of its status information yet”. Is there a better way?

Use the API Browser from @TAustin to check the device to find out if it is Type DTH or Type ZWAVE. If it’s DTH, do you still have the custom DTH installed in the IDE? If so, you’ll want to delete that before trying to add your lock again.


Some thoughts…

I had to go through the steps of Unenrolling the BE469 from the Z-Wave Network first (not just deleting it from the Hub or old/GroovyIDE)

My BE469 was from circa 2019 and did not have the “button” under the cap to press. When prompted to place the BE469 into Unenrollment Mode, I had to press Schlage, 6-digit Programing Code, 0. It responded with a “Green Checkmark” when it was Unenrolled. See Schlage Guide here on Page 13.

I then installed @philh30’s (amazing) Edge Drivers.

Then when I added the BE469 back to the Hub, it picked up his Edge Drivers.

Note in my Step-By-Step that the Device Card did not update & enable the options right away. He had me Swipe Down a few times to refresh it.

I have gone through the device exclusion process several times. Each time with “Green checkmark” and the device gets removed from smartthings. When I re-add the device, it gets added as a Groovy DTH “Z-Wave Device”. I have both the Smartthings Beta Drivers and @philh30 drivers installed, and neither gets picked up when I attempt to re-add the lock, it always gets added as a z-wave device which I am unable to switch to an edge device.

API Browser:

Smartthings IDE:

Do you have “other” Schlage 468/469 locks (or similar) that are using IDE Drivers? If so, perhaps remove all of them first?

I have no other locks, custom device handlers, smartapps. I just have a bunch of lights and switches mostly, other than my garage door, which is currently using the “Z-Wave Garage Door Opener” edge driver.

I see the issue. For some reason your device is not pairing properly with your hub and the fingerprint is all zeros. In that situation, it will never match a driver’s fingerprint so it will default to a generic Z-Wave device. I’m having the same issue with one of my GE outdoor plugs.

Given my experience with the Schlage locks, I would make sure that the lock is almost directly adjacent to your hub by either moving your hub or the lock to insure proper device communication with the hub.

1 Like

I pulled out a 50 ft ethernet cord (I’m on a V2 hub) and extension cord just because I also thought it could have been a distance thing, that didn’t work either :/.

Thought I would follow up on this, finally got it to work. I factory reset the lock after excluding it and it pairs just fine now. It also picked up @philh30 drivers. I’m not sure how/why this affects the pairing process but it does.


Glad to hear you got it resolved!

1 Like

Good call !

Nice to hear you got it working !

This was required for me too. Note: factory reset for me was to hold down the Schlage logo on the keypad while reconnecting the battery. Takes all of 10 seconds.

mine refuses to exclude so i am going to pull out the long ethernet and see if that is the issue.

Mine definitely excluded quicker (almost instantly) when the hub was right next to it.

1 Like