Sudden issue adding door code with Smart Lock Guest Access

Hi All,

I’m using Smart Lock Guest Access to remotely add lock codes for a short term rental. The experience is always fairly buggy and I’m used to that, but this seems to be a more significant issue. I have two Schlage locks at the rental and starting today, when I try to add a code to one of the locks, I get the following error message: “Something went wrong while creating the lock code. Try again”. I can add codes for the other lock just fine.

The lock shows as online and I can lock and unlock it remotely. I just can’t add a code for whatever reason. Any ideas? I already filed a bug with Samsung. I have a guest checking in today so any help would be greatly appreciated.

Thank you!

two questions…

  • what is model of the Schlage lock?
  • has the lock been migrated over to an Edge driver or still using a DTH?

if it is using a stock Edge z-wave lock (assuming it is z-wave but will not know until you list it), you can check out the following Edge driver:

install the new Edge driver, switch the lock to use instead of the stock edge driver.

so report back on the two questions and someone from the forum should assist.

Thanks for the quick response. I’m using Schlage Connect Z-Wave locks.

Sorry for the dumb question but how do I tell if it’s been migrated to the Edge driver? I have not done this myself but I read that some devices will automatically be updated to the new Edge driver. I checked the “driver” option under the settings for each lock and it doesn’t give me any option to change the driver.

Should I follow the guide you linked to?

Follow up to this. Both locks are on the same driver version, so I don’t think this is the issue as one lock works fine and the other doesn’t.

Driver version for both is 2023-02-16T01:37:08:473422826

Any other ideas?

@rk1985 When you open the Device Card for each lock, are all of the Controls active/working (or are any of them disabled, such as “Tamper Alert”, “Alarm”, etc.) ? If so, pull down on the Device card several times to refresh it until the Controls become active.

Also, not sure I have the confidence in SmartThings properly converting everything over. All of our locks have behaved very well with @philh30 's Edge Drivers!

I would strongly recommend following the Step-By-Step in the post that @jkp referenced to assure you’re using @philh30 's Edge Drivers.

1 Like

Thanks @JohnRichard. I enrolled my Hub and updated the drivers for both of my locks to the @philh30 Edge drivers. Unfortunately I’m having a new issue and the “Create Code” option in Smart Lock Guest Access is now greyed out completely. Prior to updating the drivers, I could click “Create Code” and would then receive an error message. Any ideas on what else I could try?

There is no “Create Code” in SLGA, only “Invite Guest”. Is that what is not working?

@rk1985 Can you confirm that all of the Controls are “active” on the Lock’s Device Card? (i.e. you can drag the sliders for Activity, Tamper, Forced Entry, etc. ?)

Also, what is the model of the lock you’re using?

Also, what Bruce @h0ckeysk8er said: In SLGA, there is only an “Invite Guest” button at the bottom of >Menu>Locks>LockCodes (there is not a “Create Code” button). Can you confirm what button you are seeing?

Finally, I would recommend Uninstalling/Reinstalling SLGA now that you have the Edge Drivers installed.

@h0ckeysk8er @JohnRichard

After you press “Invite Guest”, you type in a code for the lock and you then hit “Create Code” in the bottom right of the screen to submit the change. This “Create Code” option is greyed out and I can’t click it and therefore can’t add a code.

Circling back to this thread as I’m running into the same issues again today. I’m on the philh30 drivers. Any other suggestions? The lock has worked generally fine for the past few months.

Mine stays greyed out until you enter at least 4 characters. Other than that, I’m not having an issue.

Are folks having better success with the philh30 1.00 driver or the beta driver? Neither seems to be working in this case.

Any alternative drivers that this group would recommend I try?

I’m only aware of the ST stock driver, the one from philh30, and the beta Rboy driver. I’m using the beta version of philh30’s which fixes issues with lock codes being reset to “code x” and exposes the unlockCodeName (at least for Schlage it does).

I still am getting the error message when I try and add codes via SLGA. I tried updating to both the PH and PH Beta drivers that @jkp posted about and still got the error codes. I also, deleted the SLGA and readded it to no avail. Any ideas? I have model #BE469ZP. Firmware 0.11.0

Exclude the lock and add again. Scan QR code if it uses one.

1 Like

I’m having the same problem as @rk1985. I have two Schlage FE595s. When trying to create code, I receive “Something went wrong while creating the lock code. Try again.” Should I follow the same Step-by-Step instructions/process as above?


  1. The locks use RBOY APP 2023-09-25T22:52:18.404576414

  2. Is there any way to force the locks to their default factory settings?

are you using the Edge driver posted earlier in this thread for the locks? If not, switch the locks to it and try adding codes.

I just moved back to ST (from Hubitat) on an Aeotec V3 hub. I have 2 Kwikset Z-Wave locks and 1 Schlage Connect (Camelot) lock. I installed SLGA, and it only allows me to add names to the 4 slots for codes. There is no button or field to enter a code. Though I saw the hub import the codes from the lock after adding each. So, again, all I can seem to do is apply names, no field or option for entering or changing the codes.

I have four Kwikset locks and through SLGA I can edit a name, delete a code and invite new guest. In SLGA, 3 dots, lock codes, invite new guest. You can also manage this through

Hi @mlchelp - Thanks. Basically, I had a different expectation based on other SH platforms and ST of old. I figured I could tap on the listed codes and besides set a name, but a code. I saw that you can only do that through the Invite Guest function. That does allow me to set a new code and name. So, if that sounds right, then all good. Just not what I expected

1 Like