Schalge Lock pairs, but won't report status

Hi All,

I’ve got a Schlage Connect BE469WK and have been attempting to get it to work with ST. I actually have a identical lock on my front door and it works fine - status, locking, PIN mgt and everything.

However, my issue is that this new lock will pair to ST, and I can successfully send the Lock and Unlock commands, but it just reports that the status is “Unknown” and it seems to fail when I tried adding the lock to the Lock Manager smartapp and it sent my existing PIN codes to it.

I have tried a bunch of things including:

  1. General exclusion, then re-pairing (several times) within a few feet of the hub.
  2. Full lock reset, then general device exclusion, then re-pairing.
  3. Changing the DTH. It gets paired as “Z-wave Lock”, and I tried changing it to “Z-wave lock with codes” as well as the custom DTH needed for “Lock Manager” called “Z-wave Schlage Touchscreen Lock”.

When I look at the device’s configuration I see:

  • fw: 128.22
  • manufacturer: Schlage
  • networkSecurityLevel: ZWAVE_S0_LEGACY

Current states says:

  • battery: 100 %
  • lock: unknown
  • lockCodes: {}
  • scanCodes: Scanning
  • pinLength: 4

Is there anything else I can try? Is this just a dud?

Nkw that ST fixed the bug that had this symptom earlier this year, and we can rult that out… It’s also symptom of this:

Thanks, yeah I read through a few of those threads.

One thing occurred to me: if the device was indicating “unknown” status, it might mean that it never completed its normal startup routine mentioned in the instructions. So I re-did that and was finally able to see the status change.

Now I’m working on getting the PIN codes to get sent over, but so far it looks like the codes are blank. Not sure if it’s because my code length is set to 4 in the device (default), and my PINs are all 6 digits.

Which Lock Manager app are you using and what device handler is assigned to the lock?

1 Like

Yes that would do it.

Hi there,

I actually used ethayer’s Lock Manager app & DH. The parts that tripped me up were:

  1. To get a status, you must make sure that you’ve done the lock’s “setup” routine where it figures out what is locked and what’s unlocked.
  2. If you have 6-digit codes in the app, the lock must be manually configured to use 6-digit codes.

I’m now getting statuses and full functionality with the exception of the notification - not sure why it’s broken all of the sudden, I’d been getting them from the app previously.