Scenes with Fibaro Z-Wave devices crashes app

Hi!
Got this really strange issue since a month or so.

Adding any Fibaro device to a scene crashes the Classic app, same thing if I try to edit a scene with a Fibaro device. Adding the same device to a scene in the new app doesn’t crash the app but the one/off settings is blank and no matter which I chose nothing happens.
Tried both custom and ST provided DH…

Any guesses?

TIA!

Per

Same issue. I have an old scene that has a fibaro zwave device in it. Any time I try to open the scene to edit it, the app crashes.

@JB_Bentz @Thyg0d what Fibaro devices exhibit this problem and what DTH are you using? If it’s a custom DTH, does it contain the code addChildDevice? If it does, and one of the parameters is isComponent=false can you try removing the code that sets componentName, deleting the device and joining it again? This PR has an example of the change I’m suggesting:

@tpmanley
Sorry for the slow reply, first time in 2 weeks I get to sit down…

I’m using @erocm1231’s wonderful DTH


but I’ve also tried the “default” that Smartthings made available a while ago.

The custom DTH conatins the code you said.

addChildDevice(“Metering Switch Child Device”, “{device.deviceNetworkId}-ep{i}”, null,
[completedSetup: true, label: “{device.displayName} (S{i})”,
isComponent: false, componentName: “ep$i”, componentLabel: “Switch $i”])

Just to make sure I got this right.
Below is the same code but with , componentName: “ep$i” removed
Is that correct?

addChildDevice(“Metering Switch Child Device”, “{device.deviceNetworkId}-ep{i}”, null,
[completedSetup: true, label: “{device.displayName} (S{i})”,
isComponent: false, componentLabel: “Switch $i”])

TIA!
BR
Per

This has been a problem for a very long time. I’ve submitted a support request for it (developer support I think). It happens with any child device that was created with “isComponent:false” I believe.

And if you remove the isComponent:false line it doesn’t fix it?

Same issue here with scenes crashing the app when i include fibaro or qubino child devices. I’m using the default Qubino device handler and Eric’s great device handler for the Fibaro. Any solution tried and confirmed ?

Thx!
Fab

Hi @Fab
Yeah, sort of…
But you probably won’t like it, I didn’t enjoy it anyway… :slight_smile:

I got my 223 to work by removing them all, removing Eric’s DH :frowning: , adding the devices using the new app.
This sorted the crashing issue in the old app and you can now create scenes with the Fibaro 223 devices using the old app. You can also control each device manually in the new app.
Downside, if you add the 223’s to a scene in the new app it doesn’t work and since you’ve edited the scene in the new app you can never edit it in the old app ever again.
I my case I need to create some 40 new scenes, 20+ routines and a bunch of “Smart Lightning” routines and of course SMH settings.

So it’s a solution but not a very fun one…

@prjct92eh2

Nope, didn’t seem to help at all, unless you need to remove the device and add it again.

You do need to exclude it and re-pair.

Did that with Erics but it didn’t work…
Still have a ticket open with the support so I’ll post any findings…

1 Like

Still waiting for a reply from the support…

Now I’ve got even more issues…
Smart lighting automations are loosing their name saying no devices or scenes have been selected but when I check the automation it shows devices selected…

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.