Scenes fail to activate


(A K) #1

I have several scenes set up and yes, I realize they are in Beta.

Unfortunately when scenes are activated from routines, several of them execute inconsistently. The routine runs just fine but the scene specified in the routine is not activated. The notifications in the app says “some scenes failed to activate” for any scene that did not work.

I tried deleting the scenes and recreating them - same thing.

Obviously pistons that rely on these scenes encounter the same issue as webcore can only execute a scene via a routine. I can have the piston continuously poll a device in any specific scene to see if it got to the desired state on a repeat loop until the scene successfully activates but it’s not a cool solution plus prone to get locked in an infinite loop

Anyone else experience it and what debugging mechanisms are available to troubleshoot? The logs in the IDE are rather limited and I would be keen to know if there are any lower level debugging tools or techniques associated with Smartthings. Of course any workarounds would also be appreciated.


(jkp) #2

Can you post a screenshot of any of the scenes you are experiencing issues?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #3

I presume you’re referring to SmartThings Classic App (I don’t know if Scenes are implemented differently in the new App).

Scenes are no longer in “Beta” as far as I know. Where did you get this impression?

There’s no additional debugging (other than Live Logging and Support tickets) for Scenes - or for any SmartApp for which we don’t have the source code.

You could put some Virtual Switches in the Scenes to assist with testing.

I currently only use 2 Scenes frequently - both called from Routines. And they do fail too often. I don’t see the message you mentioned because I run the Routine from ActionTiles or a trigger.


#4

Are you trying to activate multiple conflicting scenes from the same Routine? If so, stop doing that. That’s what’s causing your problems.


(A K) #5

Thanks.

  1. @tgauchat - Yes, these are referring to SmartThings Classic. I am not looking to switch over in the near future until I had enough confidence and evidence of success in the field. These are also simple scenes. Virtual switches proved no change. Basically if the scene is activated not by selecting it in the app, then any other mechanism reports that the scene failed to activate - I should say this is frequent but not 100% the case which makes it annoying. I have about 7 of these for different scenarios and they include anywhere from 3 to 12 lights

  2. @jkp - here’s a screenshot of one that frequently fails. Nothing fancy. I removed a few switches to no improvement then added them again. I even deleted the entire scene and recreated it from scratch. Same results of often misfires

  3. @Ryan780 - no. Single routines / single scene. Different time of day or triggers (examples would be routines for sunrise, sunset, goodnight, goodbye - each triggers a lighting scene but none executes concurrently or calls more than one scene at a time


#6

Can you see what is triggering the unwanted change in the device under Recently? If not, open LiveLogging and leave open while waiting for the issue. Does it fail every time? Is it consistent or intermittent?


(jkp) #7

How many are hue lights by chance?


(A K) #8

Nope. It does not show any devices related to the scene in LiveLogging which makes me think it is not actually finding the scene that it is trying to activate?

For now I recreated several scenes in webcore. A PIA but works well. Just not as easy to perform on-going changes from my smartphone but I guess this is an acceptable tradeoff.


(A K) #9

None. All Lutron Caseta with a Wemo switch here and there in a couple of the scenes. I did not find a pattern that leads to specific devices. The routine(s) could fail finding the scene or timing out on trying to find the scene due to an unknown / unexplained reason.


#10

What? Your devices are lights are going on and off and that is not being recorded in LiveLogging? Are you sure? I find that highly suspect because that means that ST has no idea that they are changing at all. Did you wait until the scene activated before looking at LiveLogging. It’s LIVE, not a recording.


(Mark) #11

I’ve only created a couples scenes since the feature was released, so I don’t have a ton of experience with them.

But I do have several Lutron caseta dinners and switches. I’ve noticed that intermittently the state of the Lutron dimmer or switch doesn’t report correctly to ST (if i manually turn one on, for instance).

So could the problem be that the scene is trying to run, but times out due to an issue with the ST-Lutron integration?


(A K) #12

That is my going theory as well. yet when I press the scene button in the app, it executes well. Something times out between the routine and the scene is calling it - at least that’s what I am thinking. For now, I will stick with webcore pistons for the simpler scenes and develop a ‘monitoring’ piston for the more complex ones that will repeat execution until it senses one of the devices reached its desired state.

I may give SmartLighting a try instead of the native scenes and use virtual switches to trigger. Problem I am encountering right now is ‘Access Denied’ when trying to do anything meaningful in the IDE and incognito / deleting cache and cookies does not resolve. Posted this issue under a different thread.

Not happy with overall reliability and issues ST introduced over the last several months. Hubitat seems intriguing but is not yet compatible with everything I need and getting there slowly demands more time than I have right now.


(A K) #14

@jkp It might be the case but 1) these scenes ran fine until a couple of weeks ago when they started showing problems. It could be as you say due to an issue on the Lutron side (perhaps they pushed a new firmware version to the hub or changed their interface timing specs that negatively affects ST or other). Yet, when moving the same lighting structure to Webcore, it runs fine. Again, as you say, maybe I am experiencing success because WC timing is slightly different than ST directly.

Whatever it is, my most critical scenes are under control now with WC. Wish there was a better syntax / UI for Webcore to handle scenes. I may also try the SmartLighting smartapp just to futz a bit with the more complex scenes if I have time next weekend. Surprisingly, the more complex ones run fine. It is the simpler ones (3-4 devices) that gave me the headache.

Thanks for all your help - time to move on to the next problem :slight_smile:


(A K) #15

@Ryan780 the devices are not going on and off because the scene is never launched by the routine hence live logging offers no additional value. When the scene does kick off (after several attempts of running the routine) then the lights log activities correctly bit when I get the some scenes failed to activate message, no lights are activated which might as well the error would have said “the scene totally failed to activate”


#16

What happens when you press “test scene”? What if you trigger it manually? Still nothing?


(A K) #17

It was never complete nothing. It worked like 3 out of 10 times. Usually works well at the scene / test scene level but many misses when the scheduled automation tried to trigger it. Moved the problem ones to webcore. Wasn’t worth more time that I didn’t have. Thanks.