Samsung TV Intregation ISSUES - NEED SAMSUNG TO GET THEIR OWN PRODUCTS WORKING TOGETHER

I am attempting to tell my Samsung UHD TV to Turn on via Smarthings. To build on this, I ahve a smartthings plugin for my homeseer controller in which I m launching audible command from. All things from homeseer log show the command being sent to turn on the “Switch” of the Samsung TV . I can also conclude that I can turn the TV on and off via direct controls from smarthings app as well as device control in homeseer for this TV. I can also confirm that there has been several issues noted around being able to turn on the samsung latest Q series (2019 and current) TV’s from Alexa when the smartthing skill is enabled.

I understand that Samsung is a Business within a business around different units, but I would think that Smartthings would want to ensure all Samsung products work flawlessly to promote Samsung products as a whole. This is gaining more and more concern in the IOT connected device community and I am looking to see if SmartThings “TEAM” is going to get with internal Samsung consumer products devision to remedy this integration issue with the TIZEN OS and SmartThings.

Below is the debug output from SmartThings when this command is executed:

2/17/2020 8:01:16 AM

SmartThings

Debug

{“components”:{“main”:{“contactSensor”:{“contact”:{“value”:“closed”}},“configuration”:{},“healthCheck”:{“checkInterval”:{“value”:28920,“unit”:“s”,“data”:{“protocol”:“zwave”,“hubHardwareId”:“000F”}},“healthStatus”:{“value”:null,“data”:{}},“DeviceWatch-Enroll”:{“value”:null},“DeviceWatch-DeviceStatus”:{“value”:null,“data”:{}}},“sensor”:{},“battery”:{“battery”:{“value”:100,“unit”:"%"}}}}}

2/17/2020 8:01:15 AM

SmartThings

Debug

Response:StatusCode: 200, ReasonPhrase: ‘OK’, Version: 1.1, Content: System.Net.Http.StreamContent, Headers: { Access-Control-Allow-Headers: DNT,Keep-Alive,User-Agent,If-Modified-Since,Cache-Control,Content-Type,Accept,Authorization,X-ST-Client,X-ST-Api-Version,X-ST-Client-AppVersion,X-ST-Client-OS,X-ST-Client-DeviceModel Access-Control-Allow-Methods: GET, POST, PUT, DELETE, OPTIONS Access-Control-Allow-Origin: * X-RateLimit-Limit: 350 X-RateLimit-Remaining: 349 X-RateLimit-Reset: 43723 Connection: keep-alive Date: Mon, 17 Feb 2020 15:01:16 GMT Server: openresty Content-Length: 388 Content-Type: application/json }

2/17/2020 8:01:15 AM

SmartThings

Debug

Request:Method: GET, RequestUri: ‘https://api.smartthings.com/v1/devices/4dac0888-8456-4f4f-b55c-6ca9f85cf694/status’, Version: 1.1, Content: , Headers: { Accept: application/json Authorization: Bearer ### }

2/17/2020 8:01:07 AM

SmartThings

Error

No command mapping for device 325

2/17/2020 8:01:07 AM

HomeSeer

Device Control

Device: 7630 S Blackstone Patio Switch to On (0)

2/17/2020 8:01:07 AM

HomeSeer

Event

Event Trigger “Patio TV Turn on Patio TV”

2/17/2020 8:01:07 AM

HomeSeer

TTS

Speak (json:):OK, running the event Turn on Patio TV

2/17/2020 8:01:07 AM

HomeSeer

Info

Heard: turn on patio tv

do you have the TV connected via Wifi or ethernet?

TV is connected via WiFI as I already know the issue around WOL on wired connection

Aaron Jones

Interesting. Have you tried to create a virtual switch on the SmartThings side and have the TV switch state connected to it via an automation in the new app? I have a couple automations with my TV setup with the automation creator in the new app that work fine.

Is the homeseer plugin using groovy or working directly with our API?

1 Like

To answer simply question, they are using the API. More details below to support the distinction, request to remedy and opportunities to grow!!

@jody.albritton there is a member of the homeseer family @Spud that has created a plugin whereas you can pull all devices and functions that ST has enabled into there framework such that they can be controlled and leveraged in complex routines. This is part of there HS4 software update (currently in BETA) that has been released. Based on my issue that I have posted here, I was able through Homeseer and there Homeseer Alexa SmartSkill be able to get the issue with the latest samsung Q series TV to work like a champ now (Thanks @prjct92eh2) for pointing out what I looked over. here is what I have done

HS4 Beta Release running on VM
SmartThings PLugin enabled
HTD (Whole home Audio) enabled
SONOS plugin enabled

From this solution, my HS4 can see native devices that HS4 is managing (Like my sonos connect and HTD Lync6 whole home audio) as well as with the plugin on ST, with authorization and shared key, I was able to pull in and recognize all ST devices my V2 hub was managing (Including my Q series TV’s)

From this setup, I was able to setup an event with a custom voice command (Patio TV) and when I say, Hey Alexa, Tell homeseer to turn on Patio TV, the following happens:

  1. Turn on Samsung TV (This clearly works now as it does not with native ST plugin and Alexa integration hence my post)
  2. Set Audio input to that of TV on HTD system (Zone1), set volume level to 30 (default) and then set lighting scenarios to what I want based on time of day (Homeseer has a very open flexible event engine that does what WEBCORE can and more, but it very simply If this then statements)
  3. From there I am able to interact with Alexa to then custom announce whatever I want.

FWIW, I wish ST and Samsung Consumer products group would get together and fix there integration and make sure your products work together (Newer in last couple years of course) such that you can have a Samsung experience that is end-end. Currently the TV integration is broke, support for OFC is not operating and sides are not aligned, hence the complaints that continue to pour in on this community (they are all there). Additionally, my company (Calix) is working to open your ST SW solution integration onto our next generation gateway solutions we our to sour service providers in our open platform we call EXOS and it would be awesome if we are able to showcase package solutions with Smartthings and Samsung as a way for operators (Broadband Service Providers) to drive ramp and unit growth.

I hope you dont see this as a rant but rather an opportunity to help grow your solutions ability beyond current and recognize that we in the community know this is not easy based on lots of moving parts and beliefs on protocol stack, OS, API exposure, etc… So keep up the great work and look forward to seeing what new and exciting things the ST DEV team bring to market!

Which model TV do you have? I’m able to turn on/off my Q7 with Alexa using the native SmartThings skill.

I agree there does seem to be a lot of people having trouble with the TV integration. Most of them seem to be using an ethernet connection, though. As noted on the ST product site, for some reason some commands aren’t available when the TV is connected via Ethernet vs WiFi.

Can you explain exactly what is not working in detail? In your posts there are several issues mentioned but I don’t know how they are related and which ones still exist because at one point you say it is working.

@jody.albritton I will provide a brief explanation

I have 5 2019 Q Series Samsung TV’s in a new home automation project for my folks. After getting all TV’s online and visible in the ST V3 hub and App, I proceeded to then enable the ST smart Skill in Alexa so that I could interact with the TV’s. Simply put, Alexa discovered all TV’s with no issues. I could control the TV’s via the ST app with ON/OFF and other control functions with no issues.

The problem came to Alexa. What I found was that you could not say “Alexa, Turn the TV on”.

I had no problems with telling Alexa, Turn TV Off (IE I have the TV and the Dot in a group in Alexa), but when you trying to tell it to turn on, Alexa immediately came back and said the TV is offline. Well that was not the case as I was able through ST app to turn the TV on and Off.

Enabling debug, when the Alexa command was sent "Alexa, Turn the TV OFF), there was an OCF error in the logs. Researching this issue in ST community, it was found that TV integration has had several issues around this.

Fast forward today, with my complex environment, I was able to discover the Samsung TV’s via the API plugin a Homeseer member developed that allowed all ST devices that I authorized became discoverable in my Homeseer solution.

In Homeseer-

I created a voice command for the power option on each TV (Example, Patio TV ON would trigger TV switch to ON)

Through smart skill (Homeseer) discovery, I was able to discover these devices from Homeseer. With a simple Alexa spoken routine, Alexa turn on the Patio TV, I was able to call the event in Homeseer that subsequently turned on the TV based on the actions within that event.

There is clearly some interop issue around TIZEN OS (ver 1335) and ST/Alexa SmartSkill that errors on the TTS that is sent from Alexa to ST (Hence the comments above).

I hope this helps. I mean, I have a work around, complex it is, but it is working 100% of the time. I just wish Samsung and the ST and consumer products unit look at this issue. It clearly stems from a few issues as well as the same network at home having multiple TV’s on the same subnet and possibly not being able to delineate between them given the the forced localhost hostname that is imbedded in the OS for each of these TV’s.

So if I understand correctly the problem is with the Alexa Skill and not connectivity between the apps, APIs or appliances?

There are some known limitations with the voice integrations and we are working on a solution.

From the skill

NOTE: Not all features and devices on SmartThings are fully compatible with Alexa, and not all Alexa TV features are available on all Samsung TV models*.

https://www.amazon.com/SmartThings/dp/B01ETW5Q9O

Do we have any further updates on progress with this matter. I see this as a large opportunity to drive ST and Samsung branding with Cross partner brand relationships. You dont see these issues with Sony or others so I am really taken back that Samsung does not see this as a brand capability problem they should be solving.
Thanks