Samsung tv has lost Smartthings connection ( Resolved 17/05/18 )

I got it to work for me. Though I still can’t get it to turn on, only off. I basically removed my account on SmartThings app and deleted the app. Samsung says they no longer support that app. Downloaded Samsung Connect app and it was able to find my smart TV (KU6300) almost instantly. Connected that to same account as my TV and voila it worked. It also connected to my Samsung Smart Hub and everything else (lights, plugs, camera).

Wow! Really glad I read all this before taking the plunge and buying the ST Hub. Thanks guys. I’ll avoid for now (or forever lol)

1 Like

Any updates, Brad_ST?

I doubt it. All hands are on migration. The TV is probably a lost cause at this point. I’ve given up hope

You can onboard a compatible TV with the new SmartThings app by signing into your TV with the Samsung account you use in the new SmartThings app, a factory reset may be necessary if you were signed into the TV previously.

If you use the same Samsung account to log into the SmartThings classic app, you should also see and be able to control, except for turning on, the TV from SmartThings classic. However, longstanding SmartThings users will may see that the TV is on a different location than their Hub/devices. Additionally, because account migration isn’t fully rolled out that may cause a separation between the account where your Hub/devices are vs the location where the TV is added.

This isn’t a new update but there is continued work on the ability to turn a compatible TV on with both of the SmartThings apps and the ability to move the TV device between locations.


How would I control it from SmartThings Classic? I have the TV added in the new SmartThings app, but I don’t see it in Classic. I really just want to be able to turn my TV off using my Echo–can I do this again? Thanks!

Brad i believe this IS new information !

Unless ( entirely possible ) i missed a post on the forum this is the first time anyone has mentioned your method of Tv connection

Can you elaborate on factory reset please, which device? Tv, Hub

The 6000 series was/is a compatible Tv but as i have posted many times… no connection in classic or new St

I have factory reset many times on the Tv, sign in using same account as new st but still no connection

Actually for the heck of it i tried a Tv hub reset … again, something i have done many times in the past

I can confirm for the first time in months the 6000 series Tv actually does now connect to new smartthings with the new controller Ui once the tv is found, i can also confirm that classic now has basic control AND amazon echo once again has the Off ability, not on but heck i wont complain

This is definately a new progression and probably deserves its own thread just to state that some Tvs should now work… just not switch on.

Thank you to everyone involved in making this work again


Anyone had luck with more recent models or it only work stills with previously supported models?

Could you elaborate how to get it to appear when search?

I had a tv originally connected to the new app as it doesn’t need a to be connected to a hub. I have since then got another ST hub and slowly moving stuff over. At start the TV (Samsung 5 series K5500 40”) was still showing and functioning. However after me accidentally deleted the location I started reinstalling but the TV wouldn’t show up. At one point somehow it appeared again but only for a short while and the app would actually connect to the TV…(keep ‘checking status’ or ‘disconnected’)

So I deleted it again but yet to be able to find the tv

What do you press while the new app searches for the tv? I tried everything from simply turning the tv on to frantically press every button on the damn remote…don’t laugh. This automation intrigues and annoyed me at times.

The SmartView definitely works it’s connected to the network alright…


Still no official fix?

Hello I bought a Samsung TV series 7 NU71000 but I’m not able to turn on via Google home (mini) I already add the smart things integration with Google and when I arrive home in my smartthings app on my phone the TV appears as disconnected until I turn on the TV when I turn off, the TV appears in the app as TV turned off but like 5 minutes later it appears TV disconnected, sorry for my bad english

That’s the way things are now. It was possible to turn on the TV with the previous integration, but that is no longer possible. In my situation it’s not a big deal in all honesty, although it was good for simulating presence in the evening.

In your situation I’d invest in a chromecast, as it would give you this functionality direct from the Home device and you’d be able to do a lot more as well.

Just don’t buy a Samsung TV…problem solved :slight_smile:

I get all smartthings hub notification’s on my Sony android TV :slight_smile:

1 Like

My Samsung 7 Series TV also appears in the new app but not in the Classic app. I also don’t see the TV under My Devices in the IDE. Am I missing something?

Did it come up thru bluetooth? That’s how mine appears in the new app for some obscure reason… not to mention it doesn’t appear in the classic… :frowning: So I can’t be sure if my family will be able to control it if my phone isn’t near…

Mine’s a Spanish model though… :frowning:

@Brad_ST I finally understood what you wrote a while ago and almost got things working, but I’m afraid I screwed it up again. I found my TV under a different “Home” location in ST Classic, so then I went into the new ST app, moved it to my original “Home” location, then deleted the new location. Unfortunately, despite all the devices being under the same location in the new ST app, I still couldn’t see the TV in ST Classic. Figuring I didn’t have anything to lose, I deleted the TV in the new ST app and tried to re-add it, but now I can’t add it again no matter what I do. Any advice? Thanks!

Can anyone who has this working tell me what their device network ID is? You can find this in I’m curious if it matches any of the TV’s MAC addresses or other device ID’s.

My TV’s device ID is a fairly long hexadecimal string that does not match the wifi or Ethernet MAC addresses. My guess is it’s randomly generated.

Thanks! I’m guessing the TV can’t be added the way I want. Unfortunately for me, I can’t seem to add it through the apps either.

Any advice, @Brad_ST?

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.