Samsung Q85 not found in App

Hi, my Samsung Smart TV (GQ85Q95TGTXZG) cannot be found anymore by the Smart Things app. It used to work but there is no connection anymore.

I did sanity checks like “am I in the same WiFi”, “delete/reinstall app and start over”, etc.

Streaming works fine, but I cannot control it.
Any ideas on how I can get it back to normal?
Thank you in advance

In the Smartthings App did you try Add device, Scan for nearby devices, ?

In fact I’ve tried both, add & scan and add & select from the list.

What year is that TV? They announced some models of TV’s were losing support in the transition to the new architecture.

Its fairly new, the 2016 models were being killed off, the Q95 should work and have full ST integration plus ST app on screen

Unless there is a region change that is stopping the integration

Unlikely but possible with all the changes

Is it a German spec Tv ?
Are you using an ST hub ?
Have you recieved the latest Tv update as 2401.1 came out recently, there is a distinction between 2401 and .1

It is a 2020 German spec tv and my software version is 2401, no further updates offered when checking for updates. I don’t know what you mean by ST hub, I’m just using the tv and the original remote control.

BTW using Netflix, Disney+, Paramount+, YouTube etc without any issues. So other than that app connection to Smart Things, the tv is fine (minus the ads in the menu :roll_eyes:)

ST hub is Smartthings hub, many users use a hub to control our home automations

When we had issues with Tv connections in the past the only recourse available was to completely reset the Tv back to factory settings and set it up again, that normally resolved issues with connection in the long past

your call if you want to try but if you do be very aware all your Tv apps will need to be reset and re signed back in… so CAUTION :warning: if trying that route

Apart from that im not familiar with a hubless Tv connection

@JDRoberts may have more insight into hubless connection , hopefully JD will notice this thread soon

I noticed it, but I don’t have anything else to add. Televisions never used the hub, so it doesn’t matter whether you have one or not. The connection is to the smartthings cloud. Most people who have a Samsung smart television do not have a smartthings/Aeotec hub, but they are still using the smartthings app.

I don’t know anything about why the app stopped working for this television model. :thinking: You could try asking in the official TV support forum and see if they know, although they might just send you back to this forum since it’s about the app. Or there may be a different forum for German models, but they should know that.

1 Like

Thanks for the advice so far, I’ll do two things now:

  1. Factory reset
  2. Ask the TV forum

I always assumed the Tvs connected through a hub if a hub was present JD, im sure they used to be ! Oh well you live and learn but the factory reset used to be the only way to repair the app tv connection

Maybe prior to the 2018 app update? But in 2018, Samsung combined a bunch of their apps into one app, including the television app, under the name of the smartthings app. So from then on that app was how you set up a smart Samsung television, and no hub was required.

1 Like

I’ve done a factory reset and during setup the TV asked me to connect to the Smart Things app and it immediately worked.

Problem solved.

Thanks for the advice, I appreciate it! :smiling_face: