Samsung Connect Home/SmartThings WiFi - 0.47.10 —all Zigbee devices went offline

The original forum got closed due to inactivity, so I created this one for the community to discuss. After upgrade all of my zigbee devices went offline! Anyone else have this issue? @nayelyz is investigating.

1 Like

Same. et-wv520 hub with firmware 000.047.00010

I had to reset every. single. zigbee. device.

Dont delete the devices - go around to each device, click add device in the app, search for device, the hit the reset button on the device. It will find it again.

Rinse and repeat for every device. Fun!!!

But I have 80 zigbee devices!

1 Like

And then do it again a few days later.

Same thing has been happening on the other hubs with the latest FW update.

To quote the occasional SmartThings system status update … "Something’s not right.’


I’ve been repairing them all night. I have a leak sensor under the dishwasher that is a pain to get to! I hope they can fix it. And I’m going to need to recalibrate all of my blinds!

I had the exact same issue and same resolution… reset each device. Painful.

If anyone is currently having this problem, instead of individually resetting each device, it might be worth trying a Zigbee heal as that will rebuild all the network neighbor tables.

Take the hub off power (and any satellite hubs if you have those as well) but leave all of your other Zigbee devices on power.

Wait 20 to 30 minutes. That should be long enough for the individual zigbee devices to go into “panic mode“ because they can’t find the hub.

Then restore power to the hub(s). This should cause all the individual devices to check in again, which might be all you need.

I’m not saying this will work, I’m just saying it might be worth a try, especially if you have devices which are physically hard to get to.


If you do try this, let us know if it does or doesn’t work. :thinking:

JD, I have been through some power outages recently (several) that basically simulates what you are suggesting. No dice.


A power outage wouldn’t normally trigger a Zigbee heal because while the hub will go offline and the batterypowered end devices will stay online, all of the Zigbee mainspowered repeaters will also be unavailable. Not the same scenario.


Since upgrade I am having OFF Line issues with HUBs, saying they are Off Line along with other devices going offline, but seemed to be working. I have since factory reset and delete app to only now not able to add/extend my HUBs back to Main HUB / Router. When trying to extend to second HUB it gets to 43% and fails. So now down to working with one HUB/Main Router and its Off Line again… Need to roll back upgrade or come up with a patch…



I got the 47.10 Firmware yesterday morning and as most of us, all zigbee devices appear offline… I was told to follow the steps that @nayelyz posted on this other forum

Other than that I have tried power cycling the main hub with no success. I may try to disconnect all hubs from the mains, wait for 30 mins or so and see if that helps…

Any other hints?

Hey all, Thank you for your patience. We are releasing a hotfix for this issue, as you can follow here: Samsung Connect Home/SmartThings WiFi Hub Firmware Hotfix Notes - 0.47.12

Please provide us with your feedback to see if this release may have restored functionality with your Zigbee devices.

1 Like

I got the update, but since I had reset most of my devices, the rest didn’t work. I have some in really hard to reach places (under dishwashers)

Hi Mike, I am having the same issue. I reset all my hubs and I can attached the main hub to the router and it works, however when I try to attach any sub hub the progress stops at 43% and then I get an error message. The SmartThings Hub firmware version I have is 000.047.00010. Looking for a fix

I still have the old Software version 0.47.10 and I can’s get any of my sub Smart Home sub node hubs to connect to the main Samsung hub. Keeping my fingers crossed, this new version will correct the issue. Will I need to connect all my sub hubs directly to the router in order to get the update?

Is the 0.47.12 only for the primary Samsung Home connect Hub or do the sub hubs need the update as well. If the sub hubs need the update, then will I connect the sub hubs directly to the router and will the update happen automatically?

July 18. Checked today and my primary node received the Firmware 47.12. I powered a secondary node and it flashed red/green. I continued through the smarthing software only to be disappointed with the same issue freezing at 43% with the same message “could not add device and try rebooting the wifi router.” I created another primary hub with another node and there are no issues with creating a primary hub. Created a new room too. I powered a secondary hub. Used the software to discover the hub and and the same issue, it locks at 43%. I tried rebooting the primary hub ( I takes about 5 minutes). Tried to add a secondary hub, same issue 43% and freezes. I Factory Reset the secondary hub, follow the app procedure and the same issue 43% and freezes. I am very disappointed in your product and the software developers. This product is only 2 years old and the money I spent purchasing this product and the hours I have spent after its initial failure when I factory reset the primary node weeks ago. The support staff is trying its best to make the product functional, but the software engineers fail to produce a quality product. Who wants to purchase a product with such a poor track record.

Hey Mark, I got a ticket open and sent several log files to support but still no fix with all the patching they have done, including the .047.0012… Did you have any luck? Need at least one sub hub working badly


Hi Mike,

The update did not work. Read my previous reply it is some what detailed. I spent most of the morning with four pages of details what I tried to do to get the secondary node to function. The developers are poor at best fixing this issue. The techs reached out to me again on July 1st. They never mentioned there was an update till I started searching and found this web site by Smart Things. I replied to a previous email by Saik Adnan and an email from Smarthings Team regarding my issue and the previous repair ticket. The Firmware 47.12 did not resolve the issue. We can’t be the only ones with this issue.

There should be a web page where we can change the firmware update to a previous one or when we press factory reset the original Firmware is set in place. Don’t have any idea when the developers sent out 47.10 or any previous updates. An email from the developing team would be helpful and for the end user to to yes update or no.

I totally agree, wish I would have not done the factory reset… Are you using Iphone with the ST app? I ran through the log files and saw a lot of errors related to apple.

I would like to try an Android device but I don’t know anyone that has one to use.


I am using a iPhone with the ST app. Where do you locate the log files? I tried an old iPad, but it has the current IOS. Still did not work.

Here is what Android user had to say about the App

Roger Grosse

July 16, 2023

Most frustrating app ever. Have used for a couple years now to control my TV in a pinch and half the time never works. When it does work is super buggy. It always says ‘To use this feature turn on your TV’. It’s on. Even if the TV is streaming to your phone, it won’t recognize it’s on. And when it doesn’t recognize it is on, it refuses to allow you to control it, so it basically useless as a controller. You can back ways turn it off though.

2 people found this review helpful

Did you find this helpful?

Samsung Electronics Co., Ltd.

July 18, 2023

Hi Roger, we apologize for any issue you might be having! Could you send details of what you are experiencing to our customer support at We’ll get you up and running.

Kendra Meyer

July 13, 2023

This app is the worst. Constantly crashes, won’t open, it’s useless. Every update causes it to crash. If I can’t access my shopping list, it doesn’t help me. I’ll go back to paper and pen. I have completed all of the recommendations. Cleared cache, Uninstalled multiple times, reinstalled, followed the directions on the app, which constantly boots me out of the cooking portion…I give up. Worst updates and completely useless… stand by the original rating.

14 people found this review helpful

Did you find this helpful?

Samsung Electronics Co., Ltd.

April 19, 2023

Hi Kendra, we apologize for the inconvenience. Please try clearing cache data, uninstall, reinstall the app and check the results. Clear the App Cache by going to your Phone Settings-Apps-ST App-Storage-Clear Cache. If the issue persists kindly write back to us at so that we can help to resolve the issue. Thank you!

Geoff Mounts

June 29, 2023

Not working at all with my Samsung TV, despite being on the same WiFi AND previously working on this exact TV. Makes no sense. The only reason that it’s even not working now was because I deleted and re-downloaded the app because it would close out every 2 seconds or so. I figured a good solution would be to uninstall and reinstall the app. Nope. Actually just made the problem worse and now I can’t even use the app at all. If they fix it, I’ll make this review look much different.

29 people found this review helpful

Did you find this helpful?