Samsung 6 Series TV "Cant download controller"

Good morning,
I got my Samsung 6 Series TV Added to my Devices in the SmartThings App last night but when I attempt to download the device controller, I get an error msg:

Cant Download Controller

  1. My TV just downloaded a software update this morning 8/23/18
  2. The SmartThings App also received an update on 8/22/18
  3. I am using the App on my Google Pixel 2 which just got updated to Android 9.0 about 2 weeks ago

Is anyone else experiencing this issue? Is this a problem Samsung is experiencing across the board? Any ideas on the fix for this?


It’s an Android 9 problem. I am having the same issue with a different TV (Q7 2018 model) with my Pixel original model phone. If you look in the reviews for the SmartThings app a bunch of other Android 9 users are having the same issue. I think the best thing to do is to wait it out until Google and/or Samsung fixes it.

I’ve been having the same problem ever since jumping in the Android 9 beta.

Android 9 makes some changes to how apps access the network (such as requiring certain versions of TLS) so I’m suspecting that is the cause, but I’m really just speculating.

Obviously still an issue. Just bought a new Q6F and the first thing it did on setup is prompt me to download the app which unfortunately won’t work because it always fails to download the “controller”.


Using my Pixel 2 XL on Android 9.0 Pie and the Smartthings app for Android is still giving the same error for my series 7 2018 Samsung TV. “Couldn’t download controller”

Lots of time to fix a little bug in their app seeing how long this has been an issue. Since they seem to have no interest in doing so I highly suggest buying another brand. LG, TCL, Sony. All great.

I completely agree with your post. It’s b*******that they haven’t been able to fix this issue. Part of the reason why I bought the SmartThings Hub is because of its Wireless functionality and it was advertised to work with multiple devices from different manufacturers. The great irony of course is the one device I can’t connect to the Smart Hub is my Samsung Branded TV. Horse shit

Wow that is some horse shit. Are you using a Pixel phone as well? I ask because I’m wondering if it’s some kind of discrimination thing.

Another pixel 2 owner chiming in with the same problem.

In my case three TVs all different models are impacted on two different Pixel 2 phones. Losing what faith I may have had in the new Smart Things app. What is really sad is I am in the market for another tv and may not pick Samsung when this feature doesn’t work (it is heavily advertised on their website TV section)

Yep. Same here. Got a beautiful Q9F and can’t do anything as I can’t download the controller on my Pixel 2…

1 Like

Same issue here with one plus 6 (Android P) on UE40MU6100K

I am having the same issue with my Pixel 2 and Samsumg TV.

Yup, same here my Pixel 2 can’t download my Q9F controller :frowning:

Same issue here, Q7F (2018). Just refuses to work on my pixel 2XL.

Same issue here with my Frame TV and my Pixel 2.
No solve anywhere and no answers from Samsung

I got an app update this morning. I was now able to download the controller. Everything seems to be working just fine now. The only downside, is that the app now requires permissions to the phone. One step forward two steps back I guess.

That’s actually pretty incredible and exhausting news. Gonna give it a shot when I get home!

When I first reported the issue, there’s was no fix. I sent a formal letter to Samsung mobile software division. The response I got from them was:

“Google didn’t give us enough time to get the app to work with the new is. An update should be available soon”

Ok… So the developer previews, beta’s, etc before the final release… MONTHS OF LEEWAY" no time.

I got an update 12 hours ago 10/25/18 now the download control works. But "we didn’t have time to prepare… what a bs excuse. Let me guess…one of the developers had a family emergency?

Either way, way to go Samsung. A little too late though. The new Vizio 2018 43" with Chromecast built in works just as well if not better. And it saved me from buying an extra piece of hardware.

To those reading, if you have the know how, Port scan your Samsung. You’ll be shocked as to what they’re collecting about you.

I worked with Samsung in this issue again. They told me that the update they did recently resolves this but it didn’t for me. I had to clear the apps storage in my Android phone then I was able to login and download successfully!

I just got a nu7100 samsung tv and the controller downloaded just fine on my pixel 1 XL and pixel 3 XL, the only thing that isn’t downloading for me is the controller for my r7070 smart vac, so it’s defiantly not samsung being biased against pixel phones… More like them being slow and lazy when it comes to updating their crap and getting it to work. Hence why I refuse to buy samsung phones with their “oh will release the new android os 1-2 years AFTER it’s released”!

Hi all I am having the same issue it’s quite unfair when you buy like me an Samsung Galaxy Note 9 plus and a 55" Qled and I can’t get it to work.
Any ideas when is this issue going to be fixed.