Routine isn't triggering


(Ben Hartwell) #1

I have a Phillips Hue hub linked to my Smart Things Hub. I edited the “Good Morning” Routine to turn on some lights via Hue when motion is detected with a SmartSense motion sensor.
If I manually tap the button “Good Morning” in routines the lights turn on as they should. If I go to devices, select the motion sensor, it’s pickign up motion. In my Routine settings under additional settings and “Automatically perform “Good Morning!” when…” I have “Things Start Happening” selected. Within that setting I selected my SmartSense Motion Sensor during the time window of 5:30 and 7:00


(Meep Meep.....) #2

maybe the scheduler is broken for you GM routine. give this a try. update it. (also look at your logs to see whats happening). this can be tested by changing the GM time from 5:30 to now+1minute. see if it runs; if it does – bingo; change back to the desired GM time.

it could also be: 3rd party hubs not working


(Ben Hartwell) #3

I tried the clicking update where you mentioned going to do so.
I tried changing the time. Still nothing.

I also have one automation listed under Smart Lighting in Smart Apps. This turns my lights on at sunset, that has been working fine, so I don’t think there is an issue between hubs. My activity log shows the motion sensor being triggered and it will show the routine if I tap “good morning.” So it looks like SmartThings isn’t applying the trigger.


(Ben Hartwell) #4

I think I might have figured out the problem. “Good Morning” was the only routine I programed. So maybe routines are more of a “status” then an “action.” I hit “goodnight” then walked in front of my motion sensor and it initiated the “good morning” routine.

After looking at the settings again, one of the actions in the routine is to change the mode. Good morning changes it to “home.” So maybe it needs to be in “night” mode for the good morning to trigger.