Smartthings & Fibaro (Plug & Smoke detector)


(Joerg23at) #1

Hi,
i’m having a major problem integrating “standard” z-wave devices. It seems as if z-wave isn’t as much of a standard as it should be or as it is advertised to be… or one or more vendors are not adhering to those standards.

In any case, I’m trying to integrate 2 Fibaro devices, a wall plug and a smoke detector.

The integration of the wall plug worked - in principle. I can turn it on and off and it shows the kWh and W but i cant configure it at all. It shows the tile for configuration but pressing this button doesn’t do anything. (btw, it is integrated as a Z-Wave Metering Switch but it seems as if Fibaro needs some special treatment)

The smoke detector doesn’t work at all. It is integrated (and I can exclude it again) but it is integrated as an inactive “Z-Wave Sensor”. Switching it to a Z-Wave Smoke Alarm (under “My devices” in the developer tools) shows the correct icon on the Things dashboard but it still doesn’t work. (Updated incorrect wording)

Unfortunately I’m not tech savvy enough to program my own device type (or to be more precise my own Fibaro device type).

Any help appreciated!

I will post a similar thread on the Fibaro forum.

thx
joerg


(Andrew Urman) #2

The configure tile is just to send the configuration parameters to the device again. It doesn’t actually open anything up. Which is pretty confusing actually!

On the smoke detector, when its paired as Z-Wave Sensor does it actually detect anything? Does the icon go blue?


(Joerg23at) #3

No, it doesn’t detect anything. Icon does not change at all.

Another thing i found out: you can make a range test with the smoke detector. The outcome - according to the manual and the indicator lights i get is: “Fibaro Smoke Sensor is not able to connect to the main controller directly or through another Z-Wave network device”. That’s strange. Especially because i was within 2m of the ST hub.

?!?


(Joerg23at) #4

Hi Andrew,

i have some news: i bought a test spray today to test the smoke alarm.

i reset, excluded, reset again, included the fibaro smoke sensor again. it was seen as a z-wave sensor and when i used the spray, the alarm rang and the sensor was “active” on my dashboard. so far, so good.

i then changed it from “sensor” to “z-wave smoke sensor”. and sprayed again. alarm rang but dashboard did not show anything. :frowning:

now, then i changed it back again to “sensor”. and once again it showed “active” after spraying.

BUT: i can’t do anything in the smartthings dashboard with the sensor, i.e. i can’t program it.

so: at this point I know it works but I can’t include it in my smartthings setup… :frowning:

any ideas?


#5

@Urman Any updates in this integration?

Thanks!!!


(Joerg23at) #6

Hi,
no, no update unfortunately.
I have given up on Smartthings. They have completely stopped working with me on this. Since then I have bought a Fibaro Home Center and it’s some much better then the whole Smartthings stuff, it’s not even funny…
Sorry.
br
joerg


(Andrew Urman) #7

@Kooltaco check out this thread Fibaro Things - General


#8

Great news on the Fibaro Motion Sensor!!!

I am really interested in the smoke detector as it is exactly what I am looking for in terms of features, size, styling.


#9

@joerg23at

Do you still like your Fibaro Home center? can you please tell me more about it? It looks great but i would like to know if your installation went fine. The lack of community affraid me a bit if i’m having problem with installation. This is something i really like about ST.
What do ou prefer of Fibaro and of ST?