*RESOLVED* Logitech Harmony Hub Integration Slow to Execute


(Guy) #1

Hi all,

Just thought I would share some advice for anyone finding their Harmony Hub is slow to execute commands, I originally fixed this because I was asking Alexa to perform commands and would find 9/10 the Hub wouldn’t respond and then 2-3 minutes later perform the command. Since performing this fix, I have also found my Harmony integration on SmartThings works perfect too.

Anyone with a Draytek router will most likely be experiencing this issue, so here goes:

The TCP WWW Timeout value is too low on Draytek routers for Harmony via Alexa to work consistently. The default value on my Draytek was 60 seconds, I saw a post from Logitech saying to try increasing it and since setting mine to 3600 secs mine has worked every time.

To change NAT session timeout values, connect via Telnet or SSH and run ‘portmaptime -l’ to make a note of your existing values (in case you want to revert the changes later).

Then to set TCP WWW Timeout value to 3600, run ‘portmaptime -w 3600’.

Reboot the router and all should be working great.


Harmony/SmartThings Lag
(Kraeg) #2

Can this be done via the UI do you know?

I’m running a 2830 and a 2860 and my harmonys are horrible, so so slow.

Kraeg


(Guy) #3

Hi there,

I have a 2860 and couldn’t see any way to do this via GUI, so I downloaded WebSSH onto my iPad to SSH into the router:
WebSSH Essential - SSH & SFTP by Arnaud MENGUS


(Kraeg) #4

Just thought I’d check in again.

This worked well for me, I did some more tweaks but this certainly helped.

Mine took 24 hours to apply and start working better, but might be due to the fact I didnt reboot the harmony hubs (they are in places which arent easy to reboot).

Thanks for the advise @Guy1992

Kraeg


(Guy) #5

Thanks for the updated Kraeg, glad its working for you.