Router timeout causing Alexa errors

This is super technical, but interesting.

Different brand/models of routers have different default timeout settings, with some much lower than others.

It looks like quite a few Alexa errors are caused just by Alexa failing to get a response from a cloud service because the router has timed out. This appears to be particularly true for Logitech Harmony and SmartThings. And this appears to be one of the most common reasons why echo will tell you it can’t do something but that thing actually occurs. It’s because the message to do the action did go through to the other cloud service, but the response that the action was completed doesn’t get back in time.

In most cases, you can adjust the timeout setting on your router, although the exact process will vary from model to model. It won’t make anything run faster, but it will get rid of the Alexa error message.

The following article describes the problem very well. It’s highly technical, though. Still, I thought some people might be interested. :sunglasses:

https://www.mysysadmintips.com/other/web/732-logitech-harmony-hub-and-amazon-alexa-integration-issues