Harmony Hub w/Remote ~ Delays? - RESOLVED

Ok, I’m asking this here because I honestly don’t know where else to go…

I’ve got the Harmony Hub with the simple remote.

If we’ve been watching TV for a bit and then pick up the remote and press guide, or menu, or anything… there is a huge delay (5 seconds) before anything occurs. The light on the hub doesn’t flash or anything.

Is the remote going to sleep?
Is the hub going to sleep?
is there a way to make it NOT do this?

Thanks (I ask y’all cause you have a clue)

You have the wifi remote? (The one without the screen)

If so, it should be near instantaneous as long as your Wi-Fi is strong. If it has trouble finding Wi-Fi signal you can have a delay ( basically the same thing as Netflix buffering).

There are adjustable delay parameters for the harmony which are used to give the receiving device time to process a command before it gets another command. If you have one of those set up incorrectly, you might get a delay, but then it should happen every time.


This is the one I have…

Do you have to have it pointed at the TV to get it to work or will it work no matter where you point it? If it will work no matter where you put it, it’s a Wi-Fi remote.

Also note that some remote send a signal as soon as you press a button, but others don’t send a signal until you release the button. This is particularly true for models that have a short press/long press since it’s timing the press. All of which means if you are used to a remote that sends as soon as you press a button you have to retrain your hand to press and release quicker in order to get the signal to send quicker.

Yes, it’s a Wi-Fi remote…

As for pressing the buttons, that’s not an issue.

There is definitely a strong wifi signal… I know that’s not a problem as well.

It’s only got the delay the first time that I press the button, if it’s been sitting for a few minutes.

Not sure if that remote has it but I just got the elite and there’s a settings adjustment for delaying the inputs from the remte.

Yeah, I can do that too… but that’s not the problem. It only occurs the first time it is used after sitting for a little while. I’ve done some searching online and found that others have the problem too. I just haven’t found a solution.

Oh like it’s taking a nap. I’m sure you’ve tried the rebooting route?

No need to reboot anything. I know it’s not the network or the harmony hub. I tell Alexa to do something and it’s immediate.

The only delay is with the remote.

I think I know what it is, but I can’t find any docs to prove it.

The remote is a Wi-Fi remote. It runs off of a cr2015 battery. I think the remote is going into standby to conserve battery life and it takes a couple of seconds to wake up and reconnect.

Could be a battery saver, the elite has a reboot just for the remote also don’t if yours does but ya if the hub works quick thru alexa than thats probably not the hub.

Are you sure it’s a wifi remote and not RF? I’m like 99% sure the remote and hub communicate with each other via RF. The hub and app communicate via WiFi.


I thought so… But IR is line of site.

Wi-Fi isn’t. I stuck it under a thick pillow facing the opposite direction and it works

IR (infrared) is line of sight, yes. I’m talking about RF (radio frequency), which is not. RF and WiFi are similar in that they are both radio waves but different in that WiFi requires a connection to a wireless network, where RF is direct communication between your remote and hub.

1 Like

Oops… I read that wrong… You did say RF.

I’m not sure. I honestly didn’t think about it being RF, but I’ll check into it and test the remote.

That still doesn’t explain the, what seems to be a standby mode, delay.

1 Like

The remote talks to the hub via RF.

Have the same remote and button presses immediately cause the hub to flash. My remote was sitting all night, and was cold start.

The remote should not even have a standby mode, it has nothing to sleep (like a screen). Waking up from a button press then transmitting a RF signal is not saving energy.

Was it working before? Did this just start?
Try using the smart App for harmony. The delay could be in the hub.

Trying to remember what happened when my battery was going out. If I remember correctly I was getting weird behaviors. Delayed responses was one of them.

I would still reboot the hub and maybe battery pull from the remote. I seem to reboot my harmony hub every couple months for some reason.

1 Like

I will try that, including a new battery. This thing is less than a week old. If it keeps up, I’ll just exchange it.

1 Like

Mines been doing it too… Let me know if that works

Week old it should be good, unless the battery was dead on arrival.

@JDRoberts may be onto something. The remote has short/long presses. I usually set up the same key press action on both short/long presses (suppose to be by default). Might want to check that.

Check firmware, but I am assuming on setup it updated.

Good Luck.