(RESOLVED) Leviton Z-Wave Smart Plug DZPA1 Pairing

I have a Leviton Z-Wave Smart Plug DZPA1 I am unable to pair. I have gone through the steps with Leviton support and they have replaced the device but still unable to pair. I hold down button for 7 seconds while Smartthings is searching for devices, then when the light begins blinking I press and it goes through the device pairing process but Smartthings never finds anything…

If you have used any custom device handlers in the past, you may want to login to IDE, open the device handlers and Publish for Me again. Then exclude the device and try to pair it :slight_smile:

I have other leviton smart plug devices and did not have the issue pairing (used same method). I have tried excluding after unsuccessful pairing and it always excludes an unknown device but never finds it during pairing. Leviton is no help on this one.

Did you add the others in the past or currently? If in the past, again I will ask if you have used any custom device handlers? There is a condition where device handlers may become stale preventing you from pairing new devices

1 Like

I have added the others more recently (1 a week ago) and they are not using custom DTH.

Might be an older firmware version on the switch. I think I have seen that reported before so hopefully someone with these switches can offer better advice.

This was a replacement from Leviton and they confirmed the firmware is the most recent.

I had this same issue with this device trying to add to a fiends network. Had to do a hard reset on the device (continue to hold button until it blinks red) then try to repair again. Worked for me.

1 Like

Same issue… I perform the reset, then set smartthings to search for device. Hold button on plug for 7 seconds and let go to start blinking. Press button again and it starts flashing faster, then after a few seconds, the light turns off then solid. Never finds it in Smartthings though.

Anything show in live logging in IDE when you attempt to pair?

Nothing, I have another call with Leviton today.

I have resolved this issue. While watching the IDE Live Logging while pairing it looked as though a device was being created as a custom DTH but not in the application. I was able to press the switch and saw it turning on/off in the logs. I excluded the device (which always showed unknown device excluded) and deleted the custom DTH as I wasn’t using it. Once I tried to pair again it worked as expected.