Resetting the hub


(Christopher Masto) #1

I haven’t been able to find any information on how to reset the Smartthings hub and start over from scratch. I had big plans for this weekend to get rid of my Nexia and clean up and re-do my whole Z-Wave setup with SmartThings. I overnighted a kit because this is the only chance I’ll have for several weeks to go around the house re-pairing everything. Unfortunately, I started by testing a bunch of stuff and now I really need to start over from zero. (Literally, as I have some Z-Wave keypad controllers that don’t work with node IDs > 32, so I need to start at the beginning and add everything in a careful and controlled fashion). In my attempts to do this myself, I deleted my account through the web site, which didn’t really delete me account, it just rendered it unusable. I can’t add a location, and I can’t sign up again because the e-mail address is still taken. Does anyone know how I can fix this? I won’t be able to get ahold of support until it’s too late. I never imagined this device would have no way to reset its network…


(John Rucker) #2

Have you connected to the IDE and looked at your hub ? There are several commands you can send your hub and one of them is labeled Join/Leave another Z-Wave network.

URL to get to your Hub List https://graph.api.smartthings.com/hub/list You will have sign up just follow the prompts.


(Christopher Masto) #3

Yes, I have been through every screen in the IDE, that’s how I managed to delete my account. “Join/Leave another Z-Wave Network”, as I understand it, would be to make the hub a secondary controller. That’s not quite what I’m going for.

I did manage to create a new account and manually add my hub to it by using its ZigBee ID. Unfortunately, it’s still numbering Z-Wave devices where I left off before (now I’m up to 0x0C). Also, the utilities menu is now displaying no options other than Z-Wave Exclude, for some reason.


(Christopher Masto) #4

Utter failure. :frowning: I’m so frustrated right now. There went my Saturday, and now I have to pack all this junk back in the box and return it.


(Tim Slagle) #5

I’d reach out to support. It’s not "junk"and the reason you are having all this trouble is security(don’t want people adding random devices to an account then controling your house with it) . Basically you can’t fully “reset” the hub without supports help due to a bunch of stuff that needs to happen on the backend first. Shoot them an email at support@smartthings.com. I have even gotten a respons from them on staturday, which is rare for a company like STs.

Good luck, and welcome to the forums!! Always cool to see a new face!


(Christopher Masto) #6

I did reach out to support, but I did not experience the miracle of a Saturday response. Your security explanation makes no sense: I have several other Z-Wave controllers and all of them have a network reset function. You may be misunderstanding what I’m trying to do, it doesn’t involve adding random devices to an account. I need to erase the node list so that devices added start again with low numbers. Anyone using GE/Jasco Z-Wave products (such as these otherwise lovely keypads: http://amzn.to/1va2IE7) will eventually that they have a major flaw and don’t work with node IDs above 32. I’m planning to slowly replace mine once I find a suitable alternative, but from what I have seen so far of SmartThings, it won’t let me program codes on my Schlage lock, it can’t do a network reset or become a secondary controller, I have to keep restarting the iOS app to add devices, and technical support may be difficult to obtain. I’m stuck having to make a leap of faith that if I live with being unable to control half the lights in my house for another 2-3 weeks until I have a free weekend again to play with this, I’ll be able to get it reset by then and won’t run into another fatal flaw. Or I can give up and reprogram everything back to the Nexia tomorrow. Z-Wave pairing is such a hassle, once it’s working I’m loathe to touch it again.

That reminds me of another issue there’s probably no way to solve. I have some hardwired light switches, I don’t understand how I’m supposed to add them to the SmartThings hub from several rooms away. The Nexia hub at least has a battery so you can take it to the device you’re adding. This seems like a necessary feature that has been left out of SmartThings. How are other people managing to deal with this?

P. S. I acknowledge that I’m in a bad mood and my language is perhaps harsher than warranted. I had very high hopes for what I would accomplish today, and now I have to explain to my family why the light switches don’t work. I should have held off posting any rants until I’ve had some time to cool off.


(Tim Slagle) #7

I can answer this. I didn’t have a problem with this. I was able to pair all my zwave switches throughout my entire house from the gangbox. Some even went through two floors to do so. I have paired all my switches without moving the hub. I currently have 16 hardwired switches I’ve done this with.


(Tim Slagle) #8

Yep. Misunderstanding. My bad. Support can help:)


(Edward Pope) #9

@masto I hope you hang around and give ST a chance. Like yourself, I am a new user. I have been here for a little over a month now. And, like yourself, I had the new install challenge. I stuck with it, and really enjoy ST very much now. The community here is very helpful, and the ST staff is great. Give them a chance, stick with it ok?


(Christopher Masto) #10

So yeah, I went around the house last night and used a handheld controller to exclude everything, set up a new network, and get all of the lights and keypad buttons assigned the way they’re supposed to be. I have no “automation” in my home automation setup at the moment, but I’m a lot less cranky this morning.

If I can just perform a primary shift to the SmartThings, or even add it as a secondary, I’ll probably be good to go. I don’t understand why that doesn’t work – the option is there in the iOS app and in the web IDE, but it appears to do nothing whatsoever. The green light doesn’t blink, and it doesn’t accept a transfer from my primary controller. I read all the forum threads mentioning the word “secondary” and I can’t tell if anyone has ever gotten this to work, or if it used to work and stopped, or what. I would love to get this working today, since I bought a kit with a bunch of sensors and presence devices, and I seem to have solved the problem with my account. If I could either add it to my existing Z-Wave network or reset the node ID numbering, I’d be good to go and could spend the rest of the day tweaking behaviors.

I will be patient, since I can see the potential. While I believe that it should be possible for the end user of any consumer electronics device to reset it to a factory default state without involving support, I understand that most people wouldn’t need to do that. From the little I saw while trying it out, this is a pretty good product, and the relatively open API means I should be able to do some interesting things, especially when my Arduino shield arrives.

I do think there’s a larger issue lurking, as many people have GE/Jasco products (everything from Jasco appears to have the same defective design). I don’t understand how they can pass Z-Wave certification while being limited not just to controlling 32 devices, but to only control the first 32 devices you add to your network. The way node ID numbering works, numbers are assigned sequentially and not reclaimed when a device is deleted. I started using Z-Wave in 2009, and it doesn’t take much tinkering over 5 years to “waste” a bunch of node IDs. I predict this community will be full of people running into this problem before too long. As I understand it from talking to Nexia support, the Z-Wave chipset everyone has to use gives you very little control over the process: you can only tell it to go into inclusion mode, and it does the rest, including maintaining node numbering. I like the idea I’ve seen elsewhere on this forum about making “virtual” devices so the remote is not directly controlling switches, but rather a virtual device generated by the hub, which triggers an action. This seems necessary to use Z-Wave remotes to control a multi-protocol network, but I suspect it’s impossible due to chipset limitations.


(Edward Pope) #11

Actually I am using a mixed network here. I do use Z-Wave GE switches for my lights (but thankfully that will end up being way under the Max of 32). I use Zigbee for various motion and other sensors (ST Multi for example). However, I can see that once I expand my horizons to replacing the electrical switches that we might start running into this issue.

I guess a question for ST is there a way to code around this issue?


(Convinced ST will never be unbroken…) #12

I am not all that familiar with Z-Wave, but is the node ID the same as the network ID shown for the device?

If so, this is an editable value in SmartThings. Does it simply not apply to Z-Wave devices?


(Christopher Masto) #13

It is editable. I don’t know why. Editing it only makes the device stop working (or perhaps be confused with another device). As I understand Z-Wave, it would not be possible to simply renumber a node since all the other nodes maintain an address table of their own. There’s a lot about Z-Wave that kind of sucks, and this is one of those things. Once I get a reset, I can start over and all will be ok until I get half a dozen more switches and there’s just know way to fit them in to the lower 32.


(Convinced ST will never be unbroken…) #14

Wait… are you saying no switches will function if they are assigned a address of over 32, or just within the context of a jasco controller?

And just thinking out loud here, if you edit the id, and then repair the network, would the address table be rebuilt?


(Christopher Masto) #15

Z-Wave is supposed to support 232 devices on a network. (More information: http://www.vesternet.com/us/resources/technology-indepth/understanding-z-wave-networks)

The problem I’m referring to is specific to these Jasco controllers. They are advertised as “Up to 32 Z-Wave devices can be included in each of the Groups and Scenes”. This is not entirely accurate. What happens is that as soon as you have a switch with a node ID over 32, the controller acts like it’s not there. Performing the procedure to add it to a button just ignores it. If you do a Google search for “jasco node id 32”, you’ll find a lot of forums where people have run into this flaw. This isn’t just a problem if you have lots of devices. As I’ve explained, node IDs are assigned sequentially, so if you add and remove devices over time, you will eventually end up with IDs over 32, even if you have only a few devices in your network. Just removing and re-adding the same device causes it to get a new node ID.

I have four of these keypads, purchased before I ran into the node ID limitation. They were a great solution to the electrical wiring limitations in my apartment. Eventually, however, I added a few more lamp modules and couldn’t get them to work with the keypads, which led to discovering this problem. I only have 25 devices, so rebuilding my network from scratch carefully, to avoid any wasted node IDs, allows it to fit within the keypad limitation. I will have to buy new keypads eventually, but I’m putting that off because the HA market is continuing to change rapidly. Maybe I want to go all Zigbee or something else.

Putting on my software engineering hat for a minute, I think that editing the ID in the Web IDE only changes the internal table that the hub’s software “knows” a device by. I doubt that it even tells the Z-Wave chip about the new number: I’ve been looking at Z-Wave APIs today and I haven’t seen any of them that have such a facility. So, for example, if a switch is 0x08, and you change it to 0x07 in the UI, the switch itself still believes it’s 0x08 (and it stays 0x08 on the network). When you try to control the switch through SmartThings, the hub will say to its Z-Wave chip “turn on switch 0x07”, but that won’t correspond to the right device, so it won’t work (or will turn on the wrong switch). If someone made a HA platform that let you centrally manage and program Z-Wave devices, renumber the network, etc., I would buy it for any price, but I’m pretty sure that can never happen while the protocol is under the thumb of Sigma Designs.


(Convinced ST will never be unbroken…) #16

Ok… then rather than binding the jasco controller to the individual switches, could it be paired with the hub and send some variety of events?

I have some auxiliary switches that, with a modified device type, simply send on/off messages. Then a SmartApp can be assigned to actuate the control part of it.


(Christopher Masto) #17

No, it’s a secondary controller, not a switch. That can’t be changed. There are some threads about “virtual” devices, but I don’t see that ever being implemented.


(Edward Pope) #18

Hmm, Sounds like this should be brought up to the ST team. I suspect that they can write something on there side that will deal with this issue automatically when encountered. I know many people who use Jasco/GE switches as I do as well. I run a mixed mode, but even I can see that at some point this is going to affect me. Do you mind if I send a message to support about this? Or could you do it?


(Christopher Masto) #19

@theedpope if you want to work with ST on ways to deal with this, feel free. I’m taking the route of waiting for my hub to be reset so I can “renumber” everything the hard way and stick my head in the sand again for a while.


(Edward Pope) #20

@masto Just to let you know I sent them an email. I do not expect them to come up with a solution immediately. But, I can envision a smartapp that might be able to do this for us as a task in the back ground as needed.