Replacement iPhone Not Working as a Presence Senso

My wife recently replaced her iPhone. I deleted the old one and used Smartthing app to connect the old one. Her phone with new name, etc always shows as present. :cry: Thanks for any help on this.

Did you tried to deleted her phone from ST and added it again?

I mean to remove her phone as a “Presence Sensor”.
Then, Add it again.

Yes, I deleted it and deleted the App from her phone. When I add it again, it shows up, but does not work as a presence sensor. Her old phone worked fine and I think ST is assuming the new ‘added’ phone is the old phone. Since old phone is no longer around, its ‘presence status’ never changes.

Create the “New Phone” with OTHER name (not the same as it was the old phone).
This should work. You can add an additional letter, number or even and underscore ("_").

Also, try to open GPS Maps on the “New Phone” to see if the phone is actually actualizing its position correctly.

Just checking… you logged in with her ST account on the new phone? :slight_smile:

This is one of the most frustrating things for me with this system…replacing phones. It is always a chore to get it figured out. I end up using multiple email addresses so I don’t ever have a duplicate device. I “think” the trick is that you must log off of the old device first before re-using the account on the new device. I just went through this stupidity a few months back when I got a new iPhone. I spent two weeks trying to figure out what the issue was. I gave up and just used yet another email account to log the device in.

I think we figured it out. Her phone’s location services for the ST app, was set to ‘when using the app’. It has to be set to ‘always’. Thanks for everyone’s help.

My wife got a new phone the other day. I backup the old one. Swapped the sim card and restored the back up to the new one. ST never missed a beat like it didn’t know the phone changed.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.