Replace Device doesn't work


(Justin Cox) #1

For the life of me, I cannot get the “Replace Device” functionality to work. I’ve tried just about everything but it seems to be stuck on “Checking Device Health”. Has anyone else had this problem? I found this post and tried these steps but still doesn’t work: Using “Replace Device” for Z-wave devices Any help would be greatly appreciated. For context, I’m trying to replace a GE dimmer switch (with the same switch that I have already excluded).

My “smart home” became dumb over the past few weeks and most of my GE switches are not responding to the ST hub, so I’m trying to re-add the devices. I really don’t want to delete them and start all over, which is what I thought the replace functionality was for but I can’t seem to get it working.


"Replace Device" Doesn't Work? Try this manual work-around
(Andrea Bianco) #2

If I am reading this correctly, you have already “excluded” the device? So you would need to re-pair it with onto the hub. Maybe I am not clear. I have alot of GE Zwave switches and have had to exclude and re pair a couple myself. None recently though. Can you go to market place and add ? have you checked your IDE to see if the device is listed?


#3

The OP wants to use the zwave replace utility rather than adding the device as a completely new device. This utility will reuse the device ID rather than assigning a completely new one, which means you can use all of the existing smart apps and routines without having to update them.


#4

I’m sure that’s very frustrating. You can talk to support and they should be able to help.

Meanwhile, just to be sure, you said you excluded the device before you try to replace. Did you do a general exclude on it or did you remove it specifically? If you removed it specifically, its ID is no longer available in the system to replace.

Also, one more thought… The GE switches have a known issue which is that as they get older (usually about six months after out of warranty) they could have trouble staying attached to the network. They need to be physically reset. You can try just pulling the airgap switch, but that isn’t always enough. However, if you cut the power completely, typically by throwing the circuit breaker at the box, that normally will reset them and they will then be able to process network traffic again.


(Andrea Bianco) #5

say it aint so. I have only had mine 6 months. . . I can’t imagine replacing them all ! ugh.

Justin. . . I would check the IDE to see if your device is there (ID) and check the state etc first.


#6

It’s not all–from reports on various forums, it looks like about 15% have the problem. They aren’t technically defective, because it doesn’t happen until they’re out of warranty. It’s just a higher failure rate than other brands. But because the GE’s are so inexpensive relative to other zwave brands, most people figure they still save money by putting in the GE’s and replacing 10 or 15% of them eventually if needed.


(Justin Cox) #7

UPDATE: I was never able to get the “Replace Device” functionality to work properly. It was stuck on “Checking Device Health” for every device I tried (previously excluded or not). Ultimately I had to “start over”. ST support was extremely helpful and stayed with me on chat for most of the day (Thanks Ethan!). Unfortunately starting over was a huge pain in the butt, as you can all imagine.

If I had to distill down what happened, basically my z-wave network took a sh&^ and the entire “smart” home no longer functioned. Slowly removing (excluding) and re-adding (marketplace > connect new device) for each switch I was able to bring everything back online. Some devices did not require being re-added, they just magically started working after the network started repairing itself. I excluded and re-added about 7 (of 30). After that, I had to go in and completely remove the no longer functioning “old” device entries…which as you know, requires that you first remove them from each smart app…what a pain. About 6 hours invested into getting everything back to normal. Here are some things I learned to help others:

  • Z-Wave Replace Device never delivered on its promise. It just flat out didn’t work.

  • ST Support does NOT recommend using Z-Wave Network Repair utility for a household that has as many devices as I do (~30). Not sure why. I didn’t get a clear answer but they said stay away from it because it will make things worse, which it did. I probably ran that about 10 times in the past 2 weeks.

  • Z-Wave Device exclusion only reported (iOS app) the device actually being excluded about 50% of the time, even though in the background it had magically been removed.

  • If you have more “things” connected as I do (Harmony Hub & Amazon Echo) you have to start over there too. Delete all the devices and re-add your ST account etc.


(Justin Cox) #8

@JDRoberts thanks for the link about the GE switches. That’s basically what happened to me, though all of my devices started failing around the same time. It was almost a domino effect over a two week period. I wish “replace” would have worked, that would have saved me a lot of time :frowning:


#9

Glad you got it working again. Zwave devices that magically reappear with the same device ID are typically because the controller keeps its own backup copy of the device tables. There are a few situations where if the controller is malfunctioning it may reload from an old backup. That restores device
IDS for devices which were previously removed.

regarding the “don’t do a zwave repair”, that has been posted by some SmartThings staff in the forum, but honestly it’s a really weird statement. It must have something to do with the SmartThings cloud architecture. For a regular Z wave installation, a repair should always be a “can’t hurt, might help” utility.

SmartThings competitor Vera runs an automatic repair every night. Smartthings competitor Homeseer recommends a repair every night, but leaves it up to individual customers to schedule in case they are using the system for security and they don’t want it to go off-line.

And most certified Z wave controller manufacturers feel that a heal is more important for a larger network, although it does it definitely take more time. SmartThings competitor ISY support says

We have yet to see a situation where healing was not required and especially in larger venues.

Also, just to point out the obvious, how are you supposed to add new devices to the network if you can’t run a repair? Just run the entire installation with broken neighbor tables?

The verbiage in the official knowledgebase article matches what you would find for any certified Z wave controller:

I know that support is giving this new advice to not use the repair utility to some people. And maybe there are circumstances where the hub and the cloud account are out of sync and you need to avoid doing a zwave repair until that is fixed. But being able to use the repair utility is an essential part of maintenance for any zwave network. Unless you want to rebuild the entire network every time you add a new repeater. :scream:

FWIW


(Andrea Bianco) #10

I am grateful for this post. I have NEVER repaired my zwave network - for fear of what you have stated happening - happening. IKES! so we have a repair utility that is useless or even harmful. Makes no sense. I KNOW that my mesh network would / is not OPTIMIZED as I have added on a few things here and there. BUT because it works - I “left well enough alone”. I believe someday I will need a re- pair to get the mesh optimized, but I suppose should prepare for the worse in that event.
Thank you for the info!


(Matthew Freestone) #11

Hi guys, does ‘replace’ work with ZigBee devices? I have to replace a SmartThings multipurpose sensor with an Iris contact sensor and I don’t want to go through the massive rip and replace as that sensor is tied to a LOT of things. I see the issues posted here about doing it with zwave, but what about ZigBee?


#12

No, the replace utility is specific to Z wave devices and will not work with zigbee.

This is because of the difference in how the two protocols assign device IDs. With Z wave, it is the controller that tells the device what its device ID will be at the time that the device joins the network. This is why it is possible to reuse an old device ID for a new device.

With zigbee, each device has a permanent ID which it tells to the hub at the time that it joins the network. So you can’t have a new device take on the identity of an old one, it just doesn’t work that way in zigbee.


Replace button?
(Ray) #13

Just an extra thing to add to @JDRoberts post. With ZigBee, it’s even easier to replace a device without deleting anything in Smartthings. Just do a reset of your delete and discover it again with Smartthings. You won’t see a new device during discovery but the device will get added back to the same existing device in smartthings because of the zigbee ID stated by JDRoberts.


#14

That works when replacing a device with itself. In this case, I believe the OP wants to replace a defective SmartThings brand sensor with a new Iris brand sensor. They will have different zigbee IDs.


(Ray) #15

Ahhh… I see. Ignore my post. Old age is getting to me. Need to re-read.
One other thing you could do is once you get the Iris added. Copy down the fingerprint and ID, add to the multi sensor. Delete the Iris sensor in IDE, reset the Iris sensor and run discovery again.


(Matthew Freestone) #16

@JDRoberts is correct.


(Matthew Rogers) #17

Here we are, over a year since this thread began, and “Replace Device” still doesn’t work. It just hands on “Checking device health…”, and then eventually crashes back to the Things list.

Even more fun, I can’t even remove the device! Standard remove or force delete, the device entry won’t go away from my Things list.

I don’t even use SmartThings for automation anymore, it’s just a dumb device hub for me at this point. And every time I have to return to SmartThings to do device management I’m reminded why I left 90% of it behind.