Re-pairing....Is there an easier way?


(Ben) #1

I have a GE toggle switch that isn’t talking to ST after a hub reboot. My understanding is that I will need to re-pair the switch however, if I’m not mistaken, that means I will need to first exclude it, which means that I’ll need to remove it from all of my apps.

This switch is tied to multiple apps/pistons…:sob:

Is there an easier way to re-pair devices? (Please say yes, please say yes, please say yes).


#2

Yes, that’s exactly what the zwave replace function is for. You Can replace a Z wave device with itself if you want. This only works for Z wave devices, not Zigbee.

With GE toggle switches, though, first try just throwing the power at the breaker ( not just the airgap, although of course you should make sure that the airgap is in the correct position). Cutting the power at the breaker often restarts those.


(Kenneth C) #3

Deleting the device through the IDE will remove it from apps… I found this to be the easiest way to delete devices with multiple smartapps or part of CoRE pistons.


#4

But replacing mean you don’t have to touch the smartapps at all, the new device will slide right in under the previous device ID and you won’t have to rebuild your pistons or other smart apps. :wink:


(Kenneth C) #5

Interesting… I don’t have many in-wall switches, but the few Lutron Casettas I have (which don’t work with ST) are a pain to reset. The Replace feature seems interesting and convenient… but only for Z-wave devices. :slight_smile:

I do feel the OPs pain of deleting devices through the ST App, and having to remove subsequent Smartapps manually.

Having gone through a recent ordeal with my Zigbee devices, I want to say deleting devices through IDE doesn’t delete the smartapp… which is pretty convenient also. Open the smartapp (or CoRE piston) and re-select the trigger.


#6

Again, zigbee is different. Each zigbee device has its own unique ID, which it reports to the hub at the time of pairing.

That is not true for Z wave. In Z wave, the hub assigns the device ID, and you cannot change it for force the hub to use a particular one except through the replace utility when it will reuse the one that you are replacing.

Smart apps and core all refer to devices internally by their network IDs.

Consequently if you have a zigbee device and you force delete it from the network and then you re-add that same device, it still has the same network ID, and so your pistons will be able to find it again without a problem.

But if you have a Z wave device and you force delete it from the network and then yoU and then you re-add that same device, it will have been given a brand-new network ID. There’s nothing you can do about that. And all your pistons and smart apps will be looking for the wrong device and so you will have to go through each one and remove the old device and put in the new device or the piston won’t work. That is what Z wave replace utility is intended to avoid. If you use the replace utility instead of the force delete on a Z wave device (and again it only works for Z wave devices) Then the Pistons will be looking for the correct device ID and everything will still work.


(Ben) #7

Can you explain what the “airgap” is and how I check it? I keep seeing this term in the forums, but don’t know what it refers to?

I tried the z-wave replace, but just get the never-ending spinning hamster.

Thanks @KC_703. I discovered this last night when my garage door opener decided to go walkabout, and wouldn’t cooperate.


#8

The airgap switch on GE devices is used to disconnect it from power while you’re working on it. The problem is what that well it’s supposed to be out means disconnected and in means connected, it’s possible to have it partway in and get weird results. Especially as the switch gets older.

Air Gap Switch
During normal operation, there is a small amount of power passing through the switch to the load even when the switchis turned off. This device has an air gap switch on the lower left side (see diagram for location) to completely disconnect power to the load. Pull the air gap switch OUT to disconnect the power while replacing light bulbs and push it all the way back in for normal operation. The air gap switch must be all the way in for the switch to function and control the lighting.

So the first thing when troubleshooting these devices to make sure the air gap button is pushed all the way in. :sunglasses:


(Ben) #9

Ah, gotcha! I’m using a toggle switch.

I just tried cutting the power at the breaker and replacing the switch. No Love. The app spins on this:


#10

Then unfortunately, most likely the switch itself has gone bad. How old is it? A fairly high percentage of the early model a GE switches do you fail about six months after they’re out of the warranty. This means they’re technically not “defective” but it’s still annoying. It’s not a super high percentage, maybe 15%, but it’s definitely more than some other more expensive brands.

Many people feel it still worth it because the GE switches can be 50% cheaper than other brands so even if you have to replace 10 or 15% of them into years you still save money overall. But it’s obviously very annoying.


(Ben) #11

It’s about 35 days old :rage:


#12

I’d exchange it for a new one, then. Annoying, but sometimes it’s the simplest answer.


(Ben) #13

Well, what an you do? It wouldn’t be so bad if there was a Lowes closer to my home…


(Ben) #14

Switch was replaced and works, so chalk it up to being one of the ~10% GE failure rate.

Pairing the GE switches is always such a pain. Every. Single. Time (using the St phone app).

I’ve been able to pair the GE in-wall toggle switch using both the "GE On/Off Paddle Switch (z-wave), and the “GE 3-way, in-wall on/Off Switch Kit”.

The latter is misleading in that there is a note at the bottom of the “Connect Now” page stating “Automatically turn a light on or off from two locations in your house - such as at the top and bottom of a staircase-or anywhere with your smartphone”.

This led me to believe that this is exclusively for a 3-way switch, when in fact it can be used for a single switch.

When you tap “Connect Now”, the switch is rarely found straight away. As mentioned by others, you turn on the switch for 5 seconds, and then off for 5 seconds. Wash, rinse, repeat. Wash rinse repeat…On occasion this works.

Sometimes it will find the switch, but you don’t know it until you completely back out of the “Connect Now” page to the “Marketplace”, where hopefully you’ll see “Device waiting for configuration”.

Other times I’ve completely closed the ST app and restarted it. Only then am I able to pair the switch.

For something that is on the ST approved list, it sure is a PITA to pair. It takes me less time to figure out the line/load/neutral/ground wires, throw the breaker after figuring out which one it actually is, remove the dumb switch, install the GE switch, and turn on the mains power than it does to pair the switch.