"Replace Device" Doesn't Work? Try this manual work-around


((Possibly not the Matt you're looking for)) #1

If you, like me, occasionally have had Z-wave devices drop off your network, you may have found that the “Replace Device” feature doesn’t seem to work.

Since some of the GE-Jasco Z-wave switches seem to be flaky, this seems to happen to me about once every other month. (On a separate note, I recommend paying the extra few dollars for Leviton switches. I have both GE/Jasco and Leviton and the latter are far more reliable.)

Anyway, some people have apparently had success using the Replace Device feature, but I’m not among them. This can be a hassle if you have a lot of programs assigned to the device. Removing them and reinstalling them is laborious. (One strategy for this has been described using the Z-wave exclusion function, but I’m not enthusiastic about that because on one occasion I managed to exclude a working device from my network instead, and doubled my problem.)

What do I do?

My work-around is to give the missing device a newly assigned address in the IDE. Basically, your device has become homeless on your network and it needs a new home. The solution is to re-add the device to your network as if it were an entirely new device, but then give the newly-assigned address to the old device profile, so your old device profile will have a new home on the network. I think this is how “Replace Device” is supposed to work.

This process hasn’t failed me yet, but I’ve only used it for Z-wave switches, so the usual disclaimer: your mileage may vary, no warranties, not legal advice, void where prohibited, keep from small children, do not ingest, etc. etc.

Steps:

  1. Access your account through the IDE at https://graph.api.smartthings.com/. Under “My Devices”, click on the malfunctioning device name.
  2. This takes you to the device attributes page. At the bottom of the page, select “Edit”
  3. Go to the Device Network ID and change it to any random value. (Imagine it is ‘12’, I usually change it to “12-OLD”. Scroll to the bottom of the page and hit “Update”.
  4. I now re-add the malfunctioning device to the network as if it were an entirely new device. Just follow the " + Add Thing " steps in the mobile app. (If I can’t get this to work, I now know I probably don’t have a Z-wave problem; I have a hardware failure.)
  5. Assuming it works, you now have added your device to the network. You can give it any random name – it doesn’t matter what, because you’ll be deleting this later. If you don’t name it, the app may name it something like “Generic Z-Wave Device.” Of course, the new device profile won’t have all the attributes and apps attached to it. How to fix that?
  6. Under “My Devices” Click on the name of the new device profile and scroll down to “Edit.” Take note of the Network ID, and then change it. Imagine it is ‘45’, I will edit it to “45-NEW”. Scroll to the bottom of the page and hit “Update.” (You’re doing this because two device profiles can’t refer to the same network ID address at the same time.)
  7. Go back to the Device profile page of the original device under “My Devices”, and select the ‘Edit’ button at the bottom of the page.
  8. Edit the original device profile Device Network ID to be the new device address. So, in my example, I’d replace “12-OLD” with 45. Scroll to the bottom of the page and hit “Update.”
  9. Go back to My Devices, and find your new, “Generic Z-Wave Device”, click on it, scroll to the bottom of the page, and hit “Delete.” Confirm the deletion, and now you’re back to normal.

Essentially, you’ve created a new address, assigned by the hub, for the old device profile. I imagine this is how the “Replace Device” is supposed to work, but you’re doing it manually.

If anyone has a faster way of doing this, suggestions welcome!


#2

It won’t work, unfortunately. The device address is assigned by the Z wave controller which is inside the SmartThings hub. The controller keeps track of and assigns all Z wave device IDs. It tells the devices what their network ID is.

The SmartThings ID allows you to change it there, but it’s not going to change what the controller and the individual devices have stored. So it will probably break something else eventually, but in any case it won’t let you use the same smartapps with the new device without going into the smart app and selecting the new device, which is the stuff that people are trying to avoid when they are using to replace.

Replace should work for a Z wave device. That is a utility provided by the third-party zwave protocol. It is actually an instruction to the Z wave controller, not just a superficial change.

If replace doesn’t work with an individual Z wave device , contact support, because that means the individual device you’re trying to use is defective and is not reporting properly to the hub.


((Possibly not the Matt you're looking for)) #3

Well, I just did this 5 minutes ago, for probably about the dozenth time, and in my experience it has always worked.

I don’t think anything in the process I’ve described contradicts what you’re saying here. The device (here, a switch) has been assigned a new Device ID by the Z-wave controller. What is being changed here is the software profile that is associated with the z-wave device.

EDIT: But I agree that “Replace” should work for a Z wave device. Unfortunately, my own experience and a search of the forums indicates that for many users, the app hangs on the “Checking Device Health…” step.


#4

You can’t get the Z wave controller inside the hub to change the IDs that it has for the various devices. And you can’t get the various devices to change the IDs they have stored internally. These two steps are what is a zwave replace will do.

Just changing it in the IDE may change some cloud label somewhere, but it won’t change how the zwave network internally refers to the device.

Have you tried running a Z wave repair utility after you manually changed the ID?


#5

If the device hangs on “checking device health,” it’s likely because there’s a communication problem between the hub and the device. Did you run a repair and check the error messages in the hub logging?


((Possibly not the Matt you're looking for)) #6

I have run Z wave repairs before and after following this process. I’ve never noticed any performance changes. The first time this happened, probably 2 years ago, I reviewed the hub logging while talking with support, but it was inconclusive. Eventually I arrived at the solution described above. (this was long before the “Replace Device” was rolled out.

To be clear, nothing here is changing the network ID that is assigned to any device. What is happening is that you’re causing to network to start internally referring to the lost device with a new address that the hub itself has assigned. All the user does it alter which “cloud label” is associated to that new device. You cause the hub assign the lost device a new address, and then you connect the ‘correct’ software profile to that newly-assigned address.


#7

That is very true for the earlier GE 4xxxx model numbered switches. The newer ones, GE models 12xxx (smaller LED), work perfectly so far.


((Possibly not the Matt you're looking for)) #8

good to know!


#9

Unfortunately the newer ones have also had a somewhat higher failure rate than other more expensive brands. It’s not super high, maybe 10 or 12% and it seems to usually happen about six months after they come out of warranty. This means they’re not technically “defective” since the warranty is over. This has nothing to do with SmartThings, you’ll find the same reports on other forums.

Because the GE switches are often much cheaper than other brands, many people feel it’s worth it even if they have to replace 10% of the switches after a couple of years; they still saved money overall.