Reoccurring Hub Issues (SOLID BLUE LED)


(DawgOnKing) #1

Well, this seems to be my last avenue to a solution.

I’ve got the original ST Hub and my home setup hasn’t changed since its purchase…

  • Motorola Modem
  • Netgear Router
  • ST Hub (only hard-wired device in my network)

Anyway, starting a few months ago my hub would simply disconnect randomly (SOLID BLUE LED). At first I assumed it was a software issue but that’s not the case. In the months since, the issue has become somewhat routine. The hub will work fine for a few weeks and then decide to take a week to 10 days off.

I’ve contacted ST support on three separate occasions and together we can’t find a solution. I’ve contacted my ISP and verified that no ports are being blocked on their end. SO…, before I send the hub in for testing by ST, any suggestions or similar issues from the community?

Thanks.


New hub setup and won't setup properly
(Jeff DeWolfe) #2

When stuff like this happens I always try to start with the most basic and sometimes stupid things. Can you try a different ethernet cable? How do you have the hub powered? Just wondering if it could be something like not enough power or something. Do you have it plugged directly into the Netgear Router?


(Cassidy) #3

Your situation may vary, but port forwarding of both TCP/UDP port 53 (DNS) looked to block communication from the SmartThings hub back to the SmartThings cloud and I was getting the same solid blue LED.

I originally opened up port 53 for my Xbox One as recommended by M$ and my ST hub went offline immediately following the reboot of my router. The ST hub came online again right after I disabled forwarding port 53.


Solid Blue light. Not getting ip from dhcp
(DawgOnKing) #4

@chevyman142000 - The hub has always had the same power source and I did swap out the ethernet cable. I also plugged the hub directly into the modem, to no avail. Thanks for the suggestions.

@nelemansc - I will look into your recommendation but I’m assuming that if another device in my home was causing issues (like the XB1 in your example), the hub would be offline continuously. As I mentioned, it online/offline periods are typically a week or more. During that time, the only other network devices are used on a daily basis (Chromecast, Apple TV).


(Bruce) #5

Sounds to me like a bad hub, not a connectivity problem.


(C Chen) #6

Does your hub somehow get the same local IP as another device on your network?

I recently got the solid blue led after a power outage (perhaps 5 minutes or so), and that seemed to be the cause though I am not really sure. By the time I noticed the ‘conflicting address’ warning message on my modem’s page, I have been plugging / unplugging various cables for a while.

In the end, what seemed to have solved the problem was powering down all three overnight.

The first night after my problem started, I simply disconnected my hub from my router for the night, but left the power to my hub on (because I didn’t want to deal with re-adding the devices). That didn’t help. So I powered everything off the second night. Next morning I powered the modem and the hub back on with the hub directly connected to the modem. The hub was able to connect to the cloud immediately. I then powered off my hub (for about a minute) and disconnected the hub from the modem, connected my router to modem, and hub to router, and turned hub back on. The hub again gave me solid blue led.

So I turned the hub off for an hour, it then was able to connect through the router.


(DawgOnKing) #7

@stepchen - thanks for response. I have tried connecting directly to the modem and I’ve power-started all three (modem/router/hub) countless times.

After reading your reply, I may try assigning a static IP address to the hub and see if that corrects the issue. Thanks.


(Ron S) #8

I am sure you have looked at what these lights mean…port 443?

https://support.smartthings.com/hc/en-us/articles/200882364-What-do-the-LED-colors-on-the-back-of-my-hub-mean-


(Mcvoss) #9

I had the same problem until one day it went offline, solid blue light, and it never came back. ST sent me a new hub and I never had a problem since.


(DawgOnKing) #10

@smart - yeah Ron, covered that with ST support team. Very few ports are restricted by my ISP and none locally on the network. Thanks though.

@mcvoss - yeah, I’m not sure ST will replace an original hub and I may end up purchasing v2.0 - FWIW, the hub came back online this morning. I’m leaving for a biz trip this week and will have to deal with the issue when I return at the end of the month. For now, I’m hoping I can an 80% reliability time out of the hub for the rest of the month. My wife is not happy when I’m gone and it’s offline. :-/


(Alyson Boote) #11

I just had this issue and your post was the answer I was looking for. I have a new router and followed Microsoft’s port forwarding rules for the Xbox One, and it disconnected my ST Hub. Thanks to you, all better now. :smile:


(Charles) #12

Same problem, v2 Hub. My brand new hub will not call home. It has a solid blue light (ip assigned, but no communication out). I tried bypassing the router completely by connecting it directly to the cable modem, where it shows a blinking blue light (no ip assigned).

All ST will tell me is “open ports 11111, 9443, 443, etc.” or “call your ISP”). From googling, it seems that the problem is likely port 443. The problem is that I’m out of my networking element when it comes to opening ports; is that the same as “port forwarding”? I need some basic guidance. I beg of you.


(Mike Maxwell) #13

Post up the model of your hub, I’m sure someone here can give you the steps required.


(Charles) #14

THANK YOU! My router is a TP-Link TL-R860


(Benji) #15

I seriously doubt it needs inbound ports opened like that, outbound, sure but 99% of the time everything is allowed outbound anyway, ESPECIALLY port 443 otherwise you wouldn’t be able to visit a LOT of websites…


(Charles) #16

That makes me feel better, because it wasn’t making a lot of sense. But, it still leaves me “up a creek”.

One more data point: I was confused that it had a blinking blue light when connected directly to the cable modem (why wouldn’t it get an ip address??). So, I reset everything and powered it all up and at least got to a solid blue when directly connected. I don’t think it helps diagnose my problem, but at least removes a spurious indicator.

Is it likely that the hub is defective? I’ve been poring through these boards for weeks now, and while not many v2 hubs have been received, I’ve seen no reports of defects.


(Benji) #17

Some good solid checks there and definitely need to be open to the possibility of faulty hardware.

Hmm… Just to verify:

Cable Modem --> Blue port on TL-R860 --> ST Hub plugged into one of the yellow ports correct?

Did you use the Ethernet cable that came with the ST hub (DOES it come with an Ethernet cable? I thought it did…)? Have you got anything else plugged into any of the other ports on the router? Perhaps trying power cycling everything and power up in the following order:

  1. Cable modem, wait until it has finished booting.
  2. Router, wait until it has finished booting.
  3. Verify you have Internet connectivity at this point with another device, wired into one of the yellow ports if possible.
  4. ST Hub

See where it goes from there. Have you set up or know of any changes to the router config that might differ from ‘normal’?


(Charles) #18

Thank you, Benji. Yes, the configuration is as you stated. The hub does come with a Cat-5e cable.

The router has one WAN (blue) and 8 LAN ports (yellow). I am using six LAN ports plus now a seventh for the ST. The others go to a separate gigabit switch and a couple of 802.11ac wireless routers (with DHCP off, so they are effectively switches).

Since the trouble, I moved the ST off one of the remote switches, using a long CAT-6 cable, to be directly connected to the TL-R860 with the short cable provided. I’ve gone through the following sequence several times:

  1. Power everything down
  2. Power up modem, router, ST (in sequence)
  3. ST blinks red, yellow, magenta (1-40 times), solid blue

While doing that, I have a PING going on a computer that shows when the network comes alive. That, plus another 4-6 devices are hitting the internet without issue.

I think the router is vanilla except for passwords. It has an ip of 192.168.1.1 and the DHCP range is 192.168.1.100 - 150. No port forwarding, DMZ, UPnP, static routes, etc.

Also, I have several times connected the ST directly to the Cable Modem and get a similar boot sequence, ending with solid blue.

Please send me any ideas; I’ll try anything.


(Benji) #19

Have you tried powering up the modem/router/ST in order with nothing else attached to the TL-R860?

Does the ST hub have the MAC address printed on the bottom? Can you absolutely verify it’s getting an IP address properly and can you ping the ST hub?

I just found this that verifies that that those ports are indeed outbound:

“This problem can occur when outbound traffic from a local network is being blocked. Double-check your network settings and make sure the following ports are open during initial setup: 11111, 9443, 443, and the NTP port (123)”


(Charles) #20

I did not isolate the ST as the only device on the TL-R860. However, I completely configured a new network to have only: 1) brand-new Trendnet TEW-811DRU router, 2) laptop, 3) ST hub.

This allowed me to see the MAC address (not on the unit), identify the ip and ping it. It pings reliably. The very first time, I got a brief magenta flash; other times no led response.

Does your investigation confirm that “open ports” is not my problem, or still may be?