[RELEASE] Zooz MultiRelay (ZEN16)

@thesmartesthouse @krlaframboise

A shout out to both of you for the amazing customer support regarding the ZooZ multi relay! This Device is one of the more powerful Zwave devices I have yet to find. It would have made for such an easier solution for few of my hardest to design Smart Home use cases so far and I am already looking forward to using it to replace some Fortrezz devices who just cant seem to be able to figure out how to design a Device Handler to work in the new App.

And after sitting on it for a day, for the people like myself who would disable one of the switches and use it as a contact sensor, WebCore does not even care what kind of a device it is looking at when using conditions built into Pistons. As far as I can tell It will work fine in any WebCore Piston to monitor as a contact sensor.

Once again, great product, great customer support and Kudo’s to both of you.

1 Like

Hi again. Just tried using the Zen16 in my garage using your Garage Door App. I am using the #2 relay as the actual open/close door relay and using the #1 switch to send on/off messages to the Hub which I have then created a virtual contact sensor in the IDE and used Webcore to link the virtual contact to #1 switch to use as the garage door contact sensor (which is already installed and tested. Works fine)

The problem is that using the new Smartthings App I tried using the Garage Door App to create a new device and it did not work. It goes through the entire process in the App - you can name your garage door, select your relay, select your contact switch, etc. At the end of it all it looks like a new garage door device was created within your Garage Door App, but when you go into the list of your devices it is not there.
I then tried to delete the garage door opener I had just created by clicking on “Remove all Garage Doors” in the front page of your App but that does not work. The only way to delete the garage door opener is to go one more layer into your App - into the garage door opener you created and click on the three dot menu at the top right. That did work to delete it.

I then went to the Classic App to see if I could create a device there from your App and it did not work as well. Though there is a banner that Smartthings put in the Classic App in the last few days that says “You can no longer edit or or create features from here”

Not sure if this is just a transition issue within the Smartthings migration to their new App or if some code needs to be tweaked on your side to get the Garage Door App working in the Smartthings new app but let me know.

Thank you,
Marc
.

Have you been able to create any garage door devices after programming them in the SmartApp or is that the first one?

As mentioned in the programming instructions, there needs to be a special device handler installed as well for the app to create a new opener device (this needs to be installed as a handler, on top of the existing custom handler for the ZEN16): https://raw.githubusercontent.com/krlaframboise/SmartThings/master/devicetypes/zooz/zooz-garage-door.src/zooz-garage-door.groovy

I agree with @TheSmartestHouse, it sounds like you don’t have the custom garage door handler installed, but if that’s not the problem then open Live Logging, attempt to create another door, and post the logging results.

And I cant believe you both expect your customers to follow directions. :roll_eyes: :grimacing:

My bad. All is good in the world. Everything works as expected and in the new ST App.

1 Like

It probably doesn’t help that the info on that SmartApp is buried in this topic instead of having its own…

@krlaframboise;
Thank you for your code. I have downloaded it, and published it. Then integrated the MultiRelay. In the Smartthings app (new version), only the Z-Wave Multichannel appears without sub-relays. I intended to use it to turn on and off some 12 volt lights. When I toggle it on/off from the Smartthings app, all three relays close/open. What am I doing wrong?
Thank you.
Pierre

The handler has to be published before the device is joined.

If the child devices don’t get created during inclusion then open up the settings screen in the mobile app and change a setting which will force the update method to execute.

The child devices won’t necessarily have the same name as the primary device because of the timing of their creation. If you open the parent device in the IDE you should see the names of the child devices near the bottom.

Kevin, I think I got it, I have two hubs in two different location (one at home and one on my boat), I publish it on my home location instead of the boat. Will remove the device, publish the handler, and re-add the device.
Thank you for your help.

1 Like