[RELEASE] zooZ Power Strip ZEN20

dth_misc

(Eric M) #1

I got one of these a few days ago and started working on a device handler. It is a pretty nifty device, with pretty bare bones operation. Not as many bells and whistles as the Aeon SmartStrip, but a great device.

Pairing was a little different. The manual mentions that you press "the" power button to pair, but doesn't mention which one. It is the button labeled "CH1". I had to press it on, off, on, off, etc until it paired.

This is an adapted version of my Aeon SmartStrip handler which was a heavily improved / modified version of the SmartThings github version. Some things that they didn't have in their handler are in this one as well.

  • All On/Off capability by pressing the main switch button in the SmartThings app.
  • Instant status reports when one of the five buttons is pressed on the strip itself.

Also, since SmartThings does not allow you to put anything but the first switch in automations and SmartApps, don't forget to use my Virtual / Physical device sync to make up for that gap!


How do I use a smart app to control Zooz Zen20 power strip channel?
Iris smart plug question
Extension lead with 4 to 6 zwave oulets that can be individually controlled
(Ron Talley) #2

Tried this DH out and either my device is broken or this is broken or I have a house full of z-wave and this z-wave plus device isn’t playing nice? Keeps loosing connection or something. Device looses updates and just stops working. Have to turn it off then back on.


(Eric M) #3

I haven't seen this with mine. How far is it from your hub? Sounds like it might be a network issue, but by your comment it seems like you may have a pretty robust network. Are there "repeating" devices that would provide a decent path for it back to the hub?


(Ron Talley) #4

I have all 33 devices that Alexa finds plus the ones that she doesn’t find like Blink cameras, and Ecobee 3s, DSC Alarm Panel and a couple of others. ALL of my devices have worked flawlessly thus far.

However, to the best of my knowledge, all of them are Z-Wave and Zigbee. I have no Z-Wave Plus devices outside of this one.

All of my network stuff is located in a storage closet and the room is opposite side of the hall way that the closet is in. In the room itself, I have 1 GE Socket, 1 GE Light Dimmer, 1 GE Fan Controller and and Ecobee Sensor. They all work flawlessly.

After giving up last night, just left it alone, opened up Smartthings this morning and it was working again. After clicking a couple of times, it stopped working again. LiveLog show an error but I am at work right now. Z-Wave Repair show Zooz failed to communicate.

I think I might have a bad PowerStrip.


(Ron Talley) #5

fb62f570-4f67-4159-bab4-409ce6bedb6f 2:54:30 PM: error java.lang.NumberFormatException: For input string: "null" @ line 1291
fb62f570-4f67-4159-bab4-409ce6bedb6f 2:54:30 PM: debug kill fix is: [["codenull",""],["codenull",""],["codenull",""],["codenull",""],["codenull",""],["codenull",""],["codenull",""],["codenull",""],["codenull",""],["codenull",""]]
f3b748ac-e88d-42f5-9bbe-ed87ba8b777f 2:54:30 PM: error java.lang.NumberFormatException: For input string: "null" @ line 608

70e548dc-5e0e-4f8c-9c27-3d1041950135 2:54:14 PM: debug Parse returned {{ linkText }} has left
e9b745ad-82ed-447c-886e-315c217d52a9 2:54:14 PM: debug Parse returned {{ linkText }} has arrived

??


(Ron Talley) #6

I tested another DTH.

https://raw.githubusercontent.com/robertvandervoort/SmartThings/master/zooZ-Strip-ZEN20/device_type-zooZ-strip-ZEN20_v1.0

The Virtual Switch App above is working perfectly but the PowerStrip itself is not reporting its status back to SmartThtings.

Now that I think about it, I am not sure if your DTH was receiving reports (signal) (updates?) from the PowerStrip.

i.e., if I press the blue button on the strip, then it should change the status in the app...it doesn't with the DTH I posted above. Going to test it with yours. This will let me know that there is something wrong with the PowerStrip itself.

Thanks for the Virtual Switch App! It is Key!


(Eric M) #7

My handler does support instant status updates from the power strip.

Just to clarify. The device works for a bit and then stops. The error message you posted is from when the device stops working? The errors you posted are strange as they reference line numbers that do not exist in my handler (1291, 608).


(Ron Talley) #8

After setting this to the side for a week or so, I have come back to it. Going to return this Strip and get another one. I believe that something is wrong with the switch itself. Whenever I use a generic multi-channel switch or just switch, it works for hours, however, anytime I try to set it up with your code, then it works for a couple of pushes then stops.


(Taylor Warnick) #9

Complete Newbie here. I have the smarthings hub and have connected this powerstrip just using the default connection option through the iPhone app. I'm only able to control CH1. How do i install your smart app so I can get all the various outlets to showup in my app and control individually?


(Ron Talley) #10

SmartThings uses certain terminology that you must familiarize yourself with in order for you to understand how "things" work.

Things are Devices (physical stuff that you can put your hand on)

Devices needs a "controller", "drivers", "handler" in order for ST to know what it is. These are called, Device Handlers (DH), Device Type Handlers (DTH) here in the ST Community.

Finally, you have Smart Apps. These are the applications, that make the devices do what you want them to do.

These are accessed on the SmartThings IDE or Graph Page:
https://graph.api.smartthings.com/

So you would goto that page, log in, select your location, then goto device handlers, then goto create devices handler, then from code, then copy the raw data posted above, click publish and save.

Then goto the device page in the IDE, then select your device, then click edit, then change the device handler to the one above, it would be located at the bottom as you scroll down.

Then you will need the sync app. Now you should be a little familiar with how to add stuff. You will need to install both the handlers and the app.

It's a learning curve but you'll get it.


#11

Hi Taylor,

We posted complete instructions with screenshots on how to install custom device handlers on SmartThings here:

http://www.thesmartesthouse.com/blogs/the-smartest-blog/how-to-install-a-custom-device-handler-in-smartthings

The only thing you need to change is the device you click on (the ZEN20 instead of the ZSE40) and the code since our instructions refer to a different product. Let us know if you have any questions!


(Taylor Warnick) #12

Thanks for the support. I've got this strip up and running!


#13

Where do I find your Virtual/Physcial Device. I am new to this stuff.


#14

Found it by word search...............thanks.


(Frank) #15

Eric, I just got my power strip on friday. Have installed the your handler, and the sync app. But I am experiencing some inconstancy with the switching of power. I am just using the simulated switch , not energy monitor or dimmer.

Any ideas on how to trouble shoot.


#16

I had the same problem. It was incredibly inconsistent, the master switch never worked, and when the individual switches did work, there was a ridiculous delay and at one point all stopped working. I deleted the device, DTH, smartapp and re-added them and as I was doing so I couldn't remember actually pairing the power strip with ST the first time. I think I just manually created it in the IDE. I'm not sure though, as I've done so much at this point, and I don't think it would have even worked at all without pairing it. However, I went through the setup again, making sure I paired it this time and it's been working flawlessly ever since. Master switch and all.


(Phillip Slaughter) #17

I've just ordered one of these, but I've not used any devices that need custom drivers before, so I may need help when it arrives.

How does this strip compare with the Aeon Labs one? Do they both support the same functions, including energy monitoring?

Looking forward to getting into this & learning more about custom programming.

Thanks,

Phil


(Frank) #18

I never deleted the device and unpaired it, I did a zwave repair after removing the smartapp and the virutal devices. Tested with the device handler and it seem to work ok, then I put the smart app back on. It seems ok now.


(Tim Lin) #19

I just purchased this power strip, and tried following all the steps to pair it (put it close to the hub, clicked the ch1 button repeatedly while in inclusion mode). Nothing seems to work. My hub will not detect it. I've power cycled the hub several times, and even did the factory reset on the power strip. Nothing. Any thoughts or help with this? I was really looking forward to using this power strip...

Tim


(Bob Romero) #20

I had a Similar experience. Did you install the DTH first?