SmartThings Community

[RELEASE] TCP Connected bulbs work with SmartThings Again!

The connect app is the manager who discover the lights and allows to add them to SmartThings.

Read the first post.

Still working stable, I just have 5 lights working and the response is fast, please tell me your experience with other setups.

@What_the_f What its your experience with 35 bulbs working in long term?

cant seem to get this to work.

I have a Netgear R6700v2 router

my tcp hub ip is 10.0.0.3

In the router i’ve set block on services for ip 10.0.0.3 tcp/udp for port range 1-65535

I’ve added blocked sites:
greenwavereality. eu
greenwavereality. com
update.greenwavereality. com
update.greenwavereality. eu
(without the space after . )

I’ve blocked access control to ip: 10.0.0.3

followed the doc to update the firmware (which worked exactly as specified)

however in the smart things app i get “tcp gateway is not responding”

live log just shows “state.loadStatus Loading”

You no need to block ports in the TCP hub ip, you need to block just internet access

If you block the ports, ST can not access to TCP hub

I tried removing the port and still not finding my bulbs :frowning:

Do you need to have a Smarthings Hub/Gateway to use the TCP lights with Alexa?

Is there any step by step guide starting with how to downgrade the TCP hub firmware?

Thank you very much!

Yes, you need the SmartThings hub and TCP hub to use the lights with Alexa.

https://github.com/bren1818/TCPFirmwareRestore/blob/master/Instructions.docx

sorry for the long reply :slight_smile:
virgin hub v3
any help much appreciated :slight_smile:

Hi, i do the donwgrade, but how do I do the rest? device handler and app connect. Some guide or manual? Thanks.

If you dont know how to install the connect and the device code I suggest you to read

Thanks, i read the faq and i have the app in the phone, but hub not donwgrade de firmware. I do the instruccions 3 times and nothing dont work, in the phone tcp app appears 3.0.80.

Please help.

Hi. I have downgrade some gateways with the instructions , after downgrade, remember to block internet access to avoid the hub upgrade again.

Try, try, try and nothing, in the dns this:
CNAME-record for update.greenwavereality.eu = d3k0oqko7onde3.cloudfront.net
and all work fine but not load the firmaware.

I block de d3k0oqko7onde3.cloudfront.net,
it seems to work , but the tcp app in the phone does not connect with the bridge.

I have the firmware 3.0.80

Where can I find the original TCP app? Google Play shows lots of apps when I search for “TCP Lighting” or “TCP Lighting App,” none of which appear to be affiliated with TCP.

The app is kinda dead now, too. Even if you get the APK, I still had it die and no longer work with my hub. Thankfully, this: https://github.com/bren1818/TCPLightingWebInterface/wiki

Hi. I have ios and it´s working fine, no problem to setup new gateway, sorry I have not android.

Am I right when I guess that this needs a Smart App and only works with the Smartthings Classic app?

I swear, I thought it used to work but now when I try to control the lights, I get an error from the new app saying it can’t connect to the device. The classic app works just fine.

I find that everything works great until I want to add a new TCP bulb, then I basically blow everything up and have to start from scratch.

The logs aren’t much help… “physicalgraph.exception.ConflictException: Device still in use. Remove from any SmartApps or Dashboards, then try again @line -1 (doCall)”

Um… PC_LOADLETTER??

OK, so I figured this out. Edit the Smart App and look for line 152:

removeChildDevices(delete)

comment that line out by putting // in front of it, and save & publish. You can now add new bulbs.

I’m sure I am screwing something up but it is working so I am not digging any deeper.

1 Like

Hi,

My app has never stopped working controlling my lights in house via WiFi. But does this change allow you to have the internet ability back?

Thank you.